boot-repair does not detect internet connection when proxy

Bug #1316424 reported by Saurabh Rindani
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fix Released

Bug Description

I tried running boot-repair on a system running Ubuntu 14.04. I get a message asking me to connect to the internet. All the while internet IS connected (for example, I can use Firefox etc.), but boot-repair does not seem to detect it.

I have to connect to the internet through a proxy-server, and I tried the two combinations 1. setting network proxy and asking Firefox to use system proxy, 2. setting no proxy for the network with Firefox connecting through manual proxy. Neither of them worked.

*************** Workaround:

Revision history for this message
Saurabh Rindani (saurabh-prl) wrote :

After reporting the bug, I found the reason why internet connection was not detected by boot-repair: The proxy had to be set differently. I had been using "Network" under "System settings" to set the proxy. However, I discovered Question #242493, whose answer said that one has to first login as root:

1. In a terminal, type “sudo su –“
2. Then type “export http_proxy=…”
3. Then type “/usr/bin/boot-repair”

In case of proxy requiring username:password authorization:

( export http_proxy=http://username:<email address hidden>:port ).

For me (using bash shell), this did not work. On the other hand, the following worked:

sudo su -
HTTP_PROXY=http://username:<email address hidden>:port
export http_proxy

That the proxy was set could be checked using the command:
env |grep http_proxy

Revision history for this message
YannUbuntu (yannubuntu) wrote :

Thanks Saurabh. Added your alternative procedure to Question #242493 ( )

summary: - boot-repair does not detect existing internet connection
+ boot-repair does not detect internet connection when proxy
Changed in boot-repair:
status: New → Triaged
importance: Undecided → Low
description: updated
Revision history for this message
YannUbuntu (yannubuntu) wrote :

Should be fixed since 4ppa44.

Changed in boot-repair:
status: Triaged → Fix Committed
YannUbuntu (yannubuntu)
Changed in boot-repair:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.