Mawk 1.3.3 is buggy, it should be updated with new upstream version

Bug #1005077 reported by Mantas Kriaučiūnas on 2012-05-27
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Boot-Repair
Wishlist
Unassigned
Mawk
New
Unknown

Bug Description

Why boot-repair recommends gawk package, isn't standart mawk (which is included into Ubuntu CD as default) not enough?
Mawk package description says, that "Mawk is smaller and much faster than gawk" :)
Please recommend "mawk | gawk" package instead of only gawk.

EDIT: Mawk 1.3.3 is too buggy to be used by Boot-Repair. Debian should update Mawk with upstream version. ( http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=554167 )

YannUbuntu (yannubuntu) wrote :

Thanks for the suggestion. I will discuss this with upstream (gawk is used by Boot-Info-Script) and come back to you ASAP.

Changed in boot-repair:
importance: Undecided → Wishlist
YannUbuntu (yannubuntu) wrote :

According to Gert (BootInfoScript maintainer), Gawk is currently needed instead of Mawk because the current version of Mawk (1.3.3) is buggy.
Many bugs of Mawk are fixed in a new upstream version, but the Debian maintainer does not want to update for an obscure reason.
We need to push here: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=554167

summary: - Recommend mawk|gawk package instead of only gawk - mawk is included in
- Ubuntu CD as default
+ Mawk 1.3.3 is buggy, it should be updated with new upstream version
Changed in boot-repair:
status: New → Triaged
description: updated
Changed in mawk:
status: Unknown → New
YannUbuntu (yannubuntu) on 2012-07-05
Changed in boot-repair:
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.