Membership operations don't have the same precedence

Bug #399770 reported by Gustavo Narea on 2009-07-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Booleano
High
Gustavo Narea

Bug Description

"Belongs to" and "is subset of" operations must have the same precedence, not only because that's the way it is mathematically, but also because it'd make the parser run slightly faster.

Right now "belongs to" has a higher precedence.

Related branches

Gustavo Narea (gnarea) wrote :

Actually it's undesirable to have both operators in the same precedence for practical reasons: One may want to change the arrangement of *one* these operations (e.g., "<set> contains <element>" and "<super-set> expands <sub-set>", instead of the traditional "<element> in <set>" and "<sub-set> is subset of <super-set>), which wouldn't be possible (it'd be changed in both operations).

Changed in booleano:
importance: Critical → Undecided
status: Confirmed → Invalid
Gustavo Narea (gnarea) wrote :

OK, well, I changed my mind once again and I'm reopening this.

The reason is that the arrangement issue will be solved thanks to the following blueprint:
https://blueprints.launchpad.net/booleano/+spec/fully-customizable-operations

Changed in booleano:
importance: Undecided → High
status: Invalid → Confirmed
Gustavo Narea (gnarea) on 2009-07-15
Changed in booleano:
status: Confirmed → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers