Internet Archive BookReader

protect use of $ to avoid conflicts with other JS libraries

Reported by mangtronix on 2011-04-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Internet Archive BookReader
High
mangtronix

Bug Description

From github issues:
https://github.com/openlibrary/bookreader/issues/5

shenzhuxi opened this issue February 03, 2011
JavaScript should be compatible with other libraries than jQuery
No milestone No one is assigned
Edit
I'm working on http://drupal.org/project/fileviewer
And I think this should be considered in bookreader's codes.

http://drupal.org/update/modules/6/7#javascript_compatibility
Javascript should be made compatible with other libraries than jQuery by adding a small wrapper around your existing code:
(function ($) {
// Original JavaScript code.
})(jQuery);

mangtronix (mang) on 2011-04-22
Changed in bookreader:
importance: Undecided → Medium
status: New → Confirmed
shenzhuxi (shenzhuxi) wrote :
mangtronix (mang) on 2011-08-22
Changed in bookreader:
assignee: nobody → mangtronix (mang)
importance: Medium → High
milestone: none → codesprint
mangtronix (mang) on 2011-08-31
Changed in bookreader:
status: Confirmed → Triaged
mangtronix (mang) on 2011-09-07
Changed in bookreader:
milestone: codesprint → cleanup
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers