Comment 25 for bug 1490347

Roger Lawhorn (rll-m) wrote :

UPDATE:

I created my own bluez 5.43 unsigned packages and installed them.
The issue is still present.

Here are the steps I took:

It was suggested that bluez 5.4 fixes the issue. However, that package is not available for ubuntu 16.04. I was able to build my own unsigned and upgradable package using the following steps and I have bluez 5.43. Still does not connect though.

sudo apt-get install debhelper devscripts dh-autoreconf flex bison libdbus-glib-1-dev libglib2.0-dev libcap-ng-dev libudev-dev libreadline-dev libical-dev check dh-systemd libebook1.2-dev

wget https://launchpad.net/ubuntu/+archive/primary/+files/bluez_5.43.orig.tar.xz
wget https://launchpad.net/ubuntu/+archive/primary/+files/bluez_5.43-0ubuntu1.debian.tar.xz
wget https://launchpad.net/ubuntu/+archive/primary/+files/bluez_5.43-0ubuntu1.dsc

tar xf bluez_5.43.orig.tar.xz
cd bluez-5.43
tar xf ../bluez_5.43-0ubuntu1.debian.tar.xz
debchange --local=~lorenzen 'Backport to Xenial'
debuild -b -j4 -us -uc
cd ..
sudo dpkg -i *.deb