Comment 24 for bug 1490347

Roger Lawhorn (rll-m) wrote :

Same here.

Linux Mint 18.1 64bit Cinnamon Desktop (ubuntu 16.04), Bluetoothctl v5.37.

After I wrote the below forum post I also implemented this udev change which helped somewhat as I have an onboard bluetooth that I wanted to disable after buying a "csr 4.0" usb dongle off of ebay. The GUI worked better, but still no pair:

>sudo gedit /etc/udev/rules.d/81-bluetooth-hci.rules
SUBSYSTEM=="usb", ATTRS{idVendor}=="0cf3", ATTRS{idProduct}=="3004", ATTR{authorized}="0"

Here is the article I posted in a facebook forum with all the gory details:

Been unable to use bluetooth for many years and many laptops. Bought a CSR v4.0 dongle off of ebay.
>lsusb Bus 003 Device 011: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

Even worse results.

In bluetoothctl (skipping the GUI):
[bluetooth]# list
Controller 00:1A:7D:DA:71:13 GT70-2PE #1 [default]
Controller 48:5A:B6:19:7F:30 GT70-2PE

#1 is the usb dongle I bought.
The other is the built-in Atheros in the laptop.

[bluetooth]# power on
Changing power on succeeded

[bluetooth]# scan on
Discovery started
[CHG] Controller 00:1A:7D:DA:71:13 Discovering: yes
[CHG] Device 48:5A:B6:19:7F:30 RSSI: -64
[CHG] Device 00:07:62:18:3D:C5 RSSI: -51

[bluetooth]# info 00:07:62:18:3D:C5
Device 00:07:62:18:3D:C5
Name: iMT525
Alias: iMT525
Class: 0x240404
Icon: audio-card
Paired: no
Trusted: no
Blocked: no
Connected: no
LegacyPairing: yes
RSSI: -51

I am trying to connect to the iMT525 speaker phone by Altec Lansing.

[bluetooth]# pair 00:07:62:18:3D:C5
Attempting to pair with 00:07:62:18:3D:C5
[CHG] Device 00:07:62:18:3D:C5 Connected: yes
Failed to pair: org.bluez.Error.AuthenticationRejected
[CHG] Device 00:07:62:18:3D:C5 Connected: no

Cannot pair though the default pair code is 0000 for a sound device.

Any ideas?