Daily kernel Oops kills keyboard

Bug #269322 reported by Izzy
Affects Status Importance Assigned to Milestone
linux (Ubuntu)

Bug Description

Binary package hint: linux-image-generic

The following problem started with kernel 2.6.26-20 and still persists with 2.6.26-21 on (K)Ubuntu Hardy 8.04.1, both installed via apt from the official "proposed" repository (currently linux-image-generic

Returning to my desktop in the morning, I'm not able to unlock it: While the system still runs, everything works - but the keyboard is dead. No input possible. Logging in remotely via SSH is still possible, so I was able to capture the dmesg ringbuffer (see attachment: crash.log).

What I tried to avoid a reboot:
* disconnected keyboard (PS2) and reconnected it
* disconnected keyboard (PS2) and connected another one (PS2,USB)
* switched completely to USB keyboard, on crash tried rmmod usbhid && rmmod hid && modprobe usbhid

None of these revived the keyboard, since it was the code built into the kernel that crashed. Since according to the log Bluetooth was involved (BlueProximity was running to be able to [un]lock desktop with my phone, which only worked occasionally), I now closed BlueProximity and removed the BT stick to see whether that helps. Will report results then.

As the summary says, these Oopses happen almost daily - but there have been a few days they didn't occur. So I will leave BT off for at least a week or until the next Oops, whatever happens first, and update this bug with the results then.

PS: I tried to switch back to the latest "stable" version ( from hardy-security), but when I booted that the graphic srewed up: It could no longer handle the nvidia card, though the suitable linux-restricted-modules are installed. I would be happy to get rid of the "proposed" repo stuff (it's only in there since the Wiki said it's needed for dist-upgrade from gutsy), so advices for this are also welcome.

Revision history for this message
Izzy (izzy-qumran) wrote :
Revision history for this message
Izzy (izzy-qumran) wrote :
Revision history for this message
Izzy (izzy-qumran) wrote :

As I wrote above, I closed all BT apps and even removed the Bluetooth stick to check whether Bluetooth may be the cause. Now, 7 days later, it looks like I can approve this: Since I've done so, no more Oops appeared, and the keyboard is still working fine - so the bug must have to do with Bluetooth.

Would be nice if somebody can confirm this - I'm not in kernel development at all, so I don't know where and what to look for.

Revision history for this message
Vik (vik-catalyst) wrote :

I am also experiencing this problem, using:

Linux kereru 2.6.24-21-generic #1 SMP Mon Aug 25 17:32:09 UTC 2008 i686 GNU/Linux

I have upgraded to latest current kubuntu hardy 8.04, and run KDE on a 2GB Aspire 9300 laptop. The system, Bluetooth included, otherwise operates normally.

If blueproximity is running with bluetooth enabled, I have the same symptoms as Izzy. Again, it did not happen the first day I used blueproximity, but after a few days it became bad enough for me to have to disable it.

I can run bluetooth, or blueproximity. A combination of both will crash my PC with the keyboard inoperative several times a day. The mouse continues to work.

I found I could still create keyboard input using the kvkbd program, which allowed me to try killing off X processes. Even if I killed X right off, and returned to a CRT console I could still not enter data on the real keyboard.

I have attached a complete dmesg output from boot to crash.

Vik :v)

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

[This is an automated message. Apologies if it has reached you inappropriately.]

This bug was reported against the linux-meta package when it likely should have been reported against the linux package instead. We are automatically transitioning this to the linux kernel package so that the appropriate teams are notified and made aware of this issue. Thanks.

affects: linux-meta (Ubuntu) → linux (Ubuntu)
Revision history for this message
kernel-janitor (kernel-janitor) wrote :

Hi Izzy,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/ . Please then run following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 269322

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Revision history for this message
Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Invalid
Revision history for this message
Lars Friedrichs (l-friedrichs) wrote :

Could someone please check if this is still a problem with the newest version of Kubuntu?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers