Comment 7 for bug 458091

Uwe Koch (uwe-koch) wrote :

Hi Valmantas, seems to be a common cause on 32 bit distros. I installed the same package on another 32 bit PC, running the same software configuration and the behaviour was the same. Output:

uwe@bulling-vlp01:~$ killall blueman-applet
uwe@bulling-vlp01:~$ blueman-applet
Loading configuration plugins
Using gconf config backend
Using gconf config backend
_________
Load (/usr/bin/blueman-applet:117)
['NMDUNSupport', 'AuthAgent', 'DhcpClient', 'RecentConns', 'NetUsage', 'KillSwitch', 'PulseAudio', 'Networking', 'StandardItems', 'NMMonitor', 'DiscvManager', 'TransferService', 'PPPSupport', 'Menu', 'StatusIcon', 'NMIntegration', 'Indicator', 'NMPANSupport', 'Headset', 'SerialManager', 'PowerManager', 'DBusService']
_________
__load_plugin (/usr/bin/blueman-applet:182)
loading <class 'blueman.plugins.applet.Headset.Headset'>
Using gconf config backend
_________
__load_plugin (/usr/bin/blueman-applet:182)
loading <class 'blueman.plugins.applet.StatusIcon.StatusIcon'>
/usr/lib/python2.6/dist-packages/blueman/plugins/applet/StatusIcon.py:91: GtkWarning: /build/buildd/gtk+2.0-2.16.1/gtk/gtkstatusicon.c:1030: invalid property id 15 for "tooltip-markup" of type `GParamString' in `GtkStatusIcon'
  self.props.tooltip_markup = s[:-1]
_________
__load_plugin (/usr/bin/blueman-applet:182)
loading <class 'blueman.plugins.applet.Menu.Menu'>
_________
__load_plugin (/usr/bin/blueman-applet:182)
loading <class 'blueman.plugins.applet.PowerManager.PowerManager'>
_________
__setattr__ (/usr/lib/python2.6/dist-packages/blueman/plugins/applet/PowerManager.py:113)
bt_off False
_________
__setattr__ (/usr/lib/python2.6/dist-packages/blueman/plugins/applet/PowerManager.py:113)
manager state None
_________
__load_plugin (/usr/bin/blueman-applet:182)
loading <class 'blueman.plugins.applet.Indicator.Indicator'>
_________
__load_plugin (/usr/bin/blueman-applet:182)
loading <class 'blueman.plugins.applet.Networking.Networking'>
Using gconf config backend
_________
load_nap_settings (/usr/lib/python2.6/dist-packages/blueman/plugins/applet/Networking.py:47)
Loading NAP settings
_________
__load_plugin (/usr/bin/blueman-applet:182)
loading <class 'blueman.plugins.applet.DBusService.DBusService'>
_________
__load_plugin (/usr/bin/blueman-applet:182)
Not loading NMDUNSupport because it's conflict has higher priority
_________
__load_plugin (/usr/bin/blueman-applet:182)
Not loading PPPSupport because it's conflict has higher priority
_________
__load_plugin (/usr/bin/blueman-applet:182)
loading <class 'blueman.plugins.applet.NMMonitor.NMMonitor'>
_________
__load_plugin (/usr/bin/blueman-applet:182)
loading <class 'blueman.plugins.applet.PulseAudio.PulseAudio'>
Using gconf config backend
_________
pa_context_event (/usr/lib/python2.6/dist-packages/blueman/main/PulseAudioUtils.py:115)
1
_________
on_load (/usr/lib/python2.6/dist-packages/blueman/plugins/applet/PulseAudio.py:96)
PulseAudio version: 0.9.14
Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/blueman/plugins/AppletPlugin.py", line 105, in _load
    self.on_load(applet)
  File "/usr/lib/python2.6/dist-packages/blueman/plugins/applet/PulseAudio.py", line 116, in on_load
    raise Exception("PulseAudio too old, required 0.9.15 or higher")
Exception: PulseAudio too old, required 0.9.15 or higher
_________
__load_plugin (/usr/bin/blueman-applet:182)
Failed to load PulseAudio
PulseAudio too old, required 0.9.15 or higher
Deleting plugin instance <blueman.plugins.applet.PulseAudio.PulseAudio object at 0x90acc6c>
_________
__del__ (/usr/lib/python2.6/dist-packages/blueman/main/PulseAudioUtils.py:350)
Destroying PulseAudioUtils instance
_________
pa_context_event (/usr/lib/python2.6/dist-packages/blueman/main/PulseAudioUtils.py:115)
6
_________
__load_plugin (/usr/bin/blueman-applet:182)
loading <class 'blueman.plugins.applet.AuthAgent.AuthAgent'>
_________
__load_plugin (/usr/bin/blueman-applet:182)
loading <class 'blueman.plugins.applet.NMIntegration.NMIntegration'>
_________
__load_plugin (/usr/bin/blueman-applet:182)
Not loading DhcpClient because it's conflict has higher priority
_________
__load_plugin (/usr/bin/blueman-applet:182)
loading <class 'blueman.plugins.applet.SerialManager.SerialManager'>
_________
__load_plugin (/usr/bin/blueman-applet:182)
loading <class 'blueman.plugins.applet.TransferService.TransferService'>
_________
__load_plugin (/usr/bin/blueman-applet:182)
loading <class 'blueman.plugins.applet.DiscvManager.DiscvManager'>
Using gconf config backend
_________
update_menuitems (/usr/lib/python2.6/dist-packages/blueman/plugins/applet/DiscvManager.py:132)
warning: Adapter is None
_________
__load_plugin (/usr/bin/blueman-applet:182)
loading <class 'blueman.plugins.applet.RecentConns.RecentConns'>
Using gconf config backend
_________
__load_plugin (/usr/bin/blueman-applet:182)
loading <class 'blueman.plugins.applet.StandardItems.StandardItems'>
_________
change_sensitivity (/usr/lib/python2.6/dist-packages/blueman/plugins/applet/StandardItems.py:90)
False True
_________
on_dbus_name_owner_change (/usr/bin/blueman-applet:341)
org.bluez owner changed to
_________
update_menuitems (/usr/lib/python2.6/dist-packages/blueman/plugins/applet/DiscvManager.py:132)
warning: Adapter is None
_________
change_sensitivity (/usr/lib/python2.6/dist-packages/blueman/plugins/applet/StandardItems.py:90)
False True

In either case, the command line does not return to the prompt.