'uinput' module not loaded automatically for avrcp support

Bug #439166 reported by Nate Carlson on 2009-09-30
56
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Blueman
Confirmed
Undecided
Unassigned
bluez (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I have a set of a2dp headphones (Motorola S305's); in Karmic, they worked automatically in Pulseaudio/Blueman, except for the AVRCP buttons. I saw the following error in the system logs:

Sep 30 00:56:21 knight bluetoothd[28988]: AVRCP: failed to init uinput for 00:0D:FD:2C:9F:CF

A bit of searching turned up that I needed to load the 'uinput' kernel module; after doing that, the buttons work perfectly.

I'm guessing this should be auto-loaded so that users don't have to figure this out?

Changed in blueman:
status: New → Confirmed
Jeremy Foshee (jeremyfoshee) wrote :

Hi Nate,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 439166

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Mano (m-launchpad-storin) wrote :

have same problem in lucid (other headset)
how can I help (I don't like to do modprobe uinput) which then works.

I can't do "apport-collect -p linux 439166"

Mano

fx5 (packaging) wrote :

I tried this with ubuntu 10.04 and i have to "modprobe uinput" before connecting the bluetooth headset in order to get the buttons working. So... yes, the problem is still there.

Same here! Running Ubuntu 10.04, using the deafult gnome-bluetooth software. Have to do "modprobe uinput" every time.

fx5 (packaging) wrote :

As a workaround you can also add "uinput" to your "/etc/modules" file.

Thanx for the workaround! Although it would be best if this module would be loaded on startup by default, so that headset buttons would work out of the box and inexperienced users wouldn't have to spend time looking for a solution for the problem.

This is reported against an old version of Ubuntu and many things has changed since then. Because of that we won't fix this issue however if this behavior repeats on a modern version please fill a bug report against it and we will take it from there.

Changed in bluez (Ubuntu):
status: New → Invalid
Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers