0.7.0 beta bug: only one option per clear honored

Bug #451244 reported by Daniel Riedemann on 2009-10-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
BleachBit
Critical
Andrew Ziem

Bug Description

Arch Linux, KDE 4.3.2, Kernel 2.6.31.4, Python 2.6.3
###

The Firefox cleaner doesn't work anymore. It just does nothing, I've checked if just nothing is displayed or if it does nothing - and sadly it really does nothing :-(
But it correctly detects if firefox is running at the moment :o)

Output on the console, if I click on preview:
debug: clean_operation('firefox'), options = '['cache', 'cookies', 'download_history', 'forms', 'passwords', 'session_restore', 'url_history', 'vacuum']'
debug: deepscans= {}
debug: searches= {}

Nothing is shown in the preview list for firefox.

Output when I click on delete:
debug: clean_operation('firefox'), options = '['cache', 'cookies', 'download_history', 'forms', 'passwords', 'session_restore', 'url_history', 'vacuum']'
debug: deepscans= {}
debug: searches= {}

Again nothing is shown in right list.

Regards

Tags: bug Edit Tag help
Andrew Ziem (ahziem1) wrote :

That's strange: it works here. If you have SVN checked out, in a terminal could you run the command 'make tests' in the same directory as bleachbit.py? That could help isolate the error more quickly.

If that doesn't find it, do you happen to know where I could find an Arch Linux virtual machine for VMWare or VirtualBox like there are here http://www.thoughtpolice.co.uk/vmware/ for other distro's?

Daniel Riedemann (darie) wrote :

I have updated to svn version 1311. I attached the output of make tests in a separate file.
As far as I know there isn't something like a Virtualbox or VMware image with Arch Linux because that would just be nonsense. Arch Linux is a rolling release distribution so at the moment you create the image it is already outdated. So it would be faster if you install Arch in Virtualbox/VMware by yourself...

I know that doesn't really help you, so just say me what to do. :)

I think it's the following line at make tests that is of interest: "Unit test for Cleaner.add_action() ... FAIL"

Andrew Ziem (ahziem1) wrote :

> So it would be faster if you install Arch in Virtualbox/VMware by yourself...

My machine is 5 years old, and the virtualized HDD is really slow during the install process. Hopefully we can figure this out another way. :)

> I think it's the following line at make tests that is of interest: "Unit test for Cleaner.add_action() ... FAIL"

Yes. I just updated the test to be more verbose in SVN 1312. This test makes some assumptions that may not be true on Arch Linux. Could you try again like this?

$ svn update
$ python bleachbit/Cleaner.py

Daniel Riedemann (darie) wrote :

Please see the attachment Cleaner_1312.txt :-)
Do you look for programs in /sbin or /bin ? Under Arch Linux everything is installed under /usr/... except the base tools like cat, rm, ls, tar, mount, umount, mkfs, and so on ...

BleachBit for instance is installed with "make prefix=/usr install"

Andrew Ziem (ahziem1) wrote :

The /sbin/ assumption is just for a test. Try SVN 1315 (assumption changed to /usr/sbin/).

Are the base tools in /bin/ ?

Daniel Riedemann (darie) wrote :

Again, please see the attachment :-)
I attached also an ls output for /bin and /sbin for you?field.comment=Again, please see the attachment :-)
I attached also an ls output for /bin and /sbin for you?field.comment=Again, please see the attachment :-)
I attached also an ls output for /bin and /sbin for you

Daniel Riedemann (darie) wrote :

OMG? I clicked to often on "add attachment" here because nothing happend...
###
Again, please see the attachment :-)
I attached also an ls output for /bin and /sbin for you

Daniel Riedemann (darie) wrote :
Daniel Riedemann (darie) wrote :
Andrew Ziem (ahziem1) wrote :

Sorry for the "back and forth." Now that the Cleaner.py passes, could you rerun all the tests with 'make tests'? Also could you run 'find ~/.mozilla | grep sqlite'?

Also you may want to set the environment variable LANG like 'LANG=de_DE'.

Andrew Ziem (ahziem1) wrote :

I ran all the tests successfully here on Arch Linux with the latest BleachBit SVN code. Later I'll try installing Firefox. You could check the environment variables LANG and HOME are set.

Daniel Riedemann (darie) wrote :

SVN revision 1324:

# echo $HOME
/home/daniel

# echo $LANG
de_DE.utf8

make tests: ERROR: Unit test for class bytes_to_human (--> attachment)

Daniel Riedemann (darie) wrote :

Oh yes, I have two firefox profiles.. but one was just for testing purposes. I hope that's not a problem?

# find ~/.mozilla | grep sqlite
/home/daniel/.mozilla/firefox/j3i5hurh.default/cookies.sqlite
/home/daniel/.mozilla/firefox/j3i5hurh.default/search.sqlite
/home/daniel/.mozilla/firefox/j3i5hurh.default/places.sqlite
/home/daniel/.mozilla/firefox/j3i5hurh.default/permissions.sqlite
/home/daniel/.mozilla/firefox/j3i5hurh.default/urlclassifier3.sqlite
/home/daniel/.mozilla/firefox/j3i5hurh.default/downloads.sqlite
/home/daniel/.mozilla/firefox/j3i5hurh.default/signons.sqlite
/home/daniel/.mozilla/firefox/j3i5hurh.default/formhistory.sqlite
/home/daniel/.mozilla/firefox/j3i5hurh.default/cookies.sqlite-journal
/home/daniel/.mozilla/firefox/j3i5hurh.default/dta_queue.sqlite
/home/daniel/.mozilla/firefox/j3i5hurh.default/places.sqlite-journal
/home/daniel/.mozilla/firefox/j3i5hurh.default/content-prefs.sqlite
/home/daniel/.mozilla/firefox/deevk1cq.neu/search.sqlite
/home/daniel/.mozilla/firefox/deevk1cq.neu/places.sqlite
/home/daniel/.mozilla/firefox/deevk1cq.neu/permissions.sqlite
/home/daniel/.mozilla/firefox/deevk1cq.neu/urlclassifier3.sqlite
/home/daniel/.mozilla/firefox/deevk1cq.neu/signons.sqlite
/home/daniel/.mozilla/firefox/deevk1cq.neu/cookies.sqlite-journal
/home/daniel/.mozilla/firefox/deevk1cq.neu/content-prefs.sqlite

Daniel Riedemann (darie) wrote :

Oh you try to use the en_US locale in bytes_to_human ... it's normal that this does not work. In Arch you have to uncomment the locales you want to use in the file /etc/locale.gen, after that you have to generate them with locale-gen. When I now run make tests (with en_US generated but not used!) then bytes_to_human works fine.

Please see the attachment here, I have now generated the locales for en_US but de_DE is set:

# locale-gen
Generating locales...
  de_DE.UTF-8... done
  de_DE.ISO-8859-1... done
  de_DE.ISO-8859-15@euro... done
  en_US.UTF-8... done
  en_US.ISO-8859-1... done
Generation complete.

# locale
LANG=de_DE.utf8
LC_CTYPE="de_DE.utf8"
LC_NUMERIC="de_DE.utf8"
LC_TIME="de_DE.utf8"
LC_COLLATE=de_DE.utf8
LC_MONETARY="de_DE.utf8"
LC_MESSAGES="de_DE.utf8"
LC_PAPER="de_DE.utf8"
LC_NAME="de_DE.utf8"
LC_ADDRESS="de_DE.utf8"
LC_TELEPHONE="de_DE.utf8"
LC_MEASUREMENT="de_DE.utf8"
LC_IDENTIFICATION="de_DE.utf8"
LC_ALL=

So does bleachbit have to use the US locale? I think many Arch users just have the locale for their own country generated so using en_US there would also fail like for me.

Andrew Ziem (ahziem1) wrote :

I just tried Arch Linux with BleachBit SVN 1333, but Firefox works fine. Have you tried the command line like this?

$ python bleachbit.py --preview firefox.cache

> I have two firefox profiles.. but one was just for testing purposes. I hope that's not a problem?

I also have two profile. It should be fine.

>So does bleachbit have to use the US locale?

No, I don't think so. That's just another assumption for the automated test.

Daniel Riedemann (darie) wrote :

*wtf* (sorry)
Because it still doesn't work for me I created a completely new Linux user without any config files in his home... and boom, it works! I don't understand what is going on here. It's not the BleachBit config... I have to test a bit more.
Sorry that I bothered you with this, it seems that this is just a local "PEBKAC"-problem :-(

Daniel Riedemann (darie) wrote :

Oh, no I lied... It just partially works with a new user. It deletes all temporary/cache files but it doesn't do the sqlite operations. Are you really sure everything worked for you? I tested 0.6.5 again and there everything works fine... I don't know what it is.

Andrew Ziem (ahziem1) wrote :

BleachBit ignores all options except the first for the cleaner, so it probably is just looking at the cache each time (if you check them all). Strange how your Python 2.6.3 works differently than mine 2.6.0.

Changed in bleachbit:
assignee: nobody → Andrew Ziem (ahziem1)
importance: Undecided → Critical
milestone: none → 0.7.0
status: New → Confirmed
Daniel Riedemann (darie) wrote :

Hallo Andrew,
Just want to thank you for your effort here. BleachBit is indeed a very nice program :-))
I wish I could help you with python but I just have not the time to learn it (I'm "forced" to learn VB.net, and Java at the moment ... ;)
So instead I have to bother you with bug reports.

If it is really python 2.6.3 than let's hope the bugs you kill yet help you for distributions that migrate to python 2.6.3 later. ;o)

Andrew Ziem (ahziem1) wrote :

Fixed in SVN 1338. Confirmed on Fedora too. :) I added a unit test in Worker.py to make sure this doesn't happen again

summary: - 0.7.0 beta bug: Firefox cleaner doesn't work anymore
+ 0.7.0 beta bug: only one option per clear honored
tags: added: regression
tags: removed: regression
Changed in bleachbit:
status: Confirmed → Fix Committed
Daniel Riedemann (darie) wrote :

Thank you so much :-)
Works like a charm now!

Andrew Ziem (ahziem1) wrote :

http://bleachbit.sourceforge.net/news/test-bleachbit-070-beta-2

>Thank you so much :-)

And thank you for spotting this important bug

Changed in bleachbit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers