0.7.0 beta bug: Hide irrelevant cleaners doesn't work

Bug #451231 reported by Daniel Riedemann on 2009-10-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
BleachBit
Undecided
Andrew Ziem

Bug Description

Arch Linux, KDE 4.3.2, Kernel 2.6.31.4, Python 2.6.3
###

Hiding irrelevant cleaners doesn't work anymore. It just hides rpmbuild for me, but nothing else I haven't installed. For example: apt, yum, vuze, virt-manager, skype, second life, ... and many others.

The following output I get on the console if I click on the hide cleaners checkbox:

warning: exception '[Errno 2] No such file or directory' running 'rpm --eval %_topdir'
info: automatically hiding cleaner 'rpmbuild'

And nothing more :-(
Regards

Tags: bug Edit Tag help
Daniel Riedemann (darie) on 2009-10-14
tags: added: bug
Daniel Riedemann (darie) wrote :

When I start bleachbit as root I get the following:
info: automatically hiding cleaner 'firefox'
info: automatically hiding cleaner 'openofficeorg'
warning: exception '[Errno 2] Datei oder Verzeichnis nicht gefunden' running 'rpm --eval %_topdir'
info: automatically hiding cleaner 'rpmbuild'

That's ok because for firefox and openoffice I have no config/history/whatever files in /root
But again all other that should also go away don't work.

Daniel Riedemann (darie) wrote :

Maybe this is related to the make tests output from my other bug report?

##
Unit test for Cleaner.add_action() ... FAIL
test_auto_hide (__main__.TestCleaner) ... warning: exception '[Errno 2] No such file or directory' running 'rpm --eval %_topdir'
##

What does that rpm thing do? Arch Linux doesn't have rpm or dpkg, it has a own package manager called pacman. Maybe it's this? How does BleachBit find out which software is installed?

Andrew Ziem (ahziem1) wrote :

The RPM error is harmless, but the add_action() FAIL is bad. (I'll check in detail later.)

If RPM, YUM APT is missing, then BleachBit ignores it and hides it. I tested this with Fedora (RPM/YUM) and Ubuntu (APT).

Andrew Ziem (ahziem1) wrote :

Confirmed only under Arch Linux

Changed in bleachbit:
assignee: nobody → Andrew Ziem (ahziem1)
status: New → Confirmed
Andrew Ziem (ahziem1) wrote :

Fixed in SVN commit 1333

Changed in bleachbit:
milestone: none → 0.7.0
status: Confirmed → Fix Committed
Daniel Riedemann (darie) wrote :

Thank you, works like a charm now.

Changed in bleachbit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers