new-cleaner: Gwenview

Bug #448741 reported by Daniel Riedemann on 2009-10-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
BleachBit
Medium
Andrew Ziem

Bug Description

Hello

this cleaner deletes the recently used items list in gwenview. Gwenview is part of the KDE dektop environment so it should be popular and accordingly often used. Tested again on Arch Linux with KDE 4.3.2 and Gwenview 2.3.2

Like the cleaner for KDE, the path for Ubuntu and/or Fedora maybe is not ~/.kde4/ ... but ~/.kde/ ... instead.

The filenames are pseudo-random (truncated output):
###
ls ~/.kde4/share/apps/gwenview/recentfolders/
insgesamt 80K
-rw------- 1 daniel users 73 10. Okt 14:25 BE5046rc
-rw------- 1 daniel users 63 10. Okt 14:25 Cf4323rc
-rw------- 1 daniel users 93 10. Okt 14:23 cM5046rc
###
ls ~/.kde4/share/apps/gwenview/recenturls
insgesamt 32K
-rw------- 1 daniel users 84 10. Okt 14:20 hU5046rc
-rw------- 1 daniel users 84 10. Okt 14:21 nQ5046rc
-rw------- 1 daniel users 76 10. Okt 14:27 QB5046rc
###

So the cleaner deletes all *rc files in the two directorys.

Regards

Daniel Riedemann (darie) wrote :
Andrew Ziem (ahziem1) wrote :

Looks good. Thank you.

Since the filenames are generally the same length we could match on '.../??????rc' .

Yes, Fedora 11 (LDE 4.3.1) has these paths
~/.kde/share/apps/gwenview/recentfolders/s25303rc

Ubuntu popcon rank is 1910 (high).

Please note there is a new version of CleanerML with new features for BleachBit 0.7.0. CleanerML 2 incompatible with version 1 but generally this upgrade script works:
http://bleachbit.svn.sourceforge.net/viewvc/bleachbit/misc/cml_1to2.sh?revision=1191&view=markup

Changed in bleachbit:
assignee: nobody → Andrew Ziem (ahziem1)
importance: Undecided → Medium
status: New → Confirmed
Andrew Ziem (ahziem1) wrote :

Committed in SVN revisions 1259:1260

Changed in bleachbit:
milestone: none → 0.7.0
status: Confirmed → Fix Committed
Andrew Ziem (ahziem1) wrote :
Changed in bleachbit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments