Winapp2 Windows Defender cleaners not showing in BleachBit

Bug #1571908 reported by ROCKNROLLKID on 2016-04-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
BleachBit
Undecided
Unassigned

Bug Description

Forum user bsodx2 and I confirmed that the following entries are not showing up in BleachBit when they should be:

[Windows Defender Definition Updates*]
LangSecRef=3024
DetectOS=|6.1
Detect=HKLM\Software\Microsoft\Windows Defender
FileKey1=%CommonAppData%\Microsoft\Windows Defender\Definition Updates|*.*|RECURSE
FileKey2=%LocalAppData%\VirtualStore\ProgramData\Microsoft\Windows Defender\Definition Updates|*.*|RECURSE

[Windows Defender More*]
LangSecRef=3024
Detect=HKLM\Software\Microsoft\Windows Defender
FileKey1=%CommonAppData%\Microsoft\Windows Defender\Definition Updates\Backup|*.*|RECURSE
FileKey2=%CommonAppData%\Microsoft\Windows Defender\Network Inspection System\Support|*.txt
FileKey3=%CommonAppData%\Microsoft\Windows Defender\Scans|*.bin;*.bin*
FileKey4=%CommonAppData%\Microsoft\Windows Defender\Scans\History\Service|*.log
FileKey5=%CommonAppData%\Microsoft\Windows Defender\Scans\Scans\History\CacheManager|*.*|RECURSE
FileKey6=%CommonAppData%\Microsoft\Windows Defender\Support|*.*|RECURSE

Both of us are on Windows 10 64-bit. bsodx2 confirmed this is not happening on CCleaner.

Discussion about this is on the forums here: https://www.bleachbit.org/forum/bleachbit-111-beta-results?page=0

description: updated
Changed in bleachbit:
status: New → Confirmed
milestone: none → 1.14
importance: Undecided → Medium
Andrew Ziem (ahziem1) on 2017-01-04
Changed in bleachbit:
status: Confirmed → In Progress
Andrew Ziem (ahziem1) wrote :

Does this problem still exist? With the latest Windows build of BleachBit I made a winapp2.ini file with just the two entries copied from this bug ticket. Then on Windows 7 I confirmed the registry key actually exists, and BleachBit showed both under the Utilities section. (It should work the same with the standard Winapp2.ini.)

Then I downloaded the latest winapp2.ini using BleachBit, and the two options were still there. I previewed them, and each option showed files.

I also made an automated unit test to check Winapp2.ini Detect= with a registry key with a space, and it worked too.

Please reopen if still an issue.

Changed in bleachbit:
status: In Progress → Invalid
ROCKNROLLKID (slinger1410) wrote :

They are still not showing on my system. I just confirmed that the registry keys that the detects point at are on my system, as intended.

Changed in bleachbit:
status: Invalid → Triaged
ROCKNROLLKID (slinger1410) wrote :

Actually, it seems BleachBit isn't showing a Utilities section for me: https://snag.gy/WA6kVs.jpg

It is suppose to be in a section called utilities right or is it called something else?

Andrew Ziem (ahziem1) wrote :

Yes, it is called Utilities. Here is a screenshot on my system

https://snag.gy/1zl3c0.jpg

Questions
1. Do you have any entries from Winapp2.ini?
2. Is the Winapp2.ini file installed in BleachBit's cleaner directory?
3. If #2 is yes, then does the Utilities section show up if you disable "Hide irrelevant cleaners" in the preferences?

ROCKNROLLKID (slinger1410) wrote :

I just unchecked "Hide irrelevant cleaners" and the utilities section showed up for me. There are 2 other entries that should show up for me, but do not. I also notice that the "Windows Defender Extras" and the "BleachBit Error Reporting Log" are not showing up for me, either.

If I uncheck "Hide Irrelevant cleaners", none of the Windows Defender entries show up for me: https://snag.gy/xLf0Bn.jpg

While looking at the directory where BleachBit should store Winapp2, I notice that they are 2 different locations. Look here: https://snag.gy/GXU9JN.jpg and https://snag.gy/xV8zOU.jpg If I try deleting the ones outside the BleachBit folder, BleachBit just puts them back there. Do you want me to file this in a different bug ticket, as I don't think it really relates to this.

Andrew Ziem (ahziem1) wrote :

Regarding the location of the bleachbit.ini: try deleting both. One is dated January 2. On December 31 I fixed an issue with the location for the options directory, so make sure you are using a newer build. If the bleachbit.ini or winapp2.ini shows up in the wrong location with a build newer than December 31, then yes, file a new ticket.

I will look more into the Windows Defender

ROCKNROLLKID (slinger1410) wrote :

Ok I solved the duplicate Cleaners/bleachbit.ini issue and the Utilities section is showing up for me again, but I still don't any Windows Defender entries. I do see one Windows Defender entry right below the Utilities section, though: https://snag.gy/iyU3IP.jpg

Andrew Ziem (ahziem1) on 2017-09-03
Changed in bleachbit:
milestone: 2.0 → 2.2
Andrew Ziem (ahziem1) wrote :

If this still exists in the latest version (BleachBit 2.1), please file bug report in the new home: https://github.com/bleachbit/bleachbit/blob/master/CONTRIBUTING.md . If this bug no longer exists, it would be nice if you wrote a note to confirm.

Changed in bleachbit:
importance: Medium → Undecided
milestone: 2.2 → none
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers