UAC prompt never shows on Windows 10 using an admin account

Bug #1496629 reported by Mike L on 2015-09-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
BleachBit
High
Andrew Ziem

Bug Description

In this case, I was using an admin account that is also a Microsoft account. The UAC prompt never shows up. Tried rebooting and looking into info from BleachBit. The line "win32com.shell.shell.IsUserAnAdmin() = False" indicates that for some reason, just double clicking the desktop icon or going to Start and clicking the program doesn't ever prompt the user for admin rights. See the following for more details:
http://bleachbit.sourceforge.net/forum/potential-windows-10-bug-uac#comment-1903

Andrew Ziem (ahziem1) on 2015-09-17
Changed in bleachbit:
milestone: none → 1.10
importance: Undecided → High
assignee: nobody → Andrew Ziem (ahziem1)
Andrew Ziem (ahziem1) on 2015-11-06
Changed in bleachbit:
status: New → Triaged
Andrew Ziem (ahziem1) wrote :

Fixed in commit cdf038ea710ce4d705d2c5601e9ecf393bcc2ec0

Mike: thank you for the report

Changed in bleachbit:
status: Triaged → Fix Committed
Andrew Ziem (ahziem1) wrote :

Mike, as a workaround does it help if you right-click on the BleachBit icon and choose "run as administrator"?

Andrew Ziem (ahziem1) wrote :

Please test the fix in BleachBit 1.9.2 beta
http://bleachbit.sourceforge.net/news/bleachbit-192-beta

And please feel free to add a comment to this bug ticket whether the new release fixes the reported issue.

Changed in bleachbit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers