bleachbit .exe.log reports this recurring error

Bug #1465474 reported by ineuw on 2015-06-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
BleachBit
Undecided
Andrew Ziem

Bug Description

 File "bleachbit\Windows.pyo", line 536, in set_environ
RuntimeError: special folder D:\ is too short
directory is not empty: \\?\C:\Users\ineuw\Local Settings\Temp\NVIDIA Corporation\NV_Cache
directory is not empty: \\?\C:\Users\ineuw\Local Settings\Temp\NVIDIA Corporation

Andrew Ziem (ahziem1) wrote :

Thanks for the report, ineuw.

Is this BleachBit version 1.7.7 beta?

Changed in bleachbit:
milestone: none → 1.8
ineuw (ineuw) wrote :

Yes, in version 1.7.7 beta.

These lines appear just by activating BB without running the cleaner

Traceback (most recent call last):
  File "bleachbit\Windows.pyo", line 536, in set_environ
RuntimeError: special folder D:\ is too short

Andrew Ziem (ahziem1) wrote :

I assumed it does not happen, but you have a special folder (like the documents folder) that points to D:\, so I removed this check

git commit 75f9aac

Changed in bleachbit:
assignee: nobody → Andrew Ziem (ahziem1)
status: New → Fix Committed

Thanks Andrew,

All of Drive D: is the "My Documents" folder. I am sure that this is
the cause of the hiccup.

<email address hidden>

On 2015-06-17 11:29 PM, Andrew Ziem wrote:
> I assumed it does not happen, but you have a special folder (like the
> documents folder) that points to D:\, so I removed this check
>
> git commit 75f9aac
>
> ** Changed in: bleachbit
> Status: New => Fix Committed
>
> ** Changed in: bleachbit
> Assignee: (unassigned) => Andrew Ziem (ahziem1)
>

Andrew Ziem (ahziem1) on 2015-07-31
Changed in bleachbit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers