UnicodeDecodeError: 'utf8' codec can't decode byte 0x97 in position 49: unexpected code byte

Bug #1454030 reported by Andrew Ziem on 2015-05-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
BleachBit
High
Andrew Ziem

Bug Description

Windows 7
BleachBit 1.7.6

getsize(C:\Users\username\Local Settings\Temp\Week_1_-_Ephesians—Discovering_Who_We_Are-1.doc)
Traceback (most recent call last):
  File "bleachbit\Worker.pyo", line 82, in execute
  File "bleachbit\Command.pyo", line 74, in execute
  File "bleachbit\FileUtilities.pyo", line 361, in getsize
UnicodeDecodeError: 'utf8' codec can't decode byte 0x97 in position 49: unexpected code byte

Andrew Ziem (ahziem1) on 2015-05-12
description: updated
Andrew Ziem (ahziem1) wrote :

Reproduced on Windows XP. The issue seems to be the em-dash (—).

Andrew Ziem (ahziem1) wrote :

Fixed 869f165

Changed in bleachbit:
status: Triaged → Fix Committed
Andrew Ziem (ahziem1) on 2015-05-23
Changed in bleachbit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers