UnicodeDecodeError in guess_overwrite_paths on startup

Bug #1416640 reported by goingoin on 2015-01-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
BleachBit
High
Andrew Ziem

Bug Description

Hello

In windows 8.1 64 bits, i have the same problem that :
https://bugs.launchpad.net/bleachbit/+bug/1372179

i have office starter 2010 installed
i have the lastest version 1.6

i test with 1.2 is ok

goingoin (gwen-news) on 2015-01-31
description: updated
Andrew Ziem (ahziem1) wrote :

Please attach bleachbit.exe.log

goingoin (gwen-news) wrote :

Traceback (most recent call last):
  File "bleachbit.py", line 43, in <module>
  File "bleachbit\GUI.pyo", line 40, in <module>
  File "bleachbit\Cleaner.pyo", line 40, in <module>
  File "bleachbit\Special.pyo", line 27, in <module>
  File "bleachbit\Options.pyo", line 298, in <module>
  File "bleachbit\Options.pyo", line 65, in __init__
  File "bleachbit\Options.pyo", line 194, in restore
  File "bleachbit\FileUtilities.pyo", line 407, in guess_overwrite_paths
UnicodeDecodeError: 'utf8' codec can't decode bytes in position 13-15: invalid data

Andrew Ziem (ahziem1) wrote :

The symptoms are similar, but the traceback indicates the problem is caused by something else.

This error is caused ironically by the error handler.
https://github.com/az0/bleachbit/blob/506f2e1cab8cdf0bfe46e5e28309f68d87419b2a/bleachbit/FileUtilities.py#L407

Thank you for reporting this. I plan to fix this for the next release

Changed in bleachbit:
milestone: none → 1.8
assignee: nobody → Andrew Ziem (ahziem1)
importance: Undecided → High
summary: - Same problem that : https://bugs.launchpad.net/bleachbit/+bug/1372179
+ UnicodeDecodeError in guess_overwrite_paths on startup
Andrew Ziem (ahziem1) wrote :

In your Windows username or your Windows home directory (%USERPROFILE%) do you have Unicode (i.e., non-ASCII) characters?

goingoin (gwen-news) wrote :

%userprofile% = PROPRIETAIRE

Andrew Ziem (ahziem1) wrote :

Please test the fix here and let me know whether this works
https://sourceforge.net/projects/bleachbit/files/bleachbit/1.7.1alpha/

Changed in bleachbit:
status: New → Fix Released
goingoin (gwen-news) wrote :

Launch OK
enclosed rapport

Andrew Ziem (ahziem1) wrote :

In the enclosed file Rapport.txt there are errors with "MoveFileEx." This may be because you are not running with administrator privileges, so when BleachBit starts, make sure you allow it to do so. If you believe MoveFileEx is still a problem, please open a new bug ticket.

goingoin (gwen-news) wrote :

Today i launch 1.7.1 Alpha on windows 8.1 BING 64 bits

Just launch and closed not clean, this error :
Traceback (most recent call last):
  File "bleachbit\Options.pyo", line 195, in restore
  File "bleachbit\FileUtilities.pyo", line 408, in guess_overwrite_paths
UnicodeDecodeError: 'utf8' codec can't decode bytes in position 13-15: invalid data

User is administrator of the computer.
If I do:
  - Right click on "bleachbit.exe"
  - Property
  - Tab "compatibility"
  - I checked "execute this program as an administrator.

goingoin (gwen-news) wrote :

Error with cleaning :

Traceback (most recent call last):
  File "bleachbit\Worker.pyo", line 82, in execute
  File "bleachbit\Command.pyo", line 127, in execute
  File "bleachbit\Cleaner.pyo", line 756, in emptyrecyclebin
  File "bleachbit\Windows.pyo", line 313, in empty_recycle_bin
com_error: (-2147467259, 'Erreur non sp\xe9cifi\xe9e', None, None)

Andrew Ziem (ahziem1) wrote :

UTF8 error: This is related to the original bug you filed. So you mean BleachBit started and ran normally, but then when you exited you were notified of the error? In the help menu please click "System Information" and please show me the line that includes os.getenv('TMP')

Administrator: In the "System Information" do you see "win32com.shell.shell.IsUserAnAdmin() = True"? If this is True, please open a new bug ticket to track the MoveFileEx error.

Error with cleaning about empty_recycle_bin: This is an unrelated error. It can happen if the recycling bin is empty. In Bug #1425373 I am planning to rewrite how BleachBit handles the recycling bin.

Changed in bleachbit:
status: Fix Released → In Progress
Andrew Ziem (ahziem1) wrote :

For the UTF8 error please test this new build.
https://sourceforge.net/projects/bleachbit/files/bleachbit/1.7.2alpha/

BleachBit 1.7.2 should start and close without any UTF-8 errors

Andrew Ziem (ahziem1) wrote :

goingoin (gwen-news): Have you had a chance to test 1.7.2?

Andrew Ziem (ahziem1) wrote :

For a fix for the recycle bin error (Erreur non sp\xe9cifi\xe9e), see bug#1425373

goingoin (gwen-news) wrote :

I have not had time to test again.

goingoin (gwen-news) wrote :

At launch without clean :

Traceback (most recent call last):
  File "bleachbit\Options.pyo", line 195, in restore
  File "bleachbit\FileUtilities.pyo", line 412, in guess_overwrite_paths
UnicodeDecodeError: 'utf8' codec can't decode bytes in position 13-15: invalid data

goingoin (gwen-news) wrote :

Report after clean

Traceback (most recent call last):
  File "bleachbit\Worker.pyo", line 82, in execute
  File "bleachbit\Command.pyo", line 127, in execute
  File "bleachbit\Cleaner.pyo", line 756, in emptyrecyclebin
  File "bleachbit\Windows.pyo", line 313, in empty_recycle_bin
com_error: (-2147467259, 'Erreur non sp\xe9cifi\xe9e', None, None)

goingoin (gwen-news) wrote :

Hello,

I download 1.7.3 and see report
Bleachbit 1 without administrator check (see top)

Bleachbit 2 with administrator check

Bye

Andrew Ziem (ahziem1) wrote :

When you have time, would you please test 1.7.5?
https://sourceforge.net/projects/bleachbit/files/bleachbit/1.7.5alpha/

The good news is I think I fixed the errors: "Erreur non sp\xe9cifi\xe9e" and UnicodeDecodeError

I wanted to test it more myself, but I could not get my system to show translated errors like yours. I tried Windows XP, 7, and 10, and in the control panel I changed the language. This changed the language of BleachBit itself but not the low-level Python error like "Erreur non sp\xe9cifi\xe9e." If you have any advise on how to change this, please let me know.

goingoin (gwen-news) wrote :

Hello,

I test only with administrator check today, see log.
If you want i can test without administrator check, say me.

Good day

goingoin (gwen-news) wrote :

New test : see report you have errors !
Bye

Andrew Ziem (ahziem1) wrote :

For the next release I fixed the following error
(123, 'FindFirstFileW', 'La syntaxe du nom de fichier, de r\xe9pertoire ou de volume est incorrecte.')

Which happened in Google Chrome - Vacuum because one path used forwarded slashes (UNIX-style) instead of back slashes.

In more than one session of BleachBit, have you seen this "no such file" error for Windows Explorer ? In one of your logs, it looks OK, but the error is seen in the other log. Nothing seems unusual about this file or path.
[Errno 2] No such file or directory: u'C:\\Users\\PROPRIETAIRE\\AppData\\Local\\Microsoft\\Windows\\Explorer\\thumbcache_1024.db'

goingoin (gwen-news) wrote :

Hello,

Report BUG on 1.76alpha
Bye

Andrew Ziem (ahziem1) wrote :

Thank you so much for reporting, testing, and your patience. Sorry I forgot to ask whether you would test one more time with BleachBit 1.7.7 beta?
http://bleachbit.sourceforge.net/news/bleachbit-177-beta

I think I fixed the original bug.

Andrew Ziem (ahziem1) wrote :

I am marking this as fixed, but please feel free to reopen this bug if you have the same symptoms.

Of course feel free to open a new bug for new symptoms

Thanks!

Changed in bleachbit:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers