Add a .policy file for pkexec

Bug #1111061 reported by Martin Cigorraga on 2013-01-31
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
BleachBit
Medium
Unassigned

Bug Description

Hello!

Since pkexec is slowly but surely replacing sudo/gksu/kdesu it would be a good idea to start shipping a .policy file to let limited users run Bleachbit with root rights.
I've already created this .policy file and you can grab it from here: http://pastebin.com/Nj36aWDw
The policy file must be installed in /usr/share/polkit-1/actions with your chosen file name.

Regards.
-Martin

Changed in bleachbit:
status: New → Opinion
status: Opinion → New
Changed in bleachbit:
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for BleachBit because there has been no activity for 60 days.]

Changed in bleachbit:
status: Incomplete → Expired
Andrew Ziem (ahziem1) on 2016-06-04
Changed in bleachbit:
status: Expired → New
milestone: none → 1.14
status: New → Triaged
Andrew Ziem (ahziem1) wrote :

"I think that root version of bleachbit needs to support pkexec. Otherwise, you get a terminal window with a su request. One must install gksu to get around the problem."

https://www.bleachbit.org/forum/support-ubuntu-1610#comment-2543

Changed in bleachbit:
importance: Undecided → Medium
Andrew Ziem (ahziem1) wrote :

Committed in Git 00fc5ef94c13fc312a0ffa42dac8dd4b7504bb06

Changed in bleachbit:
status: Triaged → Fix Committed
Andrew Ziem (ahziem1) wrote :
Changed in bleachbit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers