Existing users aren't accounted for and structure is not preserved

Bug #514517 reported by Zachery Bir on 2010-01-29
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Bindwood
High
Zachery Bir
bindwood (Ubuntu)
Medium
Zachery Bir

Bug Description

Existing users (pre-manifest branch) don't have their folder structure accounted for in CouchDB, and bookmark records have some inconsistencies and anachronisms relative to the new record schemas.

These users need to be provided for by means of a migration path that updates their existing records and syncs structural and ancillary content (separators, folders, and feeds) to CouchDB.

Related branches

Zachery Bir (urbanape) on 2010-01-29
Changed in bindwood:
assignee: nobody → Zachery Bir (urbanape)
importance: Undecided → High
status: New → Confirmed
status: Confirmed → In Progress
tags: added: bindwood desktop+ package
Changed in bindwood (Ubuntu):
status: New → In Progress
assignee: nobody → Zachery Bir (urbanape)
importance: Undecided → Medium
Changed in bindwood:
milestone: none → lucid-beta-2
Changed in bindwood (Ubuntu):
milestone: none → ubuntu-10.04-beta-2
Zachery Bir (urbanape) on 2010-04-05
Changed in bindwood:
status: In Progress → Fix Committed
tags: removed: package
James Henstridge (jamesh) wrote :

This bug looks like it was 1.0.x related, so marking Fix Released.

Changed in bindwood:
milestone: lucid-beta-2 → none
status: Fix Committed → Fix Released
Changed in bindwood (Ubuntu):
milestone: ubuntu-10.04-beta-2 → none
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers