Should have purge-old-kernels script on Ubuntu Precise 12.04 LTS

Bug #1473161 reported by Norbert on 2015-07-09
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
bikeshed
Undecided
Unassigned
byobu
Undecided
Unassigned
bikeshed (Ubuntu)
Undecided
Unassigned

Bug Description

Summary:
   bikeshed package has very useful script for removing old kernels.

   For now this script is available on the following Ubuntu versions:
      * 14.04 trusty LTS (http://packages.ubuntu.com/search?suite=trusty&arch=any&mode=filename&searchon=contents&keywords=purge-old-kernels)
      * 14.10 utopic (http://packages.ubuntu.com/search?suite=utopic&arch=any&mode=filename&searchon=contents&keywords=purge-old-kernels)
      * 15.04 vivid (http://packages.ubuntu.com/search?suite=vivid&arch=any&mode=filename&searchon=contents&keywords=purge-old-kernels)
      * 15.10 wily (http://packages.ubuntu.com/search?suite=wily&arch=any&mode=filename&searchon=contents&keywords=purge-old-kernels)

      But this script is not available for the Ubuntu Precise 12.04 LTS.
      Please adopt this script for Ubuntu Precise 12.04 LTS.

Expected results:
   /usr/bin/purge-old-kernels script is available on all supported versions of Ubuntu

Actual results:
   /usr/bin/purge-old-kernels script is available only on trusty, utopic, vivid, wily.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: bikeshed (not installed)
ProcVersionSignature: Ubuntu 3.13.0-55.94~precise1-generic 3.13.11-ckt20
Uname: Linux 3.13.0-55-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu17.9
Architecture: amd64
Date: Thu Jul 9 20:39:35 2015
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
MarkForUpload: True
SourcePackage: bikeshed
UpgradeStatus: No upgrade log present (probably fresh install)

Norbert (nrbrtx) wrote :
Norbert (nrbrtx) wrote :

I manually downloaded bikeshed_1.42-0ubuntu1_all.deb package from 14.04, extracted it, ran "sudo usr/bin/purge-old-kernels".
It works as expected.

So the purge-old-kernels script may be successfully included to 12.04 package. Please add it.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bikeshed (Ubuntu):
status: New → Confirmed
Jarno Suni (jarnos) wrote :

bikeshed (1.64-0ubuntu1) xenial; urgency=medium

  * move purge-old-kernels to byobu

 -- Dustin Kirkland <email address hidden> Thu, 18 Feb 2016 12:44:29 -0800

(https://github.com/dustinkirkland/bikeshed/blob/master/debian/changelog)

summary: - bikeshed should have purge-old-kernels script on Ubuntu Precise 12.04
- LTS
+ Should have purge-old-kernels script on Ubuntu Precise 12.04 LTS
Dustin Kirkland  (kirkland) wrote :

You're welcome to get the purge-old-kernels script, which moved from bikeshed to byobu, recently. You can install it easily from the byobu ppa: ppa:byobu/ppa. But I don't think we're going to sru this back to Precise or Trusty, I'm afraid.

Changed in bikeshed:
status: New → Won't Fix
Changed in byobu:
status: New → Won't Fix
Changed in bikeshed (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments