networking-odl not pip installable / breaks networking-bgpvpn CI

Bug #1764371 reported by Thomas Morin on 2018-04-16
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
networking-bgpvpn
Critical
Thomas Morin
networking-odl
Undecided
Unassigned

Bug Description

networking-bgpvpn has unit tests for the ODLv1 dirver for BGPVPN

Since 2018-04-12 the unit test job is broken [1].

The logs are not verbose, but I think I drilled this down to the fact that networking-odl cannot be installed with pip anymore since tools/tox_install.sh has been removed, because of the use of a git reference instead of a pip reference for ceilometer.

(in a networking-bgpvpn py27 virtualenv:)

pip install -e ../networking-odl

Obtaining file:///home/teom7365/prog/openstack/networking-odl
Requirement already satisfied: pbr>=3.1.1 in ./.tox/py27/lib/python2.7/site-packages (from networking-odl==12.0.1.dev54)
Requirement already satisfied: Babel>=2.5.3 in ./.tox/py27/lib/python2.7/site-packages (from networking-odl==12.0.1.dev54)
Requirement already satisfied: stevedore>=1.28.0 in ./.tox/py27/lib/python2.7/site-packages (from networking-odl==12.0.1.dev54)
Requirement already satisfied: debtcollector>=1.19.0 in ./.tox/py27/lib/python2.7/site-packages (from networking-odl==12.0.1.dev54)
Requirement already satisfied: neutron-lib>=1.13.0 in ./.tox/py27/lib/python2.7/site-packages (from networking-odl==12.0.1.dev54)
Collecting websocket-client>=0.47.0 (from networking-odl==12.0.1.dev54)
  Using cached websocket_client-0.47.0-py2.py3-none-any.whl
Requirement already satisfied: neutron>=12.0.0 in ./.tox/py27/lib/python2.7/site-packages (from networking-odl==12.0.1.dev54)
Collecting neutron-lbaas>=12.0.0 (from networking-odl==12.0.1.dev54)
  Using cached neutron_lbaas-12.0.0-py2.py3-none-any.whl
Collecting networking-l2gw>=12.0.0 (from networking-odl==12.0.1.dev54)
  Using cached networking_l2gw-12.0.1-py2-none-any.whl
Collecting networking-sfc>=6.0.0 (from networking-odl==12.0.1.dev54)
  Using cached networking_sfc-6.0.0-py2-none-any.whl
Requirement already satisfied: networking-bgpvpn>=8.0.0 in /home/teom7365/prog/openstack/networking-bgpvpn (from networking-odl==12.0.1.dev54)
Collecting ceilometer (from networking-odl==12.0.1.dev54)
  Could not find a version that satisfies the requirement ceilometer (from networking-odl==12.0.1.dev54) (from versions: )
No matching distribution found for ceilometer (from networking-odl==12.0.1.dev54)

[1] http://logs.openstack.org/25/561225/1/check/openstack-tox-pep8/948650c/job-output.txt.gz#_2018-04-16_07_48_26_829982

Thomas Morin (tmmorin-orange) wrote :

A short term solution for networking-bgpvpn is to stop drawing networking-odl from git (will then draw an older from pypi, which will not have the issue).

Longer term, we need to remove/deprecate the ODLv1 BGPVNP driver, since the v2 driver has now been here for a while.

But beyond networking-bgpvpn, it seems like networking-odl needs a fix to make the package properly installable again. I don't know how close we are to having ceilometer installable from pypi.

Changed in bgpvpn:
importance: Undecided → Critical

Fix proposed to branch: master
Review: https://review.openstack.org/561601

Changed in bgpvpn:
assignee: nobody → Thomas Morin (tmmorin-orange)
status: New → In Progress

Change abandoned by Thomas Morin (<email address hidden>) on branch: master
Review: https://review.openstack.org/561601
Reason: will work on a proper migration later

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers