Rev 91 0.6.4-pre2

Bug #404606 reported by Getrix on 2009-07-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
BeBot
High
Thomas Juberg

Bug Description

Rev 91 0.6.4-pre2

This code there was added "Merged rev 144..145 from trunk (nounderscore bug fix)"
The problem here is that it seems it was added code to "conf/MySQL.conf"
Following code:

 /*
 If you have $table_prefix Defined your tables will be prefixed as above with a _ added on
 if you dont want the _ added uncomment below
 */
 $nounderscore = FALSE;

This will make bots running with "botname_TABLE" create new tables with "botnameTABLE" because they miss "$nounderscore = TRUE;" in there config.
Atleast this happen to me.

Thomas Juberg (thomas-juberg) wrote :

Already have this one on my list, thank you for the report :)

Changed in bebot:
assignee: nobody → Thomas Juberg (thomas-juberg)
importance: Undecided → High
milestone: none → 0.6.4
status: New → Confirmed
Changed in bebot:
status: Confirmed → Fix Committed
DJKRose (dj-krose) wrote :

I just saw how it got fixed and would like to comment:

if ($nounderscore)
if ($nounderscore == TRUE)

Both lines do exactly 100% the same in 100% of all possible values and types!

If a cosmetic code change (refactoring) was intended, thats ok, even though I think the first one is better: An if-statement implies that the expression is always compared to true. The second statement says "if it's true that $nounderscore true is", which is somehow redundant ;) If something else was meant with the change, it' wasn't achieved. If it's working anyway, the change wasn't necessary.

btw... I didn't look into the rest of the code...

Thomas Juberg (thomas-juberg) wrote :

The change in question was not the fix, and should as you point out not have been commited.

Changed in bebot:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers