Error Reading RPC header

Bug #396248 reported by Nysom on 2009-07-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
BeBot
High
DJKRose

Bug Description

I am patched with the new AoC - I made it through a host of errors and now I *may* be at my final error:

Connecting
Authenticating
Read Error: EOF
Error while reading rpc header. ()

Any idea what I can do for this?

Thank you!

Related branches

DJKRose (dj-krose) wrote :

This issue is not related to a released BeBot version but to the currently unreleased aocpatch branch, which might be a part of the next release.

I can't reproduce the error. Its working here just fine in exactly the same runtime environment. Also I can't "guess" the problem from just an "EOF error" and even if I could, I'm afraid I'm not able to go that deep into the network protocol handling. So we are pretty much stuck here as long as nobody else comes up with a solution or more detailed reports.

Problem may be related to this bug: https://bugs.launchpad.net/bebot/+bug/396198

DJKRose (dj-krose) on 2009-07-07
Changed in bebot:
status: New → Incomplete
Nysom (jresnick) wrote :

Ok - in the serverlist.php it lists the Cimmeria server with port 7015(?) I altered it to 7000 and I am authenticating. You are correct that this is related to the Funcom patch and not a Bebot issue whatsoever. Therefore, I think only the serverlist.php file may need to be updated (?)

DJKRose (dj-krose) wrote :

I don't really understand, what you tried and what you are referring to. Therefore maybe my previous answer was pointing in the wrong direction. So let me explain:

Since AoC patch 1.05 there is no official BeBot version that works with AoC. It's not only a matter of serverlist.php, but the whole login and authentication system changed and has to be redone. We are currently working on it but it's not yet ready for a release. You can find many discussion threads about this in forums:
http://bebot.shadow-realm.org/bebot-0-6-support/aoc-and-patch-1-05/
http://bebot.shadow-realm.org/bebot-0-6-support/aoc-patch-1-05-login-information/
http://forums-de.ageofconan.com/showthread.php?t=125128

However you might wanna try the current unstable version from our code repository: http://bazaar.launchpad.net/~bebot-contrib/bebot/0.6.2-aocpatch/files - For some people (like me) it's already working, for others it isn't.

DJKRose (dj-krose) wrote :

The fix for the new login protocol (AoC 1.05) is ready, tested, committed, and will most likely be part of the next version.

Changed in bebot:
assignee: nobody → DJKRose (dj-krose)
importance: Undecided → High
milestone: none → 0.6.4
status: Incomplete → Fix Committed
Nysom (jresnick) wrote :

Yes, I understand it's part of the whole login and authentication change :)

However, I was unable to log the bot in until I changed the port in the serverlist.php - however I am able to log in now. Unfortunately, we were working alright the other day, and now our bot does not talk in Guild any longer.

However, I will try the new files from the beta you posted.

Thank you again for all of your hard work ;)

Changed in bebot:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers