Logon.php EOF error

Bug #396198 reported by Doob on 2009-07-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
BeBot
Undecided
DJKRose

Bug Description

When anyone tried to log on or off and as soon as bot displays message in guild chat it disconnects with EOF error.

Tested with a new db, WinXP 32 PHP 5.2.6 and 5.3, Bebot 6.2 and 6.3

Related branches

DJKRose (dj-krose) wrote :

According to the additional infos you gave here (http://forums-de.ageofconan.com/showthread.php?p=1362513#post1362513) I just want to add, that this is referring to AoC only and it's not related to BeBot 6.2 or 6.3 or any other released version. It's an issue with the currently unreleased aocpatch branch, which might be a part of the next release.

I'd like to add that I can't reproduce the error. Its working here just fine in exactly the same runtime environment. Also I can't "guess" the problem from just an "EOF error" and even if I could, I'm afraid I'm not able to go that deep into the network protocol handling. So we are pretty much stuck here as long as nobody else comes up with a solution or more detailed reports.

Changed in bebot:
status: New → Incomplete
DJKRose (dj-krose) wrote :

Problem may be related to this bug: https://bugs.launchpad.net/bebot/+bug/396248

DJKRose (dj-krose) wrote :

The problem was caused by a change in Funcoms chat servers: Up till 1.05 message send to private group was “sent in space”, and after 1.05 it cause the crash.

Fixed the Bot so that it never sends privatemessage when connected to AoC.

Changed in bebot:
status: Incomplete → Fix Committed
DJKRose (dj-krose) on 2009-07-08
Changed in bebot:
assignee: nobody → DJKRose (dj-krose)
Changed in bebot:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers