Quit on Ctrl+Q

Bug #952279 reported by Sergey "Shnatsel" Davidoff on 2012-03-11
70
This bug affects 11 people
Affects Status Importance Assigned to Milestone
AppCenter
Fix Released
Wishlist
Daniel Fore
BeatBox
Low
Scott Ringwelski
Cable
Low
Unassigned
Calculator
Fix Released
Low
MarkoD
Files
Fix Released
Low
Jeremy Wootten
Mail
Fix Released
Low
Ralph Plawetzki
Noise
Fix Released
Low
Patrick Pace
Scratch
Fix Released
Low
Mario Guerriero
Screenshot
Fix Released
Low
Daniel Fore
Terminal
Invalid
Undecided
Unassigned

Bug Description

Quit on Ctrl+Q key combo, as described in the keyboard shortcuts document: https://docs.google.com/document/d/1jUtWkfqlwDydaO-B67F9PsOhE66AZ2y5N_uDRW9pOuQ/edit

Related branches

tags: added: consistency
Christian Dywan (kalikiana) wrote :

Midori has switched to quitting on Ctrl+Shift+Q some time ago because users tend to accidentally hit Ctr+Q when aiming for Ctrl+W or Ctrl+A.

Changed in midori:
status: New → Won't Fix

I agree that the shortcut for quitting an app as opposed to closing a window should involve a meta key, but it's also important not to hard-code this. I think the blueprint for Consistent keyboard shortcuts is on the money, but there needs to be a central table of common shortcuts that is truly adhered to as part of the HIG. For Macs, if it's a menubar item, it can be set as a keyboard shortcut in a specific app or in all apps, and this for example lets me map Command-Shift-M to Zoom (close enough to maximize) across all apps. A similar level of consistency for sizing, tabbed navigation, document opening/saving, and app quitting is highly desirable and not just in Midori.

Changed in beat-box:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Scott Ringwelski (sgringwe)
milestone: none → 0.4
status: Confirmed → Fix Committed
Changed in beat-box:
status: Fix Committed → Fix Released
description: updated
Changed in scratch:
status: New → Confirmed
importance: Undecided → Low
milestone: none → luna-beta1
assignee: nobody → Mario Guerriero (mefrio-g)
Changed in scratch:
status: Confirmed → Fix Committed
Daniel Fore (danrabbit) wrote :

Is there any way we can do this in Granite Application or as a function of Gala or something so that all apps just have this automatically for free?

Mario Guerriero (mefrio-g) wrote :

With Gala we could call delete-event signal of the window when CTRL+Q is clicked. If it can be so I suggest to use the current implementation since many apps, such as scratch, do some functions before close themselves

Christian Dywan (kalikiana) wrote :

Keep in mind cases where Ctrl+Q is intentionally being disabled, such as Midori which uses Ctrl+Shift+Q.

Another point is, if this only works in Gala, we're going to see very strange and confused problem reports. Not even all of Elementary developers use Gala.

Tom Beckmann (tombeckmann) wrote :

Well, it would probably conflict with other apps using ctlr+q too, I'd rather say put it in GraniteApplication and make it disable-able for the worst case. We inherit some signals from GLibApplication and GtkApplication which could be useful here.

Cody Garver (codygarver) on 2012-07-24
Changed in granite:
status: New → Confirmed
importance: Undecided → Medium
Changed in noise:
status: New → Won't Fix
tags: added: hotkey

Gala can only call closing the window, not the actual quit function (which are different things in many apps, e.g. BeatBox).

Daniel Fore (danrabbit) on 2012-08-03
Changed in scratch:
status: Fix Committed → Fix Released

Cody, why this is "Won't Fix" for Noise?

Victor Martinez (victored) wrote :

It's actually fixed for noise

Changed in granite:
importance: Medium → Wishlist
status: Confirmed → Triaged
Changed in noise:
status: Won't Fix → Fix Committed
importance: Undecided → Low
milestone: none → luna-beta2
assignee: nobody → Patrick Pace (pqp)
Corentin Noël (tintou) on 2013-02-23
Changed in noise:
status: Fix Committed → Fix Released
Changed in pantheon-files:
status: New → Confirmed
Changed in cable:
status: New → Confirmed
importance: Undecided → Low
milestone: none → 0.2
David Gomes (davidgomes) on 2013-09-16
Changed in midori:
status: Won't Fix → Confirmed
status: Confirmed → Won't Fix
Cody Garver (codygarver) on 2013-09-19
Changed in pantheon-files:
importance: Undecided → Low
Timo Reimerdes (timorei) wrote :

I stumble upon this every single time I use files - avid keyboard user when laptop is not on docking. ;)

One of these details that are like a sore in the mouth: you just can't stop poking it once you know it's there. Just like that godaweful idea in midori: Everyone is ctrl+q - lets do it different.

Closing a series of windows right now looks like this:
fotos, midori, noise, files, terminal

fotos works
midori takes no simple shortcut (1 failure)
noise takes no shift-shortcut (1 failure)
files takes neither, but does react to alt+f4 (3 tries!)
And terminal uses something else entirely (usually I don't have to try all shortcuts, because terminals are so distinctive)

Ctrl+q -> Ctrl+q -> *wonders* -> Ctrl+Shift+q -> Ctrl+Shift+q -> *wonders* -> Ctrl+q -> *wonders*-> Alt+F4 -> *recognize* Ctrl+d

It might be minor, but it is REALLY anoying and feels... well... inconsistent.

Changed in pantheon-files:
assignee: nobody → Jeremy Wootten (jeremywootten)
status: Confirmed → In Progress
PerfectCarl (name-is-carl) wrote :

Fixed in files/all-views-vala

Daniel Fore (danrabbit) on 2014-11-23
Changed in pantheon-files:
status: In Progress → Fix Committed
milestone: none → freya-beta2
Daniel Fore (danrabbit) on 2015-02-10
Changed in pantheon-files:
status: Fix Committed → Fix Released
Cody Garver (codygarver) on 2015-04-11
Changed in pantheon-files:
milestone: freya-beta2 → 0.2
Cody Skinner (wskinner) wrote :

Ctrl + Shift + Q is the shortcut used to quit terminal. The CTRL key by itself in terminal is usually used for control commands, such as ^c.

Changed in pantheon-terminal:
status: New → Invalid
Daniel Fore (danrabbit) on 2016-07-29
Changed in appcenter:
importance: Undecided → Wishlist
no longer affects: midori
Changed in pantheon-mail:
importance: Undecided → Low
milestone: none → loki+1-beta1
status: New → Confirmed
Daniel Fore (danrabbit) on 2016-08-04
Changed in screenshot-tool:
importance: Undecided → Low
status: New → Confirmed
Changed in pantheon-calculator:
status: New → Confirmed
Changed in pantheon-mail:
assignee: nobody → Ralph Plawetzki (purejava)
status: Confirmed → In Progress
Daniel Fore (danrabbit) on 2016-08-09
Changed in pantheon-mail:
milestone: loki+1-beta1 → loki-rc1
status: In Progress → Fix Committed
Cody Garver (codygarver) on 2016-08-13
Changed in pantheon-mail:
milestone: loki-rc1 → 1.0
status: Fix Committed → Fix Released
Daniel Fore (danrabbit) on 2016-09-30
Changed in screenshot-tool:
milestone: none → juno-beta1
Changed in appcenter:
milestone: none → juno-beta1
Changed in pantheon-calculator:
milestone: none → juno-beta1
Cody Garver (codygarver) on 2016-10-07
Changed in pantheon-calculator:
importance: Undecided → Low
Daniel Fore (danrabbit) on 2016-10-26
Changed in appcenter:
status: New → Confirmed
Daniel Fore (danrabbit) on 2016-11-28
Changed in pantheon-calculator:
assignee: nobody → MarkoD (markodolar)
status: Confirmed → In Progress
Daniel Fore (danrabbit) on 2016-12-04
Changed in pantheon-calculator:
status: In Progress → Fix Committed
Daniel Fore (danrabbit) on 2016-12-06
Changed in screenshot-tool:
assignee: nobody → Daniel Fore (danrabbit)
status: Confirmed → In Progress
no longer affects: granite
Daniel Fore (danrabbit) on 2016-12-06
Changed in appcenter:
assignee: nobody → Daniel Fore (danrabbit)
status: Confirmed → In Progress
RabbitBot (rabbitbot-a) on 2016-12-07
Changed in appcenter:
status: In Progress → Fix Committed
Changed in screenshot-tool:
status: In Progress → Fix Committed
Cody Garver (codygarver) on 2017-01-19
Changed in pantheon-calculator:
status: Fix Committed → Fix Released
Cody Garver (codygarver) on 2017-02-10
Changed in screenshot-tool:
status: Fix Committed → Fix Released

Is there any possibility of implementing Ctrl+Q on Evince (PDF Viewer packaged by default with elementary OS)? Currently, its default seems to be Ctrl+W, which doesn't settle well with the 'defaults just work' idea.

Cody Garver (codygarver) on 2017-03-16
Changed in appcenter:
milestone: juno-beta1 → 0.1.4
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers