Got a SIGSEGV while executing native code. Debian Basenji 0.8.0

Reported by triple on 2012-12-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Basenji
Undecided
Unassigned

Bug Description

I have compiled basenji version 0.8.0 in debian squeeze, and when I added a volumen, basenji shows me:

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Abortado

After, Basenji is closed. The volumen added is very big, there are many files. I installed basenji version 0.8.0 because I use Debian squeeze. I tried to install basenji version 1.0.1 but i cannot install dbus-sharp-1.0 in Debian squeeze, so it show me:

Looking for required packages
Checking for package 'dbus-sharp-1.0'.. ERROR: Package named 'dbus-sharp-1.0' >= 0.7.0 not found.
Try adjusting your PKG_CONFIG_PATH environment variable.

Is this bug resolved in version 1.0.1? if not, Is it posible to resolve in other versión that I can install it in debian squeeze without dbus-sharp-1.0 >= 0.7.0?

I attached completed output of error.

triple (triplevic) on 2012-12-29
description: updated
description: updated
Patrick Ulbrich (pulb) wrote :

Thanks for your bugreport. This is most probably an libextractor bug and has been fixed in Basenji 0.9 which introdoced a new metadata extraction backend (taglib-sharp). Unfortunately Basenji 0.9 also introduces the dbus-sharp dependency so 0.8 seems to be the last version supported in your distro :-( As a workaround you can try to disable metadata extraction in the preferences dialog.

Changed in basenji:
status: New → Fix Committed
status: Fix Committed → Fix Released
Patrick Ulbrich (pulb) wrote :

Alternatively you can try to grab the latest 1.0.1 release and try to undo the dbus-sharp related changes, i.e.
* Rename DBus to NDesk.Dbus in DKDisk.cs -> http://bazaar.launchpad.net/~pulb/basenji/trunk/revision/567#Platform/src/Unix/IO/DkDisk.cs
* Replace the dbus-sharp-1.0/ dbus-sharp-glib-1.0 dependencies by ndesk-dbus-1.0/ndesk-dbus-glib-1.0 in the Platform makefile ->
http://bazaar.launchpad.net/~pulb/basenji/trunk/revision/570#Platform/Makefile
* Replace dbus-sharp* dependencies by ndesk-dbus* dependencies in configure -> http://bazaar.launchpad.net/~pulb/basenji/trunk/revision/570#configure

triple (triplevic) wrote :

I have disable metadata extraction in the preferences dialog but, when basenji has readed amount 200 Gb shows me "Argument is out of range". My disk has around 400Gbytes, Why?

I have tried to grab the latest release also (I replaced dbus-glib by ndesk-dbus in all Makefile, you can see in attach file), but doesn't work, make command shows:
..................
/bin/Release/Platform.Common.DB.dll -r:../Platform/bin/Release/Platform.dll -r:../MusicBrainz/bin/Release/MusicBrainz.dll
./src/Metadata/TagLibMetadataProvider.cs(35,52): error CS0234: The type or namespace name `Image' does not exist in the namespace `TagLib'. Are you missing an assembly reference?
Compilation failed: 1 error(s), 0 warnings
make[1]: *** [bin/Release/VolumeDB.dll] Error 1
make[1]: se sale del directorio `/home/vicente/Escritorio/basenji-1.0.1/VolumeDB'
make: *** [all-recursive] Error 1
.................
This error is because of I have install TagLib# version 2.0.3.7, I think that in this version there isn't "Image". Is posible to change the latest release 1.0.1 to work in Debian squeeze? or is imposible because of TagLib version?

triple (triplevic) wrote :

OutOfRange

Patrick Ulbrich (pulb) wrote :

Regarding the out of range error, please run Basenji in a terminal and post the output here. The size of your disk shouldn't matter.

There's an taglib build for Ubuntu 11.11 (natty) in this ppa -> https://launchpad.net/~pulb/+archive/basenji-daily/+packages, not sure if it is compatible wih debian squeeze though. If not, I'm afraid you have to compile taglib# yourself too (source is here https://launchpad.net/~pulb/+archive/basenji-daily/+files/taglib-sharp_2.0.4.0.orig.tar.gz).

Patrick Ulbrich (pulb) wrote :

(you need both, the libtaglib-cil-dev and the libtaglib2.0-cil package)

triple (triplevic) wrote :

Ok, the output is here (see line 123 onwards).

On the other hand, thanks for all, but the package to Ubuntu is not compatible to Debian, therefore I have compiled TagLib-Sharp 2.0.4 but when I run make, it print 5 errors:

./src/VolumeScanner/AudioCdVolumeInfo.cs(44,50): warning CS0420: `VolumeDB.VolumeScanner.AudioCdVolumeInfo.tracks': A volatile field references will not be treated as volatile
./src/Import/CdCatImport.cs(96,41): error CS0117: `System.Xml.XmlReaderSettings' does not contain a definition for `DtdProcessing'
/usr/lib/mono/gac/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll (Location of the symbol related to previous error)
./src/Import/CdCatImport.cs(238,56): error CS1502: The best overloaded method match for `string.Join(string, string[])' has some invalid arguments
/usr/lib/mono/2.0/mscorlib.dll (Location of the symbol related to previous error)
./src/Import/CdCatImport.cs(238,56): error CS1503: Argument `#2' cannot convert `System.Collections.Generic.IEnumerable<string>' expression to type `string[]'
./src/Import/CdCatImport.cs(400,118): error CS1502: The best overloaded method match for `string.Join(string, string[])' has some invalid arguments
/usr/lib/mono/2.0/mscorlib.dll (Location of the symbol related to previous error)
./src/Import/CdCatImport.cs(400,118): error CS1503: Argument `#2' cannot convert `System.Collections.Generic.List<string>' expression to type `string[]'
Compilation failed: 5 error(s), 1 warnings
make[1]: *** [bin/Release/VolumeDB.dll] Error 1

Why are there these errors now? Well... doesn't matter, I give up with 1.0.1 version, let's focus on "Out of range" error.

Patrick Ulbrich (pulb) wrote :

Hmm can't say why the out of range exception is thrown in the 0.8 release and I don't want to waste my time on outdated code. We really should try to get the 1.0.1 release working in your distro, it shouldn't be too hard. Basenji 1.0.1 should also work with Taglib 2.0.3.7 though you won't have image support (i. e. no image metadata like dimensions). Please try to recompile with VolumeDB/src/Metadata/TaglibMetadataProvider.cs replaced by the file attached (also apply your NDesk.DBus patch).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers