Intermittent Functional Test Failure

Bug #1499673 reported by Dave McCowan on 2015-09-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Barbican
Fix Released
Low
Dave McCowan

Bug Description

Sometimes, a functional test gate fails with the following traceback.

This is low priority. A recheck clears the problem. It usually happens in the dogtag gate which is non-voting.

The test case:
   1) creates a secret with a short expiration period
   2) reads the secret, gets 200
   3) wait until expiration
   4) tries to read the secret, gets 404

The problem is, when the gremlins are angry, the secret may expire between steps 1 and 2.

2015-09-02 17:03:45.012 | 2015-09-02 17:03:45.026 | ==============================
2015-09-02 17:03:45.015 | 2015-09-02 17:03:45.029 | Failed 1 tests - output below:
2015-09-02 17:03:45.017 | 2015-09-02 17:03:45.031 | ==============================
2015-09-02 17:03:45.019 | 2015-09-02 17:03:45.033 |
2015-09-02 17:03:45.026 | 2015-09-02 17:03:45.035 | api.v1.functional.test_secrets.SecretsTestCase.test_secret_create_then_expire_then_check
2015-09-02 17:03:45.026 | 2015-09-02 17:03:45.037 | ----------------------------------------------------------------------------------------
2015-09-02 17:03:45.026 | 2015-09-02 17:03:45.039 |
2015-09-02 17:03:45.031 | 2015-09-02 17:03:45.042 | Captured traceback:
2015-09-02 17:03:45.031 | 2015-09-02 17:03:45.044 | ~~~~~~~~~~~~~~~~~~~
2015-09-02 17:03:45.032 | 2015-09-02 17:03:45.046 | Traceback (most recent call last):
2015-09-02 17:03:45.034 | 2015-09-02 17:03:45.048 | File "/opt/stack/new/barbican/functionaltests/api/v1/functional/test_secrets.py", line 519, in test_secret_create_then_expire_then_check
2015-09-02 17:03:45.036 | 2015-09-02 17:03:45.050 | self.assertEqual(get_resp.status_code, 200)
2015-09-02 17:03:45.038 | 2015-09-02 17:03:45.052 | File "/usr/lib/python2.7/site-packages/testtools/testcase.py", line 350, in assertEqual
2015-09-02 17:03:45.040 | 2015-09-02 17:03:45.054 | self.assertThat(observed, matcher, message)
2015-09-02 17:03:45.042 | 2015-09-02 17:03:45.056 | File "/usr/lib/python2.7/site-packages/testtools/testcase.py", line 435, in assertThat
2015-09-02 17:03:45.044 | 2015-09-02 17:03:45.058 | raise mismatch_error
2015-09-02 17:03:45.046 | 2015-09-02 17:03:45.059 | testtools.matchers._impl.MismatchError: 404 != 200
2015-09-02 17:03:45.051 | 2015-09-02 17:03:45.062 |

Changed in barbican:
status: New → Triaged
importance: Undecided → Low
summary: - Intermittant Functional Test Failure
+ Intermittent Functional Test Failure
Dave McCowan (dave-mccowan) wrote :

Proposed fix: remove check in #2.

Changed in barbican:
assignee: nobody → Dave McCowan (dave-mccowan)
milestone: none → pike-1
Changed in barbican:
milestone: pike-1 → pike-2

Fix proposed to branch: master
Review: https://review.openstack.org/503059

Changed in barbican:
status: Triaged → In Progress

Reviewed: https://review.openstack.org/503059
Committed: https://git.openstack.org/cgit/openstack/barbican/commit/?id=4211114c4b1e16b31583ea871bdcce466b4dc8bf
Submitter: Jenkins
Branch: master

commit 4211114c4b1e16b31583ea871bdcce466b4dc8bf
Author: Dave McCowan <email address hidden>
Date: Tue Sep 12 10:00:08 2017 -0600

    Add extra time in functional test that fails intermittently

    The functional test that checks secret expiration fails
    intermittently because sometimes, when the gate is slow,
    the secret expires too quickly for the test.

    This patch adds an extra 10 seconds so the test will pass
    more consistently, while still maintaining the integrity
    of the test.

    Change-Id: I2f0df9b42dd2bf9dd600948164532fd31bb2a0d3
    Closes-Bug: #1499673

Changed in barbican:
status: In Progress → Fix Released

This issue was fixed in the openstack/barbican 6.0.0.0b1 development milestone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers