No sound with banshee

Reported by Ahmed Toulan on 2011-04-14
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Banshee
New
Medium
banshee (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: banshee

Playing from banshee produces no sound while it's working fine with rhythmbox.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: banshee 2.0.0-1ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: wl fglrx
Architecture: amd64
Date: Thu Apr 14 02:26:06 2011
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: banshee
UpgradeStatus: Upgraded to natty on 2011-04-12 (1 days ago)

Ahmed Toulan (thelinuxer) wrote :

On Thursday 14,April,2011 08:29 AM, thelinuxer wrote:
> Public bug reported:
>
> Binary package hint: banshee
>
> Playing from banshee produces no sound while it's working fine with
> rhythmbox.

Do you have Banshee muted, perhaps? Could you check the volume icon at the top
right corner of Banshee, and also check in the Applications tab of "Sound
Preferences" from the Sound Menu to see if Banshee is present and if it is muted
there?

  status incomplete

--
Kind regards,
Loong Jin

Changed in banshee (Ubuntu):
status: New → Incomplete
Ahmed Toulan (thelinuxer) wrote :

No Banshee is not muted. Volume is at max in Banshee and system volume. And yes Banshee is present in the Applications tab of "Sound preferences"

Chow Loong Jin (hyperair) wrote :

Hmm, that's something. Could you try running "banshee --debug" and posting the terminal output here, please?

Ahmed Toulan (thelinuxer) wrote :

Here is the debug file.

grizzo94 (nicolaramoso) wrote :

This bug also affects me, today it's 18th April..the final release it's getting closer..

Andres G. Aragoneses (knocte) wrote :

Can the people affected by this bug disable Gapless Support in Preferences to see if that fixes the issue?

Chow Loong Jin (hyperair) wrote :

Could you try disabling the gapless support in Edit->Preferences, and posting the log here when attempting to play a file?

Chow Loong Jin (hyperair) wrote :

Whoop de doo, looks like I missed by 10 seconds!

Ahmed Toulan (thelinuxer) wrote :

Disabled gapless support, still no luck

Here is the log file . I noticed line 82 [1 Debug 20:01:19.082] (libbanshee:player) Audiosink has volume: No

Could this be the source of the problem? Sorry I don't know much about this stuff.

grizzo94 (nicolaramoso) wrote :

I'll tried to deacrivate that function but for me too there's no luck..

Does this happen with the daily ppa?

https://live.gnome.org/Banshee/CommonQuestions/TestingOnUbuntu

The following post 2.0 commit which is found in the daily builds might help the situation.

http://git.gnome.org/browse/banshee/commit/?id=550b3be2e24583092730e4fd53c32942a8aace90

On Tuesday 19,April,2011 02:28 AM, grizzo94 wrote:
> I'll tried to deacrivate that function but for me too there's no luck..
>

Could you please try using the build from the daily PPA[1] and see if that
works? I have just heard from Bertrand that there are some volume related fixes
just after release.

[1] https://launchpad.net/~banshee-team/+archive/banshee-daily

--
Kind regards,
Loong Jin

Ahmed Toulan (thelinuxer) wrote :

I just added the daily repo and upgraded, still the same thing...

Ahmed Toulan (thelinuxer) wrote :

Also, no luck with the unstable repo.

Chow Loong Jin (hyperair) wrote :

On Tuesday 19,April,2011 03:31 AM, thelinuxer wrote:
> Also, no luck with the unstable repo.
>

Could you try enabling the replaygain option in the preferences, and then
posting the banshee --debug log here, please?

--
Kind regards,
Loong Jin

Ahmed Toulan (thelinuxer) wrote :

Using banshee from daily-build repo, thank you for going through this trouble :)
And no audio after changing this option.

Chow Loong Jin (hyperair) wrote :

On Tuesday 19,April,2011 08:54 AM, thelinuxer wrote:
> Using banshee from daily-build repo, thank you for going through this trouble :)
> And no audio after changing this option.
>
>
> ** Attachment added: "debug3.txt"
> https://bugs.launchpad.net/ubuntu/+source/banshee/+bug/760363/+attachment/2064395/+files/debug3.txt
>

Aha, this is what I was looking for.

[1 Debug 02:53:44.400] (libbanshee:player) scaled volume: 1.00 (ReplayGain) *
0.00 (User) = 0.00

So it was a volume issue after all, and one that's not been fixed upstream.

--
Kind regards,
Loong Jin

Changed in banshee (Ubuntu):
status: Incomplete → Triaged
Changed in banshee:
importance: Unknown → Medium
status: Unknown → New
Ahmed Toulan (thelinuxer) wrote :

Banshee is working fine now.

Chow Loong Jin (hyperair) wrote :

On 27/04/2011 18:17, thelinuxer wrote:
> Banshee is working fine now.
>

Eh? It's working fine? I didn't upload a fix though.. Could you check your
Banshee version? (apt-cache policy banshee in the terminal).

--
Kind regards,
Loong Jin

Chow Loong Jin (hyperair) wrote :

On 27/04/2011 19:30, Chow Loong Jin wrote:
> On 27/04/2011 18:17, thelinuxer wrote:
>> Banshee is working fine now.
>>
>
> Eh? It's working fine? I didn't upload a fix though.. Could you check your
> Banshee version? (apt-cache policy banshee in the terminal).
>

  affects ubuntu/banshee
  status incomplete

--
Kind regards,
Loong Jin

Changed in banshee (Ubuntu):
status: Triaged → Incomplete
Ahmed Toulan (thelinuxer) wrote :

banshee:
  Installed: 2.0.0+git20110423.r1.ded5624-0ubuntu1+natty
  Candidate: 2.0.0+git20110423.r1.ded5624-0ubuntu1+natty
  Version table:
 *** 2.0.0+git20110423.r1.ded5624-0ubuntu1+natty 0
        500 http://ppa.launchpad.net/banshee-team/banshee-daily/ubuntu/ natty/main amd64 Packages
        100 /var/lib/dpkg/status
     2.0.0-2ubuntu1 0
        500 http://eg.archive.ubuntu.com/ubuntu/ natty/main amd64 Packages

Chow Loong Jin (hyperair) wrote :

On 27/04/2011 19:46, thelinuxer wrote:
> banshee:
> Installed: 2.0.0+git20110423.r1.ded5624-0ubuntu1+natty
> Candidate: 2.0.0+git20110423.r1.ded5624-0ubuntu1+natty
> Version table:
> *** 2.0.0+git20110423.r1.ded5624-0ubuntu1+natty 0
> 500 http://ppa.launchpad.net/banshee-team/banshee-daily/ubuntu/ natty/main amd64 Packages
> 100 /var/lib/dpkg/status
> 2.0.0-2ubuntu1 0
> 500 http://eg.archive.ubuntu.com/ubuntu/ natty/main amd64 Packages
>

Okay, could you test with the Natty version (2.0.0-2ubuntu1) again, and with the
version in https://launchpad.net/~hyperair/+archive/staging, and post your
findings, please?

--
Kind regards,
Loong Jin

Prashant Gupta (prashu20) wrote :

same trouble no sound

Prashant Gupta (prashu20) wrote :

able to listen to songs in other players

Kamus (kamus) wrote :

Have you checked if in your gnome-volume-control -> Applications tab banshee entry is not muted?

Chow Loong Jin (hyperair) wrote :

On 29/04/2011 20:13, Prashant Gupta wrote:
> able to listen to songs in other players
>

Please test with the Banshee version in
https://launchpad.net/~hyperair/+archive/staging.

--
Kind regards,
Loong Jin

Changed in banshee (Ubuntu):
importance: Undecided → Low
internaciulo (internaciulo) wrote :

same problem here

$ apt-cache policy banshee
banshee:
  Installé : 2.0.1-1ubuntu1~hyper1+natty1
  Candidat : 2.0.1-1ubuntu1~hyper1+natty1
 Table de version :
 *** 2.0.1-1ubuntu1~hyper1+natty1 0
        500 http://ppa.launchpad.net/banshee-team/ppa/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status
     2.0.0-2ubuntu2 0
        500 http://fr.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
     2.0.0-2ubuntu1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

$ banshee --debug
(see attached file)

Kamus (kamus) on 2011-07-21
Changed in banshee (Ubuntu):
importance: Low → Medium
status: Incomplete → Triaged
Gregory Dillon (gregorydillon) wrote :

Hi,

This is a me too posting. "me too, audio is not working in Banshee"

For about 10 days the audio has often not worked in Banshee. Clicking the speaker icon, and sound preferences makes it look like the sound is playing when it is not.

The songs do play in Rhythmbox.

I don't have the technical skills to figure this out.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.