ipod doesn't appear in banshee

Bug #139226 reported by Aaron Isotton on 2007-09-12
76
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Banshee
Fix Released
Medium
podsleuth (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: banshee

This bug affects banshee 0.13.1 on ubuntu gutsy as of Sep 12 2007.

The ipod is correctly recognized by rhythmbox and other programs, but not by banshee. It used to work on feisty. The output when starting banshee from the console is the following:

aisotton@krake:~$ banshee
Could not create Library directory: /mnt/music
Debug: [9/12/2007 7:51:57 PM] (Loading audio profiles) - /usr/share/banshee/audio-profiles
Debug: [9/12/2007 7:51:59 PM] (Default player engine) - GStreamer 0.10
Debug: [9/12/2007 7:51:59 PM] (Audio CD Core Initialized) -
Debug: [9/12/2007 7:51:59 PM] (Testing device for DAP support) - /org/freedesktop/Hal/devices/volume_uuid_EA0C_A970
System.ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
  at System.Collections.Generic.List`1[IPod.Track].get_Item (Int32 ) [0x00000]
  at IPod.TrackDatabase.LoadOnTheGo (Int32 num) [0x00000]
  at IPod.TrackDatabase.LoadOnTheGo () [0x00000]
  at IPod.TrackDatabase.Reload (Boolean createFresh) [0x00000]
  at IPod.TrackDatabase..ctor (IPod.Device device, Boolean createFresh) [0x00000]
  at IPod.Device.LoadTrackDatabase (Boolean createFresh) [0x00000]
  at Banshee.Dap.Ipod.IpodDap.LoadIpod () [0x00000]
  at Banshee.Dap.Ipod.IpodDap.Initialize (Hal.Device halDevice) [0x00000]
  at Banshee.Dap.DapCore.AddDevice (Hal.Device device, System.Type type) [0x00000]
Information: [9/12/2007 7:52:11 PM] (Mass Storage Support Ignoring iPod) - The USB mass storage audio player support ignored an iPod. Either Banshee's iPod support is broken or missing, or the iPod itself may be corrupted.
Debug: [9/12/2007 7:52:11 PM] (DAP has not been added) - /org/freedesktop/Hal/devices/volume_uuid_EA0C_A970
Debug: [9/12/2007 7:52:11 PM] (Testing device for DAP support) - /org/freedesktop/Hal/devices/volume_uuid_389086E29086A64A
Debug: [9/12/2007 7:52:11 PM] (DAP has not been added) - /org/freedesktop/Hal/devices/volume_uuid_389086E29086A64A
Debug: [9/12/2007 7:52:11 PM] (Testing device for DAP support) - /org/freedesktop/Hal/devices/storage_serial_Apple_iPod_000A2700163FBB29_0_0
Debug: [9/12/2007 7:52:11 PM] (DAP has not been added) - /org/freedesktop/Hal/devices/storage_serial_Apple_iPod_000A2700163FBB29_0_0
Warning: [9/12/2007 7:52:11 PM] (Power Management Call Failed) - Cannot find GNOME Power Manager: Name org.gnome.PowerManager has no owner
Debug: [9/12/2007 7:52:11 PM] (Enabled multimedia keys support) - Using org.gnome.SettingsDaemon

Pedro Villavicencio (pedro) wrote :

Thanks for your report, which iPod do you have? I have a video one and it works fine, according to the message could be something broken in the iPod support in banshee, does hipo[1] works for you? they use the same library for accessing to the iPod's may you try it? thanks!.

1- apt-get install hipo

Changed in banshee:
importance: Undecided → Medium
status: New → Incomplete
Aaron Isotton (aisotton) wrote :

Hi Pedro. I have an iPod Video 80GB (model A1136). Hipo doesn't work for me either; here's the console output:

Error creating new device (/org/freedesktop/Hal/devices/volume_uuid_EA0C_A970): IPod.DatabaseReadException: Detected unsupported database version 24
  at IPod.DatabaseRecord.Read (IPod.DatabaseRecord db, System.IO.BinaryReader reader) [0x00000]
  at IPod.TrackDatabase.Reload (Boolean createFresh) [0x00000]
  at IPod.TrackDatabase..ctor (IPod.Device device, Boolean createFresh) [0x00000]
  at IPod.Device.LoadTrackDatabase (Boolean createFresh) [0x00000]
  at IPod.Device.LoadTrackDatabase () [0x00000]
  at IPod.Device.get_TrackDatabase () [0x00000]
  at IPod.Device.get_Name () [0x00000]
  at IPod.DeviceCombo.AddDevice (IPod.Device device) [0x00000]
  at IPod.DeviceCombo.OnNotify () [0x00000]

Pedro Villavicencio (pedro) wrote :

Yep could be some database issue, do you known which version of database do you have? There's seems to be some problems with newest databases.

Pedro Villavicencio wrote:
> Yep could be some database issue, do you known which version of database
> do you have? There's seems to be some problems with newest databases.
>

Hi Pedro

I re-synced my iPod with iTunes. Then I attached it to banshee again;
banshee complained that the database was "too new" and offered to
rebuild the database. I did so, and now everything works again.

Thanks for your time,
Aaron
--
Aaron Isotton | http://www.isotton.com
Women love cats. Men say they love cats, but when women aren't looking,
men kick cats.

Pedro Villavicencio (pedro) wrote :

That could be caused because of your Database Version, isn't supported yet by banshee, you should wait for a new release of ipod-cil and banshee. thanks.

Changed in banshee:
status: Incomplete → Triaged
Bernhard Schuster (drahnr) wrote :

Well, in gutsy it worked fine. In Hardy it doesn't. I've got a nano 2G 8GB black. System is hardy alpha (up to date) AMD x86_64

Just downloaded the absolutely great Hardy Heron, hoping to finally get a new working version of banshee after failing to get it to compile with iPod support in Gutsy. But the banshee version shipped with Hardy Heron Alpha 7 is not showing my iPod Nano!

It is a 1G 4GB iPod Nano. Worked in gutsy and feisty.

Jorenko (jorenko) wrote :

I have the same problem; I upgraded to Hardy today to get the fix for smart playlists in banshee only to find that it no longer recognizes my iPod. In fact, my iPod's database had been corrupted by gtkpod on gutsy, and gutsy banshee is the one who repaired it! So I don't see any reason why hardy's banshee wouldn't recognize the database.

Here's my startup output:

Debug: [3/26/2008 7:37:19 AM] (Loading audio profiles) - /usr/share/banshee/audio-profiles
Debug: [3/26/2008 7:37:19 AM] (Default player engine) - GStreamer 0.10
Debug: [3/26/2008 7:37:19 AM] (Audio CD Core Initialized) -
Debug: [3/26/2008 7:37:19 AM] (Testing device for DAP support) - /org/freedesktop/Hal/devices/volume_uuid_AAA4_7BC4
System.Exception: org.freedesktop.Hal.NoSuchProperty: No property org.podsleuth.ipod.serial_number on device with id /org/freedesktop/Hal/devices/volume_uuid_AAA4_7BC4
  at IDeviceProxy.GetPropertyString (System.String ) [0x00000]
  at Hal.Device.GetPropertyString (System.String key) [0x00000]
  at IPod.HalClient.HalDevice+HalProductionInfo..ctor (Hal.Volume volume) [0x00000]
  at IPod.HalClient.HalDevice..ctor (Hal.Volume volume) [0x00000]
  at Banshee.Dap.Ipod.IpodDap.LoadIpod () [0x00000]
Debug: [3/26/2008 7:37:19 AM] (DAP has not been added) - /org/freedesktop/Hal/devices/volume_uuid_AAA4_7BC4
Debug: [3/26/2008 7:37:19 AM] (Testing device for DAP support) - /org/freedesktop/Hal/devices/volume_uuid_20327e38_7e95_43cb_a86b_3b2d926fe5f0
Debug: [3/26/2008 7:37:19 AM] (DAP has not been added) - /org/freedesktop/Hal/devices/volume_uuid_20327e38_7e95_43cb_a86b_3b2d926fe5f0
Debug: [3/26/2008 7:37:19 AM] (Testing device for DAP support) - /org/freedesktop/Hal/devices/volume_uuid_502fd170_a9de_4f08_a525_f256ad2d11f0
Debug: [3/26/2008 7:37:19 AM] (DAP has not been added) - /org/freedesktop/Hal/devices/volume_uuid_502fd170_a9de_4f08_a525_f256ad2d11f0
Debug: [3/26/2008 7:37:19 AM] (Testing device for DAP support) - /org/freedesktop/Hal/devices/storage_serial_Apple_iPod_000A27001595B412_0_0
Debug: [3/26/2008 7:37:19 AM] (DAP has not been added) - /org/freedesktop/Hal/devices/storage_serial_Apple_iPod_000A27001595B412_0_0
Debug: [3/26/2008 7:37:20 AM] (Enabled multimedia keys support) - Using org.gnome.SettingsDaemon

Debug: [3/26/2008 7:37:19 AM] (Testing device for DAP support) -
/org/freedesktop/Hal/devices/volume_uuid_20327e38_7e95_43cb_a86b_3b2d926fe5f0
Debug: [3/26/2008 7:37:19 AM] (DAP has not been added) -
/org/freedesktop/Hal/devices/volume_uuid_20327e38_7e95_43cb_a86b_3b2d926fe5f0

Looks like they have just stopped shipping banshee with DAP (Digital
Audio Player) support. What their reasons may be, I don't know ...

Sebastian Dröge (slomo) wrote :

DAP support is still shipped with banshee... this must be something else.

Timo Aaltonen (tjaalton) wrote :

This is a regression, worked fine with gutsy and in hardy too until at some point it got broken (can't tell when, it's not that often I sync the library..).

So, adding a release milestone. Maybe it's a bug in hal?

Changed in banshee:
milestone: none → ubuntu-8.04
Jan Michael Ibanez (jmibanez) wrote :

Installing podsleuth and adding user haldaemon to group plugdev resolved the issue for me.

As a point of comparison, a laptop I own had a similar issue, and installing podsleuth fixed things. This laptop was originally installed with Edgy, which was then upgraded to Feisty (on Feisty release) then Gutsy on release, then finally to Hardy Beta recently. User and group definitions were not touched from then on.

Another laptop I own was installed from scratch with Hardy Beta then upgraded to the latest updates. I found the same issue as this one, where Banshee didn't see my iPod. I installed podsleuth, and that didn't fix things (in fact, running podsleuth would complain that the method it was looking for in HAL wasn't found).

However, doing a compare of user and group definitions between the two machines had haldaemon as a member of plugdev, floppy, and cdrom on the dist-upgraded machine; haldaemon on the new machine didn't have such memberships. Adding haldaemon to plugdev then solved it for me.

Andrew Conkling (andrewski) wrote :

Jan, and others with Hardy: Hardy-related problems/regressions are likely to
be symptoms of bug 215761.

Timo Aaltonen (tjaalton) wrote :

Indeed, works for me now. Removing the milestone.

Changed in banshee:
milestone: ubuntu-8.04 → none
Andrew Conkling (andrewski) wrote :

Aaron, could you test Banshee 0.13.2 in Hardy to see if the changes affect this behavior?

Changed in banshee:
status: Triaged → Incomplete
Aaron Isotton (aisotton) wrote :
  • unnamed Edit (405 bytes, text/html; charset=ISO-8859-1)

Hi,

As I reported earlier my ipod works fine since I re-synced it with iTunes.
It worked for gutsy (with whatever version was shipped with gutsy) and it
works for hardy (with 0.13.2).

Sadly I can't reproduce the bug since I have no idea what happened in the
first place.

Greetings,
Aaron
--
Aaron Isotton - http://www.isotton.com/

Andrew Conkling (andrewski) wrote :

OK, closing this. Sorry Aaron, I missed your previous comment about it working.

Changed in banshee:
status: Incomplete → Invalid
Luke Hoersten (lukehoersten) wrote :

Still doesn't work for me in banshee 0.13.2. What debug info do you need?

My 5th generation 80 GB Video IPod worked with Gutsy.

After upgrading to Hardy it is not visible from Banshee, anymore.

Banshee says, on the console:

Debug: [11.05.2008 17:59:21] (Testing device for DAP support) - /org/freedesktop/Hal/devices/storage_serial_Apple_iPod_000A2700161329C9_0_0
Debug: [11.05.2008 17:59:22] (DAP has not been added) - /org/freedesktop/Hal/devices/storage_serial_Apple_iPod_000A2700161329C9_0_0
Debug: [11.05.2008 17:59:24] (Testing device for DAP support) - /org/freedesktop/Hal/devices/volume_uuid_1C72_91F8
Debug: [11.05.2008 17:59:24] (Waiting for possible DAP to mount) - /org/freedesktop/Hal/devices/volume_uuid_1C72_91F8
Debug: [11.05.2008 17:59:24] (DAP has not been added) - /org/freedesktop/Hal/devices/volume_uuid_1C72_91F8
Debug: [11.05.2008 17:59:25] (Possible DAP has mounted) - /org/freedesktop/Hal/devices/volume_uuid_1C72_91F8
Debug: [11.05.2008 17:59:25] (Testing device for DAP support) - /org/freedesktop/Hal/devices/volume_uuid_1C72_91F8
System.Exception: org.freedesktop.Hal.NoSuchProperty: No property org.podsleuth.ipod.serial_number on device with id /org/freedesktop/Hal/devices/volume_uuid_1C72_91F8
  at IDeviceProxy.GetPropertyString (System.String ) [0x00000]
  at Hal.Device.GetPropertyString (System.String key) [0x00000]
  at IPod.HalClient.HalDevice+HalProductionInfo..ctor (Hal.Volume volume) [0x00000]
  at IPod.HalClient.HalDevice..ctor (Hal.Volume volume) [0x00000]
  at Banshee.Dap.Ipod.IpodDap.LoadIpod () [0x00000]
Debug: [11.05.2008 17:59:26] (DAP has not been added) - /org/freedesktop/Hal/devices/volume_uuid_1C72_91F8

Is there anything that I can do to halp in debugging te issue?

Best Regards,

Peter

Brandon Hale (brandon) wrote :

I don't understand why this bug keeps getting closed. It has affected me consistently on 3 different ipods and 2 different PCs.

Changed in banshee:
status: Invalid → New
Brandon Hale (brandon) wrote :

http://pastebin.ca/raw/1009915

Here you will find a wealth of debug output from all relevant tools.
Upstream claims this is a distro specific issue as it works as advertised on SuSE. It appears that Ubuntu and Gentoo have reports on the subject.

Pedro Villavicencio (pedro) wrote :

seems to be a podsleuth issue according to bug http://bugzilla.gnome.org/show_bug.cgi?id=531927

Changed in podsleuth:
status: New → Triaged
Brandon Hale (brandon) wrote :

Similar bug reported in Fedora 9: https://bugzilla.redhat.com/show_bug.cgi?id=445611
Patch applied in Fedora: http://pastebin.ca/1034330

Similar upstream bug: http://bugzilla.gnome.org/show_bug.cgi?id=531927

Brandon Hale (brandon) wrote :

Fedora patch improves things to the point that the podsleuth cli command and banshee recognize my newer Ipod. There are still some issues with the old HP 40G black and white ipod that I do not believe are purely related to the HAL bug.

Changed in banshee:
status: Unknown → New
Brandon Hale (brandon) wrote :

Fedora patch resolved problem after doing podsleuth --rescan -- the patch ONLY applies to the console 'podsleuth' tool at this point, and is not believed to address the root of the problem:

<@abock|out> f) what I think *might* have happened
<@abock|out> is that when the console client gets patched, if you run --rescan,
          it probably gets the shit merged into the HAL tree
<@abock|out> the *real bug* is that fedora and ubuntu aren't executing the HAL
          callout to merge the stuff in the first place when teh device is
          plugged in
<@abock|out> at the end of the day, the real bug, from what I can tell, is in
          the distro
<@abock|out> those HAL's are not running the callout we install
<@abock|out> --rescan probably just fudges it
<@abock|out> bhale: the real code is in HalPopulator.cs

I am going to come back to this on Sunday -- the patch I mentioned is now in SVN, but we are going to keep digging to make sure we have a clean fix.

psyopper (bfranks) wrote :

Having the same issue with an Ipod Mini 1st gen.

Interestingly I don't and never have had podsleuth installed. At least not to my knowledge. GTKPod does show the correct music on the device.

I noticed something else interesting recently. When I upgraded (gutsy->hardy) my IDE drives moved from HDx to SDx. Threw me for a loop why none of my partitions were mounting correctly through fstab. Could this be related?

Changed in banshee:
status: New → Incomplete
Jorge Castro (jorge) wrote :

Upstream has released a new version of podsleuth:

http://banshee-project.org/files/podsleuth/podsleuth-0.6.2.tar.bz2

Brandon, Bockover tested ipod support with ~10 ipods in Hardy and found no problems, can you guys try this and report back?

psyopper, gtkpod doesn't use podsleuth so this is specific to programs that use podsleuth.

psyopper (bfranks) wrote :

I mentioned GTKPod only as a reference to the fact that it connects and is otherwise readable except by Banshee.

For some reason one of the updates that came down on June 5th resolved the issue for me. There was a bunch of stuff in there, not sure which one fixed it. Banshee recognized that it was an Ipod, but it didn't recognize which one and automatically redirected me to the Banshee "add and ipod to our database" page. My Ipod support in Banshee is now resolved and is operating as expected.

For fun I tried installing podsleuth-0.6.2 from the link above and I get a mono dependency problem. Looks like Hardy has Mono 1.2.6 and Podsleuth is looking for 1.1.10... I'm a relative Linux newb, please be patient if this is a newb mistake.

/podsleuth-0.6.2$ ./configure
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking how to create a ustar tar archive... gnutar
checking whether to enable maintainer-specific portions of Makefiles... no
checking for a BSD-compatible install... /usr/bin/install -c
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for MONO_MODULE... configure: error: Package requirements (mono >= 1.1.10) were not met:

No package 'mono' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables MONO_MODULE_CFLAGS
and MONO_MODULE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Sanchola (sanchola) wrote :

This is the output from podsleuth. My iPod is 4th Generation

iPod Found [/org/freedesktop/Hal/devices/volume_uuid_C701_14D8]
  * Generic Device Properties
    - Block Device: /dev/sdb2
    - Mount Point: /media/SAMPOD
    - Read Only: False
    - Volume Size: 40 GiB
  * General iPod Properties
    - Serial Number:
    - Firewire ID: 000A2700029CFD6A
    - Firmware Version:
    - iPod_Control:
    - Extra Capabilities: none

Unhandled Exception: System.Exception: org.freedesktop.Hal.NoSuchProperty: No property org.podsleuth.ipod.production.year on device with id /org/freedesktop/Hal/devices/volume_uuid_C701_14D8
  at IDeviceProxy.GetPropertyInteger (System.String ) [0x00000]
  at Hal.Device.GetPropertyInteger (System.String key) [0x00000]
  at PodSleuth.HalFrontend.HalClient.GetProductionInfo (Hal.Volume volume) [0x00000]
  at PodSleuth.HalFrontend.HalClient.DumpSleuthableIpod (Hal.Volume volume) [0x00000]
  at PodSleuth.HalFrontend.HalClient.SleuthIpod (Hal.Volume volume) [0x00000]
  at PodSleuth.HalFrontend.HalClient.Run (System.String[] args) [0x00000]
  at PodSleuth.HalFrontend.HalEntry.Main (System.String[] args) [0x00000]

I have used both podsleuth from ubuntu as well as the source distro linked elsewhere in the comments here. In both cases, I get output like the above from Sanchola; as a result, Banshee is unable to find my device.

My exact output:

 % podsleuth --rescan
Rescanning device [/org/freedesktop/Hal/devices/volume_uuid_A0E8_7B92]
iPod Found [/org/freedesktop/Hal/devices/volume_uuid_A0E8_7B92]
  * Generic Device Properties
    - Block Device: /dev/sdc2
    - Mount Point: /media/WEIER O'PHI_
    - Read Only: False
    - Volume Size: 40 GiB
  * General iPod Properties
    - Serial Number:
    - Firewire ID: 000A270002A95664
    - Firmware Version:
    - iPod_Control:
    - Extra Capabilities: none

Unhandled Exception: System.Exception: org.freedesktop.Hal.NoSuchProperty: No property org.podsleuth.ipod.production.year on device with id /org/freedesktop/Hal/devices/volume_uuid_A0E8_7B92
  at IDeviceProxy.GetPropertyInteger (System.String ) [0x00000]
  at Hal.Device.GetPropertyInteger (System.String key) [0x00000]
  at PodSleuth.HalFrontend.HalClient.GetProductionInfo (Hal.Volume volume) [0x00000]
  at PodSleuth.HalFrontend.HalClient.DumpSleuthableIpod (Hal.Volume volume) [0x00000]
  at PodSleuth.HalFrontend.HalClient.SleuthIpod (Hal.Volume volume) [0x00000]
  at PodSleuth.HalFrontend.HalClient.Run (System.String[] args) [0x00000]
  at PodSleuth.HalFrontend.HalEntry.Main (System.String[] args) [0x00000]

Ian Atkin (email-ian-atkin) wrote :

I have been having similar problems with both Banshee 1.0.0 and 1.2.0 on Hardy. My 3G classic iPod (connected by firewire) mounts, appears on the desktop and works fine with Rhythmbox, but Banshee does not pick it up. I don't have any outstanding updates.

Running podsleuth from terminal gives:

Found an iPod device, but it is not known by PodSleuth:
   Error: org.podsleuth.* properties are missing
   UDI: /org/freedesktop/Hal/devices/volume_uuid_AF8A_9380
   Block Device: /dev/sdb2
   Mount Point: /media/IMPALER'S I

   Cause: PodSleuth may not be installed properly, the HAL daemon may need
          to be restarted and/or the device needs to be refreshed.

Reinstalling podsleuth and rebooting did not help. The podsleuth debug file contains:

** Could not read iPod property list from SCSI code page **
System.IO.IOException: Could not read SCSI codepage 0xc0
  at PodSleuth.ScsiReader.Inquiry (Int32 sg_fd, Int32 cmddt, Int32 evpd, Int32 pg_op, Int32 mx_resp_len, Int32 noisy, Int32 verbose, System.Int32& offset) [0x00020] in /build/buildd/podsleuth-0.6.2/src/PodSleuth/PodSleuth/ScsiReader.cs:65
  at PodSleuth.ScsiReader.ReadPage (System.String devicenode, Int32 page) [0x0001a] in /build/buildd/podsleuth-0.6.2/src/PodSleuth/PodSleuth/ScsiReader.cs:37
  at PodSleuth.ScsiReader.ReadPlist (System.String devicenode) [0x00000] in /build/buildd/podsleuth-0.6.2/src/PodSleuth/PodSleuth/ScsiReader.cs:24
  at PodSleuth.Device.LoadDevicePlist () [0x0000b] in /build/buildd/podsleuth-0.6.2/src/PodSleuth/PodSleuth/Device.cs:113
Pre-Mount Settings:
  - UDI: /org/freedesktop/Hal/devices/volume_uuid_AF8A_9380
  - Block Device: /dev/sdb2
  - Temporary Mount Point: /tmp/podsleuth-mount-0
  - FS Type: vfat

Exception:

System.NullReferenceException: Object reference not set to an instance of an object
  at PodSleuth.Device.ReadPlistBoolNullable (System.String key) [0x00000] in /build/buildd/podsleuth-0.6.2/src/PodSleuth/PodSleuth/Device.cs:91
  at PodSleuth.Device.ReadPlistBool (System.String key) [0x00000] in /build/buildd/podsleuth-0.6.2/src/PodSleuth/PodSleuth/Device.cs:105
  at PodSleuth.Device.LoadDevicePlist () [0x00052] in /build/buildd/podsleuth-0.6.2/src/PodSleuth/PodSleuth/Device.cs:120
  at PodSleuth.Device.Load () [0x0000c] in /build/buildd/podsleuth-0.6.2/src/PodSleuth/PodSleuth/Device.cs:62
  at PodSleuth.HalFrontend.HalPopulator.RunInternal (System.String[] args) [0x000a7] in /build/buildd/podsleuth-0.6.2/src/PodSleuth.Hal/PodSleuth.HalFrontend/HalPopulator.cs:69

I'm a relative newcomer to Linux so any pointers as to what I can do would be much appreciated.

Carl-Erik Kopseng (kopseng) wrote :

@Ian Atkin: I compiled Banshee 1.2.1 in mid-August, and that works perfectly! Haven't tried with the old series, but that is so buggy that I don't even bother ...

Carl-Erik Kopseng (kopseng) wrote :

btw. when you compile Banshee from scratch you need to specify some parameters to enable iPod support. That might be the reason why it doesn't work for you (Ian). Don't remember exactly what, but typing "./config --help" when you compile it will probably get you what you want.

Changed in banshee:
status: Incomplete → New

I compiled Banshee 1.2.1 today, but still no luck. iPod support *is* enabled (all options are enabled), but the iPod still is not recognized.

My iPod is a 4g 40G windows-formatted iPod (one of the HP branded ones), marked as "Version 3.1.1". Amarok is able to detect it when I point amarok to the mount point, and I've successfully synced to and from that program; in fact, I had no problems prior to version 1.0 of Banshee.

Compiling Banshee from source does not install podsleuth, so I'm not sure if podsleuth is working currently; in previous attempts with >= 1.0, it threw an exception when detecting the year.

RedOranges (redoranges) wrote :

I am having the similar problems
I installed banshee from the launchpad ppa using synaptic
my 1st gen shuffle wont show up in banshee (podsleuth output below)

Also my ipod mini will show up, and its content, but the second i try and modify anything (add/delete/play) banshee crashes on me

podsleuth for shuffle:
iPod Found [/org/freedesktop/Hal/devices/volume_label_IPOD]
  * Generic Device Properties
    - Block Device: /dev/sdc1
    - Mount Point: /media/IPOD
    - Read Only: False
    - Volume Size: 520 MiB
  * General iPod Properties
    - Serial Number:
    - Firewire ID: 000A270010561E0A
    - Firmware Version: 1.1.5
    - iPod_Control: /iPod_Control
    - Extra Capabilities: none

Unhandled Exception: System.Exception: org.freedesktop.Hal.NoSuchProperty: No property org.podsleuth.ipod.production.year on device with id /org/freedesktop/Hal/devices/volume_label_IPOD
  at IDeviceProxy.GetPropertyInteger (System.String ) [0x00000]
  at Hal.Device.GetPropertyInteger (System.String key) [0x00000]
  at PodSleuth.HalFrontend.HalClient.GetProductionInfo (Hal.Volume volume) [0x00000]
  at PodSleuth.HalFrontend.HalClient.DumpSleuthableIpod (Hal.Volume volume) [0x00000]
  at PodSleuth.HalFrontend.HalClient.SleuthIpod (Hal.Volume volume) [0x00000]
  at PodSleuth.HalFrontend.HalClient.Run (System.String[] args) [0x00000]
  at PodSleuth.HalFrontend.HalEntry.Main (System.String[] args) [0x00000]

podsleuth for mini:
podsleuth
iPod Found [/org/freedesktop/Hal/devices/volume_uuid_D7D2_6576]
  * Generic Device Properties
    - Block Device: /dev/sdc2
    - Mount Point: /media/IPOD
    - Read Only: False
    - Volume Size: 4 GiB
  * General iPod Properties
    - Serial Number: 2X5430CVS4J
    - Firewire ID: 000A2700024B4B02
    - Firmware Version: 1.4.1
    - iPod_Control: /iPod_Control
    - Extra Capabilities: podcast
    - Production Info: 463 in October, 2005 from factory 2X
  * iPod Model Properties
    - Device Class: unknown
    - Model information could not be determined
      Try a `podsleuth --update --rescan` or visit
      http://banshee-project.org/IpodDataSubmit
  * Image Types Supported
    - Photos: False
    - Album Art: False
    - Chapter Images: False

Changed in banshee:
status: New → Fix Released

I'm having the same problems of some of the bug reporters. Podsleuth is saying this:

Found an iPod device, but it is not known by PodSleuth:
   Error: org.podsleuth.* properties are missing
   UDI: /org/freedesktop/Hal/devices/volume_uuid_9502_7D58
   Block Device: /dev/sdb2
   Mount Point: /media/IPOD DE DAN

   Cause: PodSleuth may not be installed properly, the HAL daemon may need
          to be restarted and/or the device needs to be refreshed.

   Note: A PodSleuth debug log was found: /tmp/podsleuth-debug
          This file may provide more details or can be useful to
          developers. Please save it somewhere else and use it in
          a bug report. See http://banshee-project.org/PodSleuth

Attached you can find the debug output of podsleuth. So something is wrong but I don't know what.

yellowpinky (matthew-davis77) wrote :

I had the same problem on 8.04 lts but installed podsleuth via synaptic and banshee then found my ipod. It could not read it and prompted me to rebuild the database. Once this was done it works.

I'm still having the same problem with the latest banshee and podsleuth. I don't know what to do to try to fix it, so basically I'm not using anymore Banshee.

I too am still having this problem with the latest Ubuntu 9.10 where my ipod 5.5g video isn't detected. It is detected in Rhythm Box. The issue seems to be with podsleuth in detecting the ipod

podsleuth --rescan
No iPods were found in the HAL device tree

Johannes Maibaum (jmaibaum) wrote :

Could this be related to the ongoing deprecation of HAL in Ubuntu 9.10? I have got the same problem with my iPod 5.5G and Banshee from the standard repos.

Chow Loong Jin (hyperair) wrote :

On Sunday 18,October,2009 07:40 PM, Johannes Maibaum wrote:
> Could this be related to the ongoing deprecation of HAL in Ubuntu 9.10?
> I have got the same problem with my iPod 5.5G and Banshee from the
> standard repos.
>
Yes, it is related. Basically podsleuth needs to be ported over to use
DeviceKit-Disks. Patches welcome, of course.

--
Kind regards,
Chow Loong Jin (GPG: 0x8F02A411)
Ubuntu Contributing Developer

Jürgen Geuter (tante) wrote :

https://bugzilla.gnome.org/show_bug.cgi?id=586508 is the relevant podsleuth bug in Gnome Bugzilla

Matt (wenger-matthew) wrote :

This bug occurred on my Ubuntu installation after I upgraded from version 9.04 to 9.10. Prior to upgrading Banshee worked fine with my iPod (video nano 2nd generation).

aymspig (aymeric-spiga) wrote :

I have the problem too.

Upstream has a fix for this:

https://bugzilla.gnome.org/show_bug.cgi?id=586508#c17

Basically we'll need to upgrade to Podsleuth 0.6.6 and a Banshee after the following commit: http://git.gnome.org/cgit/banshee/commit/?id=3aac4c2f77b30de378065222b4261bcb9fcf12bd

Chow Loong Jin (hyperair) wrote :

On Thursday 10,December,2009 12:32 AM, David Nielsen wrote:
> Upstream has a fix for this:
>
> https://bugzilla.gnome.org/show_bug.cgi?id=586508#c17
>
> Basically we'll need to upgrade to Podsleuth 0.6.6 and a Banshee after
> the following commit:
> http://git.gnome.org/cgit/banshee/commit/?id=3aac4c2f77b30de378065222b4261bcb9fcf12bd
>
You're looking at the wrong bug. This bug is an ancient one that has been fixed
long ago. The symptoms may be the same, but the underlying cause is very different.

Either way, I've just backported that commit into the upcoming 1.5.2 package,
now pending upload.

--
Kind regards,
Chow Loong Jin (GPG: 0x8F02A411)
Ubuntu Contributing Developer

Any ideas when the 1.5.2 package and podsleuth 0.6.6 will be available?

Thanks.

Chow Loong Jin (hyperair) wrote :

On Monday 18,January,2010 09:04 PM, Confusion_music wrote:
> Any ideas when the 1.5.2 package and podsleuth 0.6.6 will be available?
>
> Thanks.
>
There isn't a podsleuth 0.6.6. But Banshee 1.5.2 and Podsleuth 0.6.5-2 which
have the fixes for Karmic's iPod problem will take some time reaching the
archives due to an ongoing transition in Debian and Lucid. In the meantime, you
can use the PPA:

https://launchpad.net/~banshee-team/+archive/ppa

--
Kind regards,
Chow Loong Jin (GPG: 0x8F02A411)
Ubuntu Contributing Developer

j polanik (ndclothing) wrote :

I've got the ppa added and both Banshee and Podsleuth are updated. I still can't get my iPod to show up in Banshee. When I plug it in Banshee opens but there's no iPod in the left column. When I run podsleuth it sees the iPod just fine (didn't do this before the update). If I start Banshee from the terminal I get this when Podsleuth finds the iPod:

[Info 21:11:01.160] Received device command: action = Activate, device = /media/Ipod

But after waiting there's still nothing in the column. Am I missing something? I'd much rather use Banshee than Rhythmbox or GtkPod.

I am having the same issue. I use the Banshee Team PPA. Podsleuth finds the ipod when I check from the terminal. Banshee reports "Received device command: action = Activate, device = /media/Ipod", but there is no Ipod in Banshee.

I used the version from Chow Loong Jin's PPA and Banshee managed to find my ipod and even put some music on it, but then it hung so I had to force it to quit. Now it wont see the ipod and goes 96-100% cpu every time I try to quit, so I have to kill the process manually.

Incidentally similar to the problem I have with Rhythmbox, I made a playlist on the ipod when Banshee was seeing it and added some songs to it, but once the ipod was disconnected the playlist disappeared.

Any ideas? Thanks.

Chow Loong Jin (hyperair) wrote :

On Monday 25,January,2010 05:38 AM, Confusion_music wrote:
> I used the version from Chow Loong Jin's PPA and Banshee managed to find
> my ipod and even put some music on it, but then it hung so I had to
> force it to quit. Now it wont see the ipod and goes 96-100% cpu every
> time I try to quit, so I have to kill the process manually.
>
> Incidentally similar to the problem I have with Rhythmbox, I made a
> playlist on the ipod when Banshee was seeing it and added some songs to
> it, but once the ipod was disconnected the playlist disappeared.
>
> Any ideas? Thanks.
>
Could you try running 'banshee --debug' in a terminal, and then running 'killall
-SIGQUIT banshee-1' in a separate terminal when it hangs? Banshee should then
dump a stack trace to the terminal. That should help pinpoint what Banshee's
doing that's hanging.

--
Kind regards,
Chow Loong Jin (GPG: 0x8F02A411)
Ubuntu Contributing Developer

samba (sambismo) wrote :

I Get this temporary fix:

In order to get banshee to see the ipod,
1. close banshee
2. use terminal to killall -9 nautilus (with the ipod disconnected).
3. Then connect the ipod, give it a minute,
4. then you can reinstate nautilus.

Most likely nautilus will go ahead and mount it at that point, if not, you may need to manually mount the ipod. From here you can go ahead and start banshee, where it will then recognize the ipod like normal.

good luck.

norman784 (normanpaniagua) wrote :

Thanks samba, now I can sync my ipod with banshee

@ Chow Loong Jin

>Could you try running 'banshee --debug' in a terminal, and then running 'killall
>-SIGQUIT banshee-1' in a separate terminal when it hangs? Banshee should then
>dump a stack trace to the terminal. That should help pinpoint what Banshee's
>doing that's hanging.

I'm still waiting to do this, but the ipod is my wife's and she uses it to teach dance on an evening so I've not managed to get my hands on it again. She's been using itunes on a different computer, while I'm not around. I'll post something more useful as soon as I can.

Thanks,

Bruce

Tim Skinner (timskinner1) wrote :

I can confirm samba's temporary fix has worked for me. I had an ipod which was previously only appearing in rhythmbox, but now banshee has detected.

Chow Loong Jin (hyperair) wrote :

Can anyone test if the issue is now fixed with the Ubuntu Maverick's podsleuth (0.6.7-1)? This version is also available from the Banshee PPA (https://launchpad.net/~banshee-team/+archive/banshee-stable) which can be enabled using "sudo add-apt-repository ppa:banshee-team/banshee-stable".

Changed in podsleuth (Ubuntu):
status: Triaged → Incomplete

I have tested it today with the last podsleuth version. It detects the iPod but it doesn't recognize the iPod DB. I've upgraded the firmware of my iPod to 1.1.3 with the same results. When plugged, Banshee says that the DB has to be rebuilt, and after doing that with the firmware 1.0.2 the iPod was broken. I had to launch it in disk mode to format it from iTunes. Thus, I think it is not fixed at all, at least with my iPod.

Chow Loong Jin (hyperair) wrote :

On Tue, 22 Jun 2010 15:58:25 -0000
Daniel Lombraña <email address hidden> wrote:

> I have tested it today with the last podsleuth version. It detects the
> iPod but it doesn't recognize the iPod DB. I've upgraded the firmware
> of my iPod to 1.1.3 with the same results. When plugged, Banshee says
> that the DB has to be rebuilt, and after doing that with the firmware
> 1.0.2 the iPod was broken. I had to launch it in disk mode to format
> it from iTunes. Thus, I think it is not fixed at all, at least with
> my iPod.
>

That's a different bug, probably under ipod-sharp, which is one of the
libraries Banshee uses to interact with iPods.

--
Kind regards,
Chow Loong Jin

OK. Thus, do we open a new bug?

Chow Loong Jin (hyperair) wrote :

On Wed, 23 Jun 2010 06:56:35 -0000
Daniel Lombraña <email address hidden> wrote:

> OK. Thus, do we open a new bug?
>

If you can't find one that matches, then please do. It's probably an
upstream issue either way, so just report it at
http://bugzilla.gnome.org/.

--
Kind regards,
Chow Loong Jin

Changed in banshee:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.