BamfView's dispose() method doesn't invoke the superclass' dispose()

Bug #986888 reported by Charles Kerr on 2012-04-22
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
BAMF
Low
Charles Kerr
Unity
Fix Released
Low
Charles Kerr
bamf (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

SRU testcase not needed

BamfView's dispose() method doesn't invoke the superclass' dispose() method.

Fixed by adding a one-liner to the end of bamf_view_dispose():

+ G_OBJECT_CLASS (bamf_view_parent_class)->dispose (object);

Changed in bamf:
status: New → Fix Committed
assignee: nobody → Charles Kerr (charlesk)
milestone: none → 0.2.116
Changed in unity:
status: New → Fix Committed
importance: Undecided → Low
assignee: nobody → Charles Kerr (charlesk)
milestone: none → 5.12.0
Omer Akram (om26er) on 2012-04-26
Changed in bamf (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
description: updated
Didier Roche (didrocks) on 2012-04-27
Changed in bamf:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.118-0ubuntu1

---------------
bamf (0.2.118-0ubuntu1) quantal; urgency=low

  [ Didier Roche ]
  * New upstream release. (0.2.116)
    - multiple instances or double icons of application detected on bamfdaemon
      respawn (LP: #928912)
    - unity confused with chrome/chromium web apps (LP: #692462)
    - BamfView's dispose() method doesn't invoke the superclass' dispose()
      (LP: #986888)
  * debian/control:
    - remove Multi-Arch: same for the -dbg package
      (Closes: #669980, #658057)

  [ Alan Pope ]
  * New upstream release.
    - Unity crashed in bamf_application_on_window_removed (LP: #1000577)
    - Locked smuxi launcher icon does not indicate smuxi running status
      (LP: #999820)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - the RunningApplicationsChanged signal is no longer emitted when an
      application is closed since r460 (LP: #989551)
 -- Alan Pope <email address hidden> Wed, 23 May 2012 09:10:08 +0100

Changed in bamf (Ubuntu):
status: Confirmed → Fix Released
Changed in bamf (Ubuntu Precise):
status: Confirmed → Fix Committed

Hello Charles, or anyone else affected,

Accepted bamf into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

the change is a logical one line change, not easily user testable but the new version works without regression so confirming

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.118-0ubuntu0.1

---------------
bamf (0.2.118-0ubuntu0.1) precise-proposed; urgency=low

  [ Didier Roche ]
  * New upstream release. (0.2.116)
    - multiple instances or double icons of application detected on bamfdaemon
      respawn (LP: #928912)
    - unity confused with chrome/chromium web apps (LP: #692462)
    - BamfView's dispose() method doesn't invoke the superclass' dispose()
      (LP: #986888)
  * debian/control:
    - remove Multi-Arch: same for the -dbg package
      (Closes: #669980, #658057)

  [ Alan Pope ]
  * New upstream release.
    - Unity crashed in bamf_application_on_window_removed (LP: #1000577)
    - Locked smuxi launcher icon does not indicate smuxi running status
      (LP: #999820)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - the RunningApplicationsChanged signal is no longer emitted when an
      application is closed since r460 (LP: #989551)
 -- Alan Pope <email address hidden> Wed, 23 May 2012 09:10:08 +0100

Changed in bamf (Ubuntu Precise):
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) on 2014-01-11
no longer affects: bamf (Ubuntu Quantal)
Changed in unity (Ubuntu):
status: New → Fix Released
Jaime Pérez (jaime-91) on 2015-10-13
Changed in unity (Ubuntu Precise):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers