Started applications pinned to the launcher are not set as running

Bug #976642 reported by Goyo on 2012-04-08
46
This bug affects 11 people
Affects Status Importance Assigned to Milestone
BAMF
High
Marco Trevisan (Treviño)
Unity
Fix Released
Undecided
Unassigned
bamf (Ubuntu)
High
Marco Trevisan (Treviño)
Precise
High
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

[Test Case]
1. Make sure gcalctool is not pinned to the launcher.
2. Open gcalctool, change gcalctool mode and pin gcalctool to the launcher.
3. Close gcalctool.
4. Click the gcalctool icon in the launcher -> gcalctool starts but no arrow in the launcher icon.
5. Close gcalctool.
6. Delete the gcalctool icon from the launcher.
7. Open gcalctool again
   -> No gacalctool icon in the launcher.

[Regression Potential]
No obvious regression potential.

Original description:

Steps to replicate:
Make sure gcalctool is not pinned to the launcher.
Open gcalctool, change gcalctool mode and pin gcalctool to the launcher.
Close gcalctool.
Click the gcalctool icon in the launcher -> gcalctool starts but no arrow in the launcher icon.
Close gcalctool.
Delete the gcalctool icon from the launcher.
Open gcalctool again
No gacalctool icon in the launcher.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.8.0+bzr2252ubuntu0+677 [origin: LP-PPA-unity-team]
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
ApportVersion: 2.0-0ubuntu4
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CrashDB: unity
Date: Sun Apr 8 17:19:23 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Goyo (goyodiaz) wrote :
Ellwyn C. (ellwyn) wrote :

I'm not sure if these programs:- Colour and AisleRiot Solitaire are also affected by this bug perhaps others, for example open either up and Lock to Launcher, then close that program and unlock from launcher, then open that particular program back up and there is no icon of it back in the launcher while its running. Which gcalctool is also experiencing.

But once logged out and back in, they are back running as they should be again until these step's are re-produced.

Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Tim Penhey (thumper) on 2012-04-10
Changed in unity:
assignee: Marco Trevisan (Treviño) (3v1n0) → Jason Smith (jassmith)
status: New → In Progress
importance: Undecided → High
milestone: none → 5.10.0
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
milestone: 5.10.0 → 5.12.0
Changed in unity:
assignee: Jason Smith (jassmith) → Marco Trevisan (Treviño) (3v1n0)
Changed in bamf:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: none → maverick-alpha-3
milestone: maverick-alpha-3 → none
summary: - Bad interaction between launcher and gcalctool
+ Started applications pinned to the launcher are not set as running
description: updated
Changed in unity:
milestone: 5.12.0 → 5.14.0
Changed in bamf:
status: In Progress → Fix Committed
Changed in unity:
status: In Progress → Fix Committed
Changed in bamf (Ubuntu):
status: New → Fix Committed
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.118-1ubuntu1

---------------
bamf (0.2.118-1ubuntu1) quantal; urgency=low

  * Sync from debian. No more difference.
  * Cherry-pick from upstream:
    - Started applications pinned to the launcher are not set as running
      (LP: #976642)
    - sometimes icons get dropped from the launcher when they should not
      (LP: #925421)
  * debian/*symbols:
    - add new private symbol (will not be exported after next release)
  * debian/control:
    - change packaging location to canonical branch (lp:ubuntu/bamf)

bamf (0.2.118-1) unstable; urgency=low

  * Backport latest release to debian
  * debian/control:
    - bump Standards-Version to latest
    - remove build-dep only used for unit tests
    - replace the gtk2 variant of the wnck introspection gir package with
      gtk3 one
    - ensure the gtk2/gtk3 version doesn't have the same description
  * debian/*.symbols:
    - adding some PRIVATE symbols to make lintian happy. We saw that bamf
      is exporting by error some of its private symbols. This will be fixed
      in next released (and so the symbols will be removed from the .symbols
      files)
  * debian/rules:
    - add hardening flags (thanks Andrea)
  * debian/sources/format:
    - added to specify we use format 1.0
 -- Didier Roche <email address hidden> Mon, 25 Jun 2012 11:01:57 +0200

Changed in bamf (Ubuntu):
status: Fix Committed → Fix Released
no longer affects: unity
description: updated
Changed in bamf (Ubuntu Precise):
status: New → In Progress
Changed in bamf (Ubuntu):
importance: Undecided → High
Changed in bamf (Ubuntu Precise):
importance: Undecided → High

Hello Goyo, or anyone else affected,

Accepted bamf into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/bamf/0.2.118-0ubuntu0.2 in a few hours and then in the -proposed repository. Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case details of your testing will help us make a better decision. Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in bamf (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

I'm not able to reproduce the issue with the update, setting to verification-done

tags: added: verification-done
removed: verification-needed
Changed in unity:
status: New → Fix Committed
milestone: none → 6.0
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.118-0ubuntu0.2

---------------
bamf (0.2.118-0ubuntu0.2) precise-proposed; urgency=low

  * Cherry-pick from upstream:
    - Started applications pinned to the launcher are not set as running
      (LP: #976642)
    - sometimes icons get dropped from the launcher when they should not
      (LP: #925421)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Wed, 20 Jun 2012 19:09:43 +0100

Changed in bamf (Ubuntu Precise):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-07-10
Changed in bamf:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) on 2014-01-11
no longer affects: bamf (Ubuntu Quantal)
Changed in unity (Ubuntu):
status: New → Fix Released
Jaime Pérez (jaime-91) on 2015-10-13
Changed in unity (Ubuntu Precise):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers