PATCH: add a configure parameter to disable building of the GIO module

Bug #687683 reported by Adam Williamson on 2010-12-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
BAMF
Wishlist
Unassigned
Unity
Fix Released
Undecided
Unassigned
unity-2d
Undecided
Unassigned
bamf (Ubuntu)
Wishlist
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

As discussed by email, the GIO module in bamf is actually optional; it increases the accuracy of matching if it's built, but bamf will work without it. Since building the GIO module requires a glib patch which has not been accepted by upstream - https://bugzilla.gnome.org/show_bug.cgi?id=606960 - it would be beneficial to make it easy to build bamf without the GIO module if necessary.

This patch adds a configure parameter, --disable-gio-module , which disables building of the module. The default behaviour remains as building the module. It might be better to have a test to see if the necessary extension point is available in glib and automatically build or not build the module depending on the result, but that would probably require writing a test application and I'm not up to that, so I just made it a parameter. =)

Adam Williamson (awilliamson) wrote :

is copyright assignment required for this? let me know, if so. to make things simple I can just give all my copyright in this patch to Jason, if necessary.

Hi Adam

Thanks for the patch, and it's very cool that you're making Unity
available for Fedora users!

For this particular patch, the contribution agreement is arguably not
needed, but for completeness and for anything more complex it would be,
so you might just want to go ahead with it. I know it's a slightly
amateur draft at the moment but I promise we'll adopt a more
professional one soon once Harmony produces something usable.

Mark

Adam Williamson (awilliamson) wrote :

hey, Mark. honestly I'd probably have to run it by RH legal to be sure before signing the agreement (you know what lawyers are like) and I was hoping to avoid the complication; would it work for me to assign the copyright for this patch specifically to someone @canonical, or just declare it public domain (I believe I can do that, as a Canadian)? that'd probably keep things simpler. As I'm not a coder I'm not likely to come up with any complex patches anyway; small fixes derived by logic and/or trial and error and/or Google are about all I'm good for. =)

Mark Shuttleworth (sabdfl) wrote :

Hi Adam

AFAIK a few RH'ers have already signed it, so I doubt you'll have an
issue. Again, for this patch, based on your statements here I'm happy to
+1 a merge with thanks :-)

Mark

Adam Williamson (awilliamson) wrote :

oh, really? didn't know. okay, well I'll check into that in case I submit anything that does need the agreement in future. thanks!

Adam Williamson (awilliamson) wrote :

can you go ahead and get this one applied for now? there's been several releases without it being added. Mark signed off on adding it without me signing the agreement, see above.

Adam Williamson (awilliamson) wrote :

thinking about it, if the support for the upstream glib change is coming soon, we really don't need this parameter, I guess =)

Didier Roche (didrocks) wrote :

I think that will make more sense, let's wait a little so that we can update the stack and get the right release with the right modules.
Thanks anyway ;)

Alex Launi (alexlauni) on 2011-02-23
Changed in bamf:
status: New → Triaged
importance: Undecided → Wishlist
Changed in unity:
status: New → Triaged
Changed in bamf (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
tags: added: patch
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d:
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.94-0ubuntu1

---------------
bamf (0.2.94-0ubuntu1) oneiric; urgency=low

  * New upstream release:
    - no more dependency on the gio ubuntu patch, use the upstream system now
      (LP: #687683)
  * debian/rules:
    - the new tests depends on a X server, desactivate them when building on
      buildd
  * debian/bamfdaemon.install:
    - do not install the gio module as it's not built anymore
 -- Didier Roche <email address hidden> Thu, 04 Aug 2011 14:56:07 +0200

Changed in bamf (Ubuntu):
status: Triaged → Fix Released
Didier Roche (didrocks) on 2011-08-05
Changed in unity-2d:
status: Triaged → Fix Released
Changed in unity:
status: Triaged → Fix Released
Changed in bamf:
status: Triaged → Fix Released
Adolfo Jayme (fitojb) on 2014-01-11
no longer affects: bamf (Ubuntu Quantal)
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers