BAMF Application Matching Framework

Menu bar - UTILITY wrongly treated as an active window (fails test case)

Reported by Matthew Paul Thomas on 2010-09-23
76
This bug affects 34 people
Affects Status Importance Assigned to Milestone
Application Menu Indicator
Medium
Unassigned
Ayatana Design
Medium
John Lea
BAMF
Medium
Unassigned
Unity
Medium
Unassigned
bamf (Ubuntu)
Medium
Unassigned
indicator-appmenu (Ubuntu)
Medium
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

From the first test case <https://wiki.ubuntu.com/MenuBar#Determining_the_active_window>:
1. Open two images in Gimp.
2. Focus image 1; that window’s menus should appear in the menu bar.
3. Focus the Toolbox.

What should happen: image 1’s menus should remain in the menu bar.
What actually happens: the fallback menus appear.

Kalle Valo (kvalo) on 2011-02-23
Changed in indicator-appmenu:
status: New → Triaged
importance: Undecided → Low
John Lea (johnlea) on 2011-06-15
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
tags: added: udo
Changed in ayatana-design:
importance: Undecided → Medium
status: New → Fix Committed
John Lea (johnlea) on 2011-09-28
Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in ayatana-design:
status: Fix Released → Fix Committed
John Lea (johnlea) on 2011-10-20
Changed in ayatana-design:
status: Fix Committed → Triaged
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-appmenu (Ubuntu):
status: New → Confirmed
John Lea (johnlea) on 2011-11-03
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in bamf:
status: New → Confirmed
Changed in bamf (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-11-22
Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) on 2012-02-01
Changed in unity (Ubuntu):
status: New → Confirmed
description: updated
John Lea (johnlea) on 2012-10-09
Changed in bamf:
importance: Undecided → Medium
Changed in bamf (Ubuntu):
importance: Undecided → Medium
Changed in unity:
importance: Undecided → Medium
Changed in indicator-appmenu (Ubuntu):
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
summary: - UTILITY wrongly treated as an active window (fails test case)
+ Menu bar - UTILITY wrongly treated as an active window (fails test case)
Changed in bamf:
status: Confirmed → Triaged
Changed in unity:
status: Confirmed → Triaged
Changed in bamf (Ubuntu):
status: Confirmed → Triaged
Changed in indicator-appmenu (Ubuntu):
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in indicator-appmenu:
importance: Low → Medium
Kai Mast (kai-mast) wrote :

Still occurs on trusty. Anybody working on this?

tags: added: trusty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints