DesktopFiles with NoDisplay=true are used as primary .desktop to match applications

Bug #1161531 reported by Marco Trevisan (Treviño) on 2013-03-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
BAMF
Medium
Marco Trevisan (Treviño)
bamf (Ubuntu)
Medium
Marco Trevisan (Treviño)

Bug Description

The desktop files with NoDisplay=true should be used by bamf to match applications, but they should have a lower priority than the displayable ones.

Related branches

Changed in bamf:
milestone: none → 0.4.0
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:bamf at revision 527, scheduled for release in bamf, milestone 0.4.0

Changed in bamf:
status: In Progress → Fix Committed
Changed in bamf (Ubuntu):
importance: Undecided → Medium

You should also file bugs against the distro if you want them to be counted as fixed by commits in auto release, especially within freeze periods.

Packaging-related fixes got approved by lool so I'm not worried about them, and the rest looks properly as bug fixes, so no reason to block the landing... (that was esp. about bug 1161430 which involves changes to the maintainer scripts)

Please be mindful of freeze periods and give us time to review merges before they land so we don't risk getting the packages rejected by archive admins. Feel free to ping me if you feel merges for bamf aren't being reviewed fast enough, in case I didn't see them or whatever, I can help with making sure things are reviewed in a timely manner.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.4.0daily13.04.03-0ubuntu1

---------------
bamf (0.4.0daily13.04.03-0ubuntu1) raring; urgency=low

  [ Marco Trevisan (Treviño) ]
  * debian/bamfdaemon.postinst:
    - write it in multiline and add support for StartupWMClass
      and other properties such as NoDisplay and OnlyShowIn (LP: #1161430).
  * TestBamfMatcher: fix crashes caused by missing exec in .desktop files
  * libbamf: use scanner-flags for introspection, fixes a compilation error.
  * DesktopFiles with NoDisplay=true are used as primary .desktop to
    match applications (LP: #1161531)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 528
 -- Ubuntu daily release <email address hidden> Wed, 03 Apr 2013 02:01:51 +0000

Changed in bamf (Ubuntu):
status: New → Fix Released
Changed in bamf (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in bamf:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints