Bamf index file is not used to store the .desktop class name or the OnlyShowIn parameters

Bug #1161430 reported by Marco Trevisan (Treviño) on 2013-03-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
BAMF
Medium
Marco Trevisan (Treviño)
bamf (Ubuntu)
Medium
Unassigned

Bug Description

And this causes some extra i.o. that we want prevent with the bamf.index file.

Related branches

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:bamf at revision 526, scheduled for release in bamf, milestone 0.4.0

Changed in bamf:
status: In Progress → Fix Committed
Changed in bamf (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.4.0daily13.04.03-0ubuntu1

---------------
bamf (0.4.0daily13.04.03-0ubuntu1) raring; urgency=low

  [ Marco Trevisan (Treviño) ]
  * debian/bamfdaemon.postinst:
    - write it in multiline and add support for StartupWMClass
      and other properties such as NoDisplay and OnlyShowIn (LP: #1161430).
  * TestBamfMatcher: fix crashes caused by missing exec in .desktop files
  * libbamf: use scanner-flags for introspection, fixes a compilation error.
  * DesktopFiles with NoDisplay=true are used as primary .desktop to
    match applications (LP: #1161531)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 528
 -- Ubuntu daily release <email address hidden> Wed, 03 Apr 2013 02:01:51 +0000

Changed in bamf (Ubuntu):
status: New → Fix Released
Changed in bamf:
status: Fix Committed → Fix Released
milestone: none → 0.4.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers