vino should support reverse connections (listen mode)

Bug #121961 reported by unggnu on 2007-06-24
60
This bug affects 11 people
Affects Status Importance Assigned to Milestone
vino
New
Wishlist
vino (Baltix)
Undecided
Unassigned
vino (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

Binary package hint: vino

Since many people are behind routers/firewalls it isn't so easy to help them with vnc. People who need support doesn't often know how to open ports. Another group are people behind a firewall which can't be changed by them. For all of them it would be great to have GUI for connection to vnc clients in listen mode. People who give support know how to forward ports so it makes much more sense to let supported connect to vnc listen clients. This also makes things more secure since they don't need to open ports.
Btw. gnome-rdp should support starting the listen mode but this is another story. Atm gnome-rdp isn't usable because of some compression and starting bugs. And tightvnc seems to have problems with scrolling of huge desktops.

Changed in vino:
importance: Undecided → Wishlist
Sebastien Bacher (seb128) wrote :

Thank you for your bug, that's known upstream: http://bugzilla.gnome.org/show_bug.cgi?id=389646

Changed in vino:
assignee: nobody → desktop-bugs
status: New → Confirmed
Changed in vino:
status: Unknown → New
Derek Buranen (eburner) wrote :

Ooh, do I get some launchpad karma since I made the upstream bug report?

Sebastien Bacher (seb128) wrote :

Not likely, karma is for launchpad actions

Changed in vino:
status: New → Won't Fix
Changed in vino:
status: Won't Fix → New
Changed in vino:
status: Confirmed → Triaged
VPablo (villumar) wrote :

Is there any news on this wishlist?

I think that is a very important feature for vnc in Linux to add a listening client from the server.

Derek Buranen (eburner) wrote :

Especially important on the LiveDVD/LiveCD/LiveUSB for remote recovery operations!

piviul (piviul) wrote :

I'm agree with you: it would be very, very interesting!

Piviul

exactt (giesbert) wrote :

this already implemented upstream and should become available with the next version of ubuntu.

in the meantime, if anybody has packages (for karmic) of the new version floating around I would be happy to test them.

VPablo (villumar) wrote :

Yes, a PPA for testing would be great.

unggnu (unggnu) wrote :

@exactt
I have checked Lucid an only receiving reverse connections work with the GUI of Vinagre but it still doesn't seem to be possible with Gnome to send reverse requests which is the most important part since every supporter knows how to open vnc with a listen connection.
Or is it hidden somewhere?

François Rey (fmjrey) wrote :

Reverse vino is a must have feature for allowing support across the internet without messing with firewalls and additional installation on ubuntu machines. If implemented then why can't we find reverse connection option in Lucid gui? Is there even a command line to do it?

VPablo (villumar) wrote :

¿Something like that? (see attachment)

Not yet proved but the option is there.

François Rey (fmjrey) wrote :

The image you attached is of the client, what we need is a gui for the server to initiate a reverse connection.
In other words: a way for grandma to click somewhere and say connect to my grandson ;)
I suppose that would mean some new menu option that opens a gui which lets the user start a reverse connection. Might as well add a list of shortcuts in that gui so that grandma does not have to type the address of her grandson's computer all the time.

VPablo (villumar) wrote :

OK. The screenshot is the same as "vncviewer -listen" isn't it?

What we need is something like "vino -reverse 192.168.1.25" with a GUI (if possible).

François Rey (fmjrey) wrote :

Yes we would need something like you said, or more like the x11vnc way:
vino -connect test.dyndns.net:5500

At least we need a command line, so we can easily add a shortcut menu item.
But for grandma a gui in the line of what vino/vinagre provides would be best.
The idea is to make it as easy as possible, and why not make it work on a livecd as suggested before so that we can even provide support when the machine disk can't boot!

Changed in vino:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.