usb stick is not made bootable

Bug #273477 reported by Michael Hofmann on 2008-09-23
100
This bug affects 9 people
Affects Status Importance Assigned to Milestone
usb-creator (Baltix)
Undecided
Unassigned
usb-creator (Ubuntu)
High
Evan

Bug Description

Binary package hint: usb-creator

I bought a new 2GB usb stick which had no bootable mbr and which contained no active partition.
I fixed this manually by dd if=/usr/lib/syslinux/mbr.bin of=/dev/sdc and fdisk.
Because I suspect this may be common for new usb sticks, usb-creator should ensure that the selected partition is active and the mbr can actually boot it.

Did you run it using sudo or as the root user? If not, and you ran it as your normal account then it probably wont be able to install the mbr.

Changed in usb-creator:
status: New → Incomplete

I just tested this with a 1G USB stick and also got an unbootable result.

Changed in usb-creator:
status: Incomplete → Confirmed
Michael Hofmann (mh21) wrote :

I got a nice Ubuntu "this software can modify important parts of your system" box where I entered my password.

Evan (ev) on 2008-09-24
Changed in usb-creator:
status: Confirmed → Fix Released
Matt Zimmerman (mdz) wrote :

This bug was closed without an explanation, and I can still reproduce the problem, so I assume this was in error.

I did the following:
1. Ran usb-creator and successfully copied the installation media to the USB stick
2. Attempted to boot it in another machine, received an "Operating system not found" error
3. Checked the partition table, noticed that the partition was not set active, fixed that with fdisk
4. Attempted to boot it again, still failed
5. Installed an MBR using install-mbr
6. Attempted to boot again, succeeded

Changed in usb-creator:
importance: Undecided → High
status: Fix Released → Triaged
Evan (ev) wrote :

Matt,

Can you attach ~/.usb-creator.log to this bug report?

Thanks!

Matt Zimmerman (mdz) wrote :
Evan (ev) on 2008-10-27
Changed in usb-creator:
assignee: nobody → evand
milestone: none → later
Evan (ev) wrote :

The attached patch should fix the problem by always writing a copy of syslinux to the MBR.

Evan (ev) wrote :

Deferred to 9.04, as discussed in #ubuntu-release:

04:45 < evand> Is it too late to get changes in? I have one last one that I just cooked up a solution to (usb-creator needs to install a bootloader to the MBR as well to be safe). I can make a proper bug report detailing it, but I'm wondering if it's futile.
04:48 < slangasek> evand: so this is "usb-creator won't boot on everything because the boot loader isn't in the MBR"?
04:50 < slangasek> evand: if so, I think we're too late for that
04:54 < evand> slangasek: no, it's usb-creator wont boot in certain circumstances because something else is in the MBR already.
04:54 < evand> but fair enough, I'll just save it in bzr for -updates.
04:55 < evand> err, perhaps that is what you meant and I just misread. Apologies.

can we have this fix on a PPA until ibex-updates are open?

Evan (ev) on 2008-11-06
Changed in usb-creator:
status: Triaged → Fix Committed

Had the same "missing operating system" error. Using install-mbr on the USB disk solved the problem.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.1.11

---------------
usb-creator (0.1.11) jaunty; urgency=low

  [ Evan Dandrea ]
  * Strip null bytes from the CD label when parsing it from an ISO file
    (LP: #287318).
  * Internally represent the persistent file size in bytes for greater
    accuracy.
  * Move self.pipe declaration to the correct location (LP: #291645).
  * Add a bootloader installation progress message.
  * Install the bootloader to the MBR as well (LP: #273477).
  * Specify the filesystem type when mounting iso9660 images.
  * Warn the user when usb-creator cannot mount an image (LP: #287753).
  * i18n support (LP: #285413, #292556).
  * Added Swedish tranlsation (LP: #285811). Thanks Daniel Nylander.
  * Add -t option to write a trace file.
  * Don't include all .py files in the tree for translation.
  * Don't update the pot file on every build.
  * Write more information to the log (subprocesses, stderr, etc).

  [ Martin Owens ]
  * Fix small issue where enlarging the main window would have a different
    expanding effect on the top listview from the bottom listview.
  * Add gnomevfs support to use gnome device labels and icons. This should
    make things more user friendly.

  [ Mario Limonciello ]
  * Add support for providing command line ISO images.
  * Add support for defaulting the persistence setting in the UI via
    command line.
  * Default the GUI to start up centered on the screen.

 -- Evan Dandrea <email address hidden> Thu, 20 Nov 2008 09:28:08 +0000

Changed in usb-creator:
status: Fix Committed → Fix Released
Ketil Vestby (ketil-vestby) wrote :

Have tested the new version on three computers, the bugfixed version worked on all computers.

:-)

I would like to comment on what Bob Lewis wrote on 2008-12-07 in LP #277903 about different types/sizes of USB storage devices (and file it here as it is a duplicate bug):

Note that certain types of bios have an additional feature to be able to choose between seeing USB Mass Storage Devices as fixed or removable drives, or auto detected. In our case the automatic detection was keeping the computer from being able to boot from at least certain types of USB sticks (showing a black screen with only "Boot Error" on it). Changing the bios configuration to "consider any USB drive to be a fixed drive" allowed us to successfully boot.

(Motherboard is an Intel DQ35JO.)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments