dmraid / FakeRAID support should work automatically in installers.

Bug #90235 reported by Tom Inglis on 2007-03-06
40
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Baltix)
Undecided
Unassigned
ubiquity (Ubuntu)
High
Unassigned

Bug Description

It is very very complicated to get dmraid to work properly with my NVIDIA nForce 4 SATA RAID controller, and my two Seagate Momentus 7200.1 100GB hard drives in a RAID 0 array in Kubuntu Feisty.

Fedora Core 6 (which I also tried) does this automatically via the Anaconda installer. Can we not get this working with Ubiquity / Debian Text Installer?

'FakeRAID' is increasingly common on modern machines, and more and more people will use it, either to back up their data on the fly, or to provide more space for videos etc by adding cheaper hard drives to the array.

WillyTP (willytp) wrote :

I totally agree with you...
Let's hope some ubuntu's programmer will fix that...

Yeah, this is crucially important! :-)

If not for Feisty, then certainly for Feisty+1.

T.

On Monday 26 March 2007 21:42:46 WillyTP wrote:
> I totally agree with you...
> Let's hope some ubuntu's programmer will fix that...

Tom Inglis (tominglis) wrote :

I don't think that the package should be assigned to casper? Does dmraid not need to be implemented properly with ubiquity, casper, and the partition software?

Changed in casper:
status: Unconfirmed → Needs Info
Tom Inglis (tominglis) wrote :

Hi Guys,

What info does this bug need?

Bestest,

Tom

Andreas Simon (andreas-w-simon) wrote :

I just saw that there is a blueprint for this at
https://blueprints.launchpad.net/ubuntu/+spec/fakeraid-support

Colin Watson (cjwatson) wrote :

This bug needs no additional information, but will take a while to get to work. Some work has been done in d-i upstream.

Changed in ubiquity:
status: Incomplete → Confirmed
importance: Undecided → Wishlist
stefab (bluefuture) wrote :
RamonS (ramons) wrote :

I also like to see this added to Ubuntu...quite honestly, I'd like to have it in since yesterday, but today will work as well. ;) In order to dual-boot with another OS I had to defect to Fedora 7, which fully detected the nVidia SATA fakeRAID and installed with all the bells and whistles.

There are several how-tos on how to doctor 7.04 up to install properly. I did try two (the one from Ubuntu India and the one posted in the ubuntuforums) and both failed sooner or later, even when taking the working steps of each. Would be nice to at least get a FakeRAID package that one can pull via synaptic when booting the LiveCD and that then also gets properly applied to the installed system.

With the debian installer being able to handle this properly chances are that Ubuntu will see this soon as well? No?

Guillaume Modard (modard) wrote :

I'm agree with that ! I've a recent DELL computer and I missed a lot off time to configure my ubuntu with RAID 0. I expect it will be resolve very soon (8.04 please or in the october version at least...)

Jon Nordby (jonnor) wrote :

Without dmraid support at install, Ubuntu becomes practically inaccessible to a lot of inexperienced users. Exactly the crowd that it typically attracts. So dmraid should be avaliable as soon as possible, imo.

Vangelis Tasoulas (cyberang3l) wrote :

+++++
Agree with all the people posted above me...

Please add fakeraid support as soon as possible!
I can use this feature since Fedora 5 but still not using ubuntu/kubuntu :(

Evan (ev) wrote :

This is tentatively planned for Ubuntu 8.10.

brazzmonkey (brazzmonkey) wrote :

8.10 beta1 is out now. is this feature implemented? is it available in latest beta?

Koen (gorgabal) wrote :

can someone confirm this is being worked on?

speedy (speedy-spam) wrote :

I just encountered this issue with ubiquity - couldn't install latest ubuntu on my fakeraid raid0 array. Pretty bad user experience, disk manager took _very_ long time to load (judging by dmesg, kernel is trying to mount tons of different fs types), didn't detect RAID0, display showed 2 RAID HDDs as empty space. When I choose to quit the setup, expecting a quick reboot, ubiquity or X exiting got stuck on the X wallpaper. After waiting for a while, I hit the reset button, then upon reboot RAID bios on the ICH10R southbridge detected a spurious raid array in failed state which didn't previously exist together with my normal one which was luckily working. Phew.. After power off / power on cycle, that failed array dissapeared, and everything was back at normal. I'm going to also report aforementioned 2 additional encountered bugs to a separate bug reports..

Will try Advanced CD method for fakeRAID ubuntu install next, hopefully my data doesn't get wrecked.

In short, installing ubuntu was a thriller. Lets see if the second part has happy ending. x_x

Tom Inglis (tominglis) wrote :

Is dmraid supported in Ubiquity yet (I am on 8.04 until 10.04!)?

If so, that's awesome, and this bug can be closed!

If not, we should really try to get this done by the next LTS, which is when lots of workstation / light server users who might want to use software RAID will be upgrading.

Mark Shuttleworth (sabdfl) wrote :

I'd like to second the idea of dmraid support in Ubiquity. At a minimum, it would be useful to have all the necessary tools on the live fs. Colin, can you comment on progress or plans for fakeraid support?

Changed in ubiquity (Ubuntu):
importance: Wishlist → High
EagleDM (eagle-maximopc) wrote :

I already talked about this problem hundreads of times, I was an avid supporter of RAID devices, being using them since 6 to 8 years now.

Ive stopped using RAID last year because toons of problems with Ubuntu.

First we have the terrible idea to simply ignore the HPA (which is a setting that no OS ignores, except for Ubuntu) that alone destroyed my Matrix RAID array a lot of times.. then we have the DMRAID bugs that prevents detecting the secondary subset on Matrix RAID sets.. (both of this bugs are still present on Karmic even as of July 20).

LiveCD should have an option to directly boot with the HPA active and not ignoring it or at least ASKING the user or adding an option in the LiveCD to change it "via kernel option" (just like the rest of commands added to boot).

This could be easily implemented if the main Boot screen before booting LiveCD offers a single "option" saying "boot for RAID systems" or something like that, that pass the command libata.ignore_hpa=0 so the system could boot the LiveCD without breaking a RAID array.

THEN you could ADD the option to Install on RAID Systems to ubiquity so the installer is AWARE there is a raid array on the system an properly install dmraid package and recognize it.

It is a shame this was in my whishlist since feisty and here we are and RAID support is non-existant in Ubuntu, furthermore this is terrible if we consider that Vista and Windows 7 included RAID support for all major controllers since Service Pack 1 so, installing and using RAID on that systems is pretty much transparent to the user.

speedy (speedy-spam) wrote :

I could chime in and implement this feature as if someone would offer a "bounty" on it. Unfortunately, ATM, I can't do it for free. :(

More then 15 years of experience in linux, system programming, user-land programming over here, working mostly as a consultant, and currently between projects.

Contact: speedy.spam at gmail dot com

Giuseppe Pennisi (giupenni78) wrote :

I think is totally necessary the dmraid support in ubiquity?
It can be possible in Karmic?

giuseppe

EagleDM (eagle-maximopc) wrote :

Let's hope, because, if they implement it, they will probably fix all the error I am getting since Feisty, that, as of today, still aren't fixed.

https://bugs.launchpad.net/ubuntu/+source/dmraid/+bug/403733

Kazade (kazade) wrote :

Is there any update on this? I assume that Karmic is missing out on dmraid support, but is there progress being made for Karmic+1?

Colin Watson (cjwatson) wrote :

It actually looks as if it's nearly there. I think we may be able to squeeze this in.

EagleDM: I'm not questioning the validity of your comments, but they are misdirected in this bug report. The people who read ubiquity bug reports work on ubiquity; we can't necessarily fix the entire system (for instance, our HPA handling grew out of critical regressions that were caused by universally honouring the HPA; our HPA handling needs to be more subtle, integrated with partition table detection, but that subtlety needs to go in the kernel). Furthermore, bug reports that try to cover too many problems usually end up never being fixed because they're simply too difficult to disentangle. Please do us and yourself a favour and make sure that separate issues are raised in separate reports; it doesn't really help to add them here.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.0.0

---------------
ubiquity (2.0.0) karmic; urgency=low

  [ Colin Watson ]
  * Bump to a stable version number series for Ubuntu 9.10.

    The main reason for the version bump was because we incorporated
    oem-config and needed to jump past its version numbers, but really
    Ubiquity 2.0.0 is quite different from Ubiquity 1.0.0 despite most of
    the changes being gradual and incremental. 3.5 years and nearly 5000
    lines of changelog entries later, we have several active developers,
    lots more translations, apport integration, a new partitioner,
    migration-assistant, automation, Mythbuntu and noninteractive frontends,
    Wubi, reinstallation without reformatting, a new timezone map,
    accessibility, many UI improvements, a slideshow, plugin support, and
    much more. Here's to version 3!

  * Install kernel headers to match the kernel (LP: #413135).
  * Recommend dmraid to ensure consistent behaviour across Ubuntu flavours
    (it was already present on the Ubuntu desktop CD, but e.g. not on
    Kubuntu).
  * If dmraid devices are active, then create
    /var/lib/disk-detect/activate_dmraid so that partman will exclude slave
    devices, and ensure that dmraid is installed in the target (LP: #90235).
  * Use check-language-support if available to select language support
    packages (LP: #434173).
  * Update translations from Launchpad.
  * Automatic update of included source packages: base-installer
    1.102ubuntu2, hw-detect 1.72ubuntu5.

  [ Jonathan Riddell ]
  * ubi-intro.py: detect kubuntu-netbook-intro.txt if it exists and use
    that as warning for Kubuntu Netbook Edition

 -- Colin Watson <email address hidden> Wed, 14 Oct 2009 23:57:40 +0100

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers