Please sync sagemath 3.0.5dfsg-1 from Debian unstable

Bug #120527 reported by Kurt Hallavej on 2007-06-15
78
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Feisty Backports
Undecided
Unassigned
Hardy Backports
Undecided
Unassigned
Intrepid Ibex Backports
Undecided
Unassigned
sagemath (Baltix)
Undecided
Unassigned
sagemath (Debian)
Fix Released
Undecided
Unassigned
sagemath (Ubuntu)
Wishlist
Unassigned

Bug Description

SAGE is Open Source Mathematics Software.
General and Advanced Pure and Applied Mathematics
Use SAGE for studying a huge range of mathematics, including algebra, calculus, elementary to very advanced number theory, cryptography, numerical computation, commutative algebra, group theory, combinatorics, graph theory, and exact linear algebra.
se an Open Source Alternative
By using SAGE you help to support a viable open source alternative to Magma, Maple, Mathematica, and MATLAB. SAGE includes many high-quality open source math package.
http://modular.math.washington.edu/sage/

Many packages are included in SAGE, some of them may already be in Ubuntu and as such should be checked against requirements / conflicts / dependencies / etc.

Licensing of those packages differs, although most packages are under GPL. As of Nov. 2007, this is the licensing information that was available:
http://sage.math.washington.edu/home/was/sage/COPYING.txt

A current effort for Debian packaging is being documented at:
SAGE in Debian: http://www.sagemath.org:9001/DebianSAGE

Other links of interest:
Official project site: http://www.sagemath.org/
Bug / feature tracker: http://sagetrac.org/sage_trac/
Developers mailing list: http://groups.google.com/group/sage-devel

Online demo available at: https://sage.math.washington.edu:8101/

xRaich[o]²x (raichoo) wrote :

Confirmed. This software is essential for math and computer science. Consider it as the Photoshop of math. I'd really appreciate a package!

shtumf (boris-fonda) wrote :

Its GPL and it would be nice to have it in package repository.
Regards
Boris

The program is called "Sage".
The website that it comes from is called "Sagemath.org".

Please check that you have used the correct name for the program.
Otherwise there could be some confusion.
The authors have a right for their work to be kept by the same name.

How come I can not find my "duplicate copy" anymore on my list of submissions?
You can mark as duplicate if you so wish.
But I will refrain from expounding how unimpressed I am that when this is done, my access to it is made difficult.

C de-Avillez (hggdh2) wrote :

@Tree MendUs:

re. comment #4: There is already a package called 'sage', dealing with OpenGL. Obviously we cannot have two different packages with the same name. I renamed this packaging request following the Debian IPT (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=455292), linked here. I am unsure on how to proceed here, if you insist on having this package called 'sage'.

re. comment #5: bug 264190 is clearly a duplicate of this request, and has been marked so (and indeed there are other duplicate requests for this!). You can always access this duplicate via a series of different options:

 - search for all bugs you submitted, any stati;
 - search for all bugs you are related to, any stati;
 - click on the link provided on this bug (top right area, under the heading 'Duplicates';
 - and others.

I am unsure what is the problem, and what you expected us to do -- or not do.

Thanks for outlining the problem hggdh.

A bit of background from the submitter's angle;
1) If the submitter wants to check if a package has been submitted already, then they will use the name of the package as they know it - not some name they imagine somebody else gave to it.
So the original name is very useful to keep.
But it can be added to - tough concatenation should be avoided.

So a name like Sage math, Sage (math), is probably OK.

2) When a submission gets marked duplicate or for any other reason gets taken off the user's list of submissions, without their notice, or without their consent , it is like having an "avaricious moderator" on one's own "notes to one's self" website.
If a user is not in control of their own list (book keeping), then they will get lost.
it took me a while to figure out (in the early stages) that some submissions that I "thought" I'd made, but were removed from view (by somebody else), were viewable elsewhere. But until I found that things were going missing due to the actions of others, I resubmitted some of them, because I thought I had forgotten to in the first place (because they would be viewable - or so I thought).
This was an un-necessary Re-duplication of effort.

So let the site admins do what they want, but try to have a system that doesn't shunt stuff out of view for the user.
Now when I can't find stuff,I go to advanced search and tick everything on the left side (because I do not know for what reason an item has gone missing).

Maybe let the user set their default view, so they can all the submissions they have ever made. The advanced search is then used more for "sorting" to show less than total, rather than "revealing" what was hidden from view.

Its all very well having a multitudinous means of accessing ie;
 - search for all bugs you submitted, any stati;
 - search for all bugs you are related to, any stati;
 - click on the link provided on this bug (top right area, under the heading 'Duplicates';
 - and others.

but none of these are the way the user used to access it before, it's status got altered.

3) If two programs have the same name, then do not be prejudice as to which one gets renamed - rename both.
So Sage for OpenGL could be named Sage openGL, or Sage (openGL).

The problems discussed here are much more general than this package request.
So could you please feed this information back to the sys admins, so the problems are not repeated for other users.

i hope the thoughts here are helpful.
Thank you.

Changed in feisty-backports:
status: New → Incomplete
Changed in gutsy-backports:
status: New → Incomplete

It is now in Debian unstable and can be synced:

 sagemath (3.0.5dfsg-1) unstable; urgency=low

   * Initial Release (Closes: #455292).

 -- Tim Abbott <email address hidden> Sun, 20 Jul 2008 09:44:33 -0400

Fixed in Jaunty

Changed in sagemath:
importance: Unknown → Undecided
status: New → Fix Released

Opened tasks only concerns backports. I'll unsubscribe Ubuntu Sponsors for Universe.

Cosme Domínguez (cosme) wrote :
Changed in intrepid-backports:
status: New → Invalid
Shane H (shane.h) wrote :

From what I know about installing programs on Ubuntu (I'm not an expert), if you install Sage from a TAR file, then all the programs it depends on (e.g. octave) have to be included in the download and install – even if they're already installed. The same version of the same program could be installed twice! What a waste!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.