Baltix GNU/Linux

New QGIS versions with full Python support were released since 2007-10 - please update packages

Reported by Mantas Kriaučiūnas on 2007-12-12
10
Affects Status Importance Assigned to Milestone
qgis (Baltix)
Undecided
Unassigned
qgis (Ubuntu)
Wishlist
Unassigned
Nominated for Hardy by Leo Jackson
Nominated for Intrepid by Leo Jackson
Nominated for Jaunty by Leo Jackson

Bug Description

Binary package hint: qgis

Several new QGIS versions (0.9.0, 0.9.1 and 0.10) with full Python support were released since 2007-10 - look at
http://qgis.org and http://blog.qgis.org/?q=node/91 :

QGIS 0.9.0 Release Announcement
[..]
This release introduces several new features including Python support and many new GRASS modules. The release also includes numerous bug fixes and stability improvements. All versions can be obtained from the download page at http://download.qgis.org.

Major changes in this release are:
    * Python bindings - This is the major focus of this release it is now possible to create plugins using Python. It is also possible to create GIS enabled applications written in Python that use the QGIS libraries.
    * Removed automake build system - QGIS now needs CMake for compilation.
    * Many new GRASS tools added (with thanks to http://faunalia.it)
    * Map Composer updates
    * Crash fix for 2.5D shapefiles
    * The QGIS libraries have been refactored and better organised.
    * Improvements to the GeoReferencer

Please update Ubuntu packages to 0.10.0 (Qgis 0.9.1 was removed from Debian because of packaging/compilation bugs, see http://bugs.debian.org/474604 , but there are already packages of 0.10.0 version, see bellow.)

Unofficial deb packages repository of latest version: deb http://debian.gfoss.it/ lenny main

Latest QGis sources are available at: https://svn.osgeo.org/qgis/branches/Release-0.10.0
(according to http://lists.alioth.debian.org/pipermail/pkg-grass-general/2008-May/003073.html )

AFAIK latest Debian packaging works are at http://svn.debian.org/wsvn/pkg-grass/packages/qgis/

Changed in qgis:
importance: Undecided → Wishlist
status: New → Confirmed
description: updated
Matt Neilson (ichthyoboy) wrote :

Now up to version 0.11.0 (see changelog at http://blog.qgis.org/node/119), and on their way to 1.0.

Leo Jackson (lajjr) wrote :

Thank you for taking the time to report this bug and trying to help make Ubuntu better. However, it seems that this package is available in another area.
http://ppa.launchpad.net/jef-norbit/ubuntu/pool/main/q/qgis/

is better to add it like this.

Add these lines to your /etc/apt/sources.list

deb http://ppa.launchpad.net/jef-norbit/ubuntu hardy main
deb-src http://ppa.launchpad.net/jef-norbit/ubuntu hardy main

Then do

sudo apt-get update
sudo apt-get install qgis

Leo
Thanks for the information on how to be currently able to use QGIS.

This bug report was a package request for Ubuntu, which I understand is the method for requesting that a package be made available through Ubuntu's standard repositories.
I see that the current means of access is at Launchpad's PPA, so hopefully the project there will progress from there through to inclusion in the standard Ubuntu repo.

I use Feisty, which has QGIS available (through synaptic).
But was a little concerned to see such a useful program get dropped.
Programs like these could be very useful for local councils, farmers, etc.

Is there a place where a complete list of packages can be viewed (at once), with columns (or rows) showing which versions of Ubuntu (and Debian?) they are included in?

The Ubuntu packages search engine is good for doing checks on individual packages, but this method would be very tedious for getting the overall picture.

Thank you.

Download full text (3.5 KiB)

Tree MendUs,

It has a ton of other OS options to..

Yes..

Right here....http://download.qgis.org/downloads.rhtml

Leo Albert Jackson Jr
Owner Head Programmer
LJ's Electronics and Software

--- On Mon, 12/1/08, Tree MendUs <email address hidden> wrote:

> From: Tree MendUs <email address hidden>
> Subject: [Bug 175992] Re: New QGIS versions with full Python support were released since 2007-10 - please update packages
> To: <email address hidden>
> Date: Monday, December 1, 2008, 8:28 PM
> Leo
> Thanks for the information on how to be currently able to
> use QGIS.
>
> This bug report was a package request for Ubuntu, which I
> understand is the method for requesting that a package be
> made available through Ubuntu's standard repositories.
> I see that the current means of access is at
> Launchpad's PPA, so hopefully the project there will
> progress from there through to inclusion in the standard
> Ubuntu repo.
>
> I use Feisty, which has QGIS available (through synaptic).
> But was a little concerned to see such a useful program get
> dropped.
> Programs like these could be very useful for local
> councils, farmers, etc.
>
> Is there a place where a complete list of packages can be
> viewed (at
> once), with columns (or rows) showing which versions of
> Ubuntu (and
> Debian?) they are included in?
>
> The Ubuntu packages search engine is good for doing checks
> on individual
> packages, but this method would be very tedious for getting
> the overall
> picture.
>
> Thank you.
>
> --
> New QGIS versions with full Python support were released
> since 2007-10 - please update packages
> https://bugs.launchpad.net/bugs/175992
> You received this bug notification because you are a direct
> subscriber
> of the bug.
>
> Status in “qgis” source package in Ubuntu: Confirmed
> Status in “qgis” source package in Baltix: New
>
> Bug description:
> Binary package hint: qgis
>
> Several new QGIS versions (0.9.0, 0.9.1 and 0.10) with full
> Python support were released since 2007-10 - look at
> http://qgis.org and http://blog.qgis.org/?q=node/91 :
>
> QGIS 0.9.0 Release Announcement
> [..]
> This release introduces several new features including
> Python support and many new GRASS modules. The release also
> includes numerous bug fixes and stability improvements. All
> versions can be obtained from the download page at
> http://download.qgis.org.
>
> Major changes in this release are:
> * Python bindings - This is the major focus of this
> release it is now possible to create plugins using Python.
> It is also possible to create GIS enabled applications
> written in Python that use the QGIS libraries.
> * Removed automake build system - QGIS now needs CMake
> for compilation.
> * Many new GRASS tools added (with thanks to
> http://faunalia.it)
> * Map Composer updates
> * Crash fix for 2.5D shapefiles
> * The QGIS libraries have been refactored and better
> organised.
> * Improvements to the GeoReferencer
>
> Please update Ubuntu packages to 0.10.0 (Qgis 0.9.1 was
> removed from Debian because of packaging/compilation bugs,
> see http://bugs.debian.org/474604 , but there are already
> packages of 0.10.0 version, see b...

Read more...

Changed in qgis:
status: New → Confirmed
Nick Ellery (nick.ellery) wrote :

Closing Ubuntu report, as qgis no longer exists in Ubuntu.

Changed in qgis:
status: Confirmed → Invalid
Leo Jackson (lajjr) on 2009-01-13
Changed in qgis:
status: Invalid → Confirmed
status: Confirmed → Invalid
Leo Jackson (lajjr) wrote :

Marking as invalid it should be added to wish list.

Changed in qgis:
status: Confirmed → Invalid
Leo Jackson (lajjr) on 2009-02-07
Changed in qgis:
status: Invalid → Confirmed
Leo Jackson (lajjr) wrote :

I will Package for QGIS.

Changed in qgis:
assignee: nobody → lajjr
status: Confirmed → In Progress
Leo Jackson (lajjr) wrote :

I have the package in my ppa and sending to revu.

Changed in qgis (Baltix):
status: In Progress → Fix Committed
Leo Jackson (lajjr) on 2009-09-10
Changed in qgis (Baltix):
assignee: Leo Albert Jackson Jr (lajjr) → nobody
status: Fix Committed → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.