Baltix GNU/Linux

Package OpenOffice.org 3.x for Backports

Reported by FredBezies on 2008-09-07
508
This bug affects 44 people
Affects Status Importance Assigned to Milestone
Hardy Backports
Undecided
Unassigned
Intrepid Ibex Backports
Undecided
Unassigned
openoffice.org (Baltix)
Undecided
Unassigned
openoffice.org (Ubuntu)
Wishlist
Unassigned
Declined for Intrepid by Colin Watson
Declined for Jaunty by Chris Cheney

Bug Description

There was not enough time to officially include OpenOffice.org 3.0 in the Intrepid Ibex release of Ubuntu. OO 2.4 will be the default office package. We understand that testing out new software is exciting, and apologize for any disappointment. One common issue raised is Office 2007 document support, although contrary to somewhat popular belief, Ubuntu's version of OO 2.4 supports these new formats just fine.

OO 3.0 will be default in the next 6 month release of Ubuntu. If you would like to upgrade to OO 3.0 anyway in Intrepid, you have a couple options:

You can install from this PPA: https://launchpad.net/~openoffice-pkgs/+archive

Or, you can wait for the 3.0.1 bug fix release of OpenOffice, which will be included in the Backports repository for Intrepid. This release is expected sometime mid January. http://wiki.services.openoffice.org/wiki/OOoRelease301 has more up to date information about the expected release date.

Bear in mind, that if you choose to upgrade, there is no supported method of downgrading, so please decide carefully.

Thanks!

Chris Cheney (ccheney) wrote :

It's almost certainly too late at this point since OOo 3.0 was supposed to have originally been released on Sep 2, not just the release candidate. At their current rate of progress the final version will probably be released at the same time as Ubuntu Intrepid release candidate (~ Oct 20).

However, we are considering having separate openoffice.org3 packages for users who don't mind a very buggy version to use, but it won't be the default version installed.

Changed in openoffice.org:
importance: Undecided → Wishlist
milestone: none → ubuntu-8.10-beta
status: New → Triaged

Just wondering : could it be possible to integrate a RC (2?) version and upgrade it later to final one ? Like Canonical had done for Firefox. I know, it is a little bigger than Firefox, but having to wait for Ibex + 1 for OpenOffice.org 3.0 could be a little longer ;)

I remember that Ubuntu Breezu Badger was released using OpenOffice.org 2.0 Beta2... Yes I know, it was 3 years ago ;)

Chris Cheney (ccheney) wrote :

Maybe, but it depends on how delayed the final release is. If it somehow releases before the end of September we might be able to get it in still, but I doubt that it would be allowed in if it is delayed past the Intrepid release.

Chris Cheney (ccheney) wrote :

After the OOo Release Status meeting this morning it appears they are trying to target a release date of Sept 22 which should be plenty of time to get OOo 3.0 into Intrepid as the main version... if it actually happens.

Chris

Chris Cheney (ccheney) wrote :

It it is now pushed back to Sept 30.

Niels Egberts (nielsegberts) wrote :

I also would like to see 3.0 as a separate package, in bug #229054 the 3.0 beta2 package has been packaged. But has the packaging for RC1 already started? I would be willing to help testing it.

Colin Watson (cjwatson) wrote :

Chris has now packaged RC2 in https://launchpad.net/~openoffice-pkgs/+archive, although it's still called openoffice.org-* so you can't test it in parallel with an OOo 2.4.1 installation. I've asked Chris to rename these packages to openoffice.org3-*, which means that the PPA could be a useful test for parallel-installable packages in Intrepid.

Colin Watson (cjwatson) wrote :

Pushing milestone back to final.

Changed in openoffice.org:
assignee: nobody → ccheney
milestone: ubuntu-8.10-beta → ubuntu-8.10
Benjamin Drung (bdrung) wrote :

OpenOffice.org 3.0 is out. You can find the final version on the mirrors. An official release announcement is expected tomorrow.

I use it since 3.0rc2 and it is very stable with official debs from openoffice.org.

Let's hope it could be included for Intrepid Ibex. As Mandriva 2009.0 give it, why not Intrepid Ibex ?

I think it's final and not rc right now, so, please include it to 8.10.

http://blogs.zdnet.com/hardware/?p=2704

Ron B. (flybye882001) wrote :

The final has been released. See http://www.prweb.com/releases/OOo/3/prweb1459364.htm for the press statement.
So how about it folks - Oo-3 in 8.10!!?

Exsecrabilus (exsecrabilus) wrote :

Also, you must realize that if Ubuntu truly wanted to, it would have included OpenOffice.org already.

Developers, you cannot complain that it is already past feature freeze, and that it's too late. Nonsense.

Let's say you did the same thing with GNOME. GNOME 2.24 released well after Intrepid's feature freeze. But did you not include it? Of course you included it! How? By providing GNOME 2.23, the DEVELOPMENT version of GNOME 2.24, and changing that to GNOME 2.24 after the feature freeze, falling back on the alibi that 2.24 was only a bug-fix release for 2.23.

The same situation with OpenOffice.org. If you truly wanted, you could have provided 3.0 Beta, with 3.0 RC1, and so on. There, problems would have been found and solved. Exactly as you have done with GNOME.

I am aware GNOME is like the base, if not all of Ubuntu. But so is OpenOffice.org. It is one of the major symbols of open-source. I do not want to see Ubuntu ship with an outdated version of a major application when it has updated all others. I know openoffice.org splits into various files in the Ubuntu repos. You can delay 8.10 for a few days if necessary. You might say "You say that because you want your features. But we're developers, and have to keep on our schedule." Come on, Ubuntu is the biggest Linux distro. The public forgave you when you delayed Alpha 1 for like a month, it'll forgive you again if you delay it for like a few days.

Dimitrios Symeonidis (azimout) wrote :

come on, guys, there's tons of bugs for intrepid that still need to be fixed. go do your 5-a-day to fix those, and quit whining about oo.o3 not being included. i'm sure they'll include it after 2-3 weeks or something!

Hi Exsecrabilus, thanks for your input but I think you are missing two
or three key points.

1) Intepid did not ship any beta/RC version of OO 3.0, like they did
with Gnome (2.23), so comparing the two is not valid. If there are any
serious bugs we may not have time to catch them and this could result
in a disappointing and unpolished experience for OO users.

2) There are users just as vocal and adamant as you on the OTHER side,
who would yell and scream if Ubuntu shipped OO 3.0 with bugs, and that
it shouldn't have been pushed in past the feature freeze just to
appease a few people who could easily install it themselves (see #3)
if they weren't concerned with something as stable and thoroughly
tested. A large part of the appeal of Ubuntu to many users is that
when a release comes out, all the applications have been tested for
months already and have all the kinks worked out. If we start throwing
in completely new versions of major applications mere weeks before a
release, Ubuntu will lose a lot of stability and reputation.

3) You (and any other user) will be easily able to install OO 3.0
yourself via a deb/ppa/backport if you so desire. It is a great
candidate for a backport and will probably be backported soon after
release (see https://help.ubuntu.com/community/UbuntuBackports for
more information).

This seems like a win/win to me, since users who want stability and
polish get it by default, and users like yourself who want more
bleeding edge can easily enable it in many ways as I mentioned above.
I don't really see the gripe. As such if the decision is to stay with
2.4 for Intrepid (only 6 months after all), I think it makes sense,
and OO 3.0 can be stabilized by Intrepid backport users and Jaunty
alpha/beta testers.

I really hope to see this happen. Seeing OO3 in Intrepid is a huge deal. I strongly vote for Ubuntu to put the resources needed into getting it in the final releases of Intrepid.

Well, Ubuntu is supposed to be very user friendly, any new user would not be able to install OO.o 3 on their own, it isn't just one .deb, you need to install like 20 .deb packages at once, needs to be done via the shell. Secondly, OO.o 3 seems to be very stable, if we put it into Intrepid there will be very few bugs, I haven't noticed any, we would be able to bug squash in two weeks. Thirdy, for those of you that say, well just upgrade the package from 2.4.1 to 3.0 a few weeks after Intrepid's release, thius will NOT happen, major version changes never happen in normal releases, that is why there was so much pressure to upgrade to FF 3 RC in Hardy, because FF 2 would't be supported long enough and no major version changes. The worst thing that can happen is a relatively small bug popping up for a few users after Intrepid is released, and an average upgrade could fix that easily.

It's prefere to delay Intrepid 1week that don't ship With OO.o 3.0.

Aaron (soulblade) wrote :

Ubuntu has become known for predictable release schedules, Unless there is a bad kernel (or X) bug such as e1000e (Now fixed) than 8.10 should be released on time.

Flavelle (flavelle.ballem) wrote :

Open Office 3.0 has been released to-day (Oct-13-2008). I suspect that it's too late to be included in Intrepid, but it should absolutely be a high priority in terms of backport / update in Intrepid.

knarf (launchpad-ubuntu-f) wrote :

Even though there are sure to be bugs in 3.0.0 I'd prefer for Intrepid to be released with it instead of 2.4.1. My motivations for this are: Intrepid is NOT an LTS release, meaning that those who are in search of stability and support will most likely not choose Intrepid for deployment. This gives more leeway for potentially troublesome packages (not that OOo 3.0 has been troublesome, the beta and RC's have been quite stable).

Including OOo 3.0 now instead of in the next release gives it more exposure and hence more chance to find any troublesome bugs before it is time to release the next LTS.

Patrick Rady (prady) wrote :

I would rather Intrepid be delayed than shipped with OOo 2.4.1.

Ship it with OOo 3.0!

Herbert V. Riedel (hvr) wrote :

maybe it's a marketing thing... every new feature in intrepid is one less to attach to jaunty... :-)

anyway, I'll install and use OOo3 instead of OOo2.4 on intrepid, one way or another...

mihai007 (mihai-ile) wrote :

I would also like so see 3.0 included, and I think it is always good to delay 1 week to solve more Ubuntu bugs. I mean hey you delay 1 week and have a better Ubuntu for 6 months...

der_vegi (m-may) wrote :

Well, I also would like to have it included, but I also see the point of the devs.
So why not put 3.0 already now in the backports and leave it there even after the release? Like this, all the users who want it, could include it already now easily and help finding bugs. Even the newcomers would not find it too difficult to enable backports over synaptic. And the users looking for stability will not enable backports...

Luís Silva (luis) wrote :

I second this request...

Correct me if I'm wrong, but backports is a reporitory for software that is in the release+1, but compliles OK with the current release... This is not very good in what relates to bug correction and user experience... If a usr notices a bug in this backport, it will report it through launchpad and he will see it being corrected in the next release but not the current one... This is very frustrating. Also, if Open Office correctly (or mostly) opens docx, etc... it would be a great help into stealing windows market share to ubuntu...

Bugs are more tolerable than a missing feature to a general user. Also, bugs get corrected in time... Missing features don't... And no, backports is not an answer to this... It's a very good effort generally, but I wouldn't trust it with my eyes closed on a package such as this...

plun (plun) wrote :

As mention above I also prefer a delay and there are bugs enough for that even
without OO-3, I cannot see any bug running Calcs ppa and RC4.

OO-3 is just about this, "Do you Ubuntu ? "

http://www.librarian.net/stax/2042/do-you-ubuntu/

Backports, ppas and so are more for "crazy nerds".... not for normal users or newbies.

Exsecrabilus (exsecrabilus) wrote :

Mike Rooney:

1. What I'm saying is, if you wanted to, you could have. At alpha 1. But you didn't. Your loss.

2. True. There were those that yelled when Hardy shipped with Firefox 3. But did that do anything? No. They were merely drowned down by the praise of the new features in Firefox 3.

3. I don't want it in Backports. I want it in Main. As default. What I want is what the majority want. Where I go the majority follows, where the majority goes, I follow.

KevinM (kevbert1) wrote :

Request OOO 3.0 in Ubuntu Intrepid or as an update in 8.10.1 please.

Exsecrabilus (exsecrabilus) wrote :

There will be no such thing as 8.10.1. That is only for LTS releases. And x.xx.X releases aren't anything special but bug-fix updates pre-applied.

Bert Van de Poel (bhack) wrote :

I think OOo 3.0 should at least be added to main. It would be nice if it was a standard part of 8.10 but otherwise it should be at least an option, it should be installable through a meta-package in synaptic/whatever package manager

Brett Alton (brett-alton) wrote :

I see no reason why 3.0 is of great importance for people to immediately upgrade to.

The front-end looks verbatim to their 1.1 to 2.4 series and the backend has new features that the home user rarely needs.

You're just kinda blind so. Let's sum it up :

- 1024 columns in calc instead of 256
- ODT 1.2 support
- Microsoft Office 2007 format opening and writing
- VBA support
- new icons
- better note system

And a lot of bug squashed. Why moving to 3.0, so ?

Mathi (mathiraj) wrote :

i think openoffice in general goes through much testing before getting released. I have never bumped into any openoffice crash or bug in my years of using open office. It'd would be an very nice to have OO3.0 with 8.10

Colin Watson (cjwatson) wrote :

GNOME gets an exception from the general procedure because it has a very reliable release schedule that we're in sync with, and so it makes absolute sense to keep up with it. This does not go for OpenOffice.org; until quite recently we could not even have said reliably whether it was going to ship before Ubuntu 8.10, despite originally setting a release date of months ago, and so upgrading to an alpha in intrepid would have been very risky. I appreciate that it is a very important part of the desktop, but that is exactly why we don't want to drop a broken version in at the last minute.

Firefox 3 was unusual because we were going to have to support Ubuntu 8.04 for three years on the desktop, and we knew that Firefox has a history of making it very difficult in practice for us to offer security support for older versions over an extended period of time. This has not historically been a concern for OpenOffice.org, and furthermore Ubuntu 8.10 only needs to be supported for 18 months, so this is much less of a concern.

Furthermore, apparently the scheme that used to be used to produce versioned packages (openoffice.org2-*) has bitrotted for reasons I'm not entirely familiar with, so we couldn't use this to produce parallel-installable openoffice.org3-* packages (which was something I had asked Chris to do). This means that upgrading to OpenOffice.org 3.0 is an all-or-nothing proposition; due to the complexity of the packages involved, rolling it back to 2.4.1 with epoch versions would be very difficult indeed and would probably cause other problems. Far too risky for this stage in our release cycle.

Regarding the comments about release timings in general, I believe that https://wiki.ubuntu.com/TimeBasedReleases addresses these quite adequately, and at the moment we have no intention of slipping Ubuntu 8.10's release. We would only be prepared to negotiate that for showstopper problems, and while I understand that this is very important to some people it is not a showstopper.

The plan at the moment is to put OpenOffice.org 3.0 into jaunty, and then consider offering it in intrepid-backports if it tests out reasonably well there.

dje (duncaneastoe) wrote :

Requesting OO.o in 8.10

dje (duncaneastoe) wrote :

3.0 that is!!

fab (fab-head) wrote :

Please add OOo to 8.10 :)

fab (fab-head) wrote :

Please add OOo 3.0 to 8.10 :)

Robert Nasiadek (robzon) wrote :

So much for the "latest and greatest". It's a shame that such a significant upgrade won't make it to the final release. And a marketing gaffe, too. We've already lost A LOT due to the lack of new theme despite the promises. People ask me what's so exciting about Intrepid and I don't really know what to tell them anymore.
I wouldn't mind if at least the backports repository actually had the latest software. Waiting 6 more months is daunting to say the least.
Well, the good thing is there will always be PPAs to turn to for the a little bit more advanced users.

<joke>
So.. if you want Ubuntu to include the latest version of your software, cripple security updates for older versions. You'll be much more likely to get an exception next time. :)
</joke>

Chris Cheney (ccheney) on 2008-10-16
Changed in openoffice.org:
milestone: ubuntu-8.10 → intrepid-updates
description: updated
Michael Rooney (mrooney) on 2008-10-23
description: updated
Haukee (giga-killer-bee) on 2008-10-27
Changed in openoffice.org:
status: Triaged → Confirmed
Chris Cheney (ccheney) on 2008-10-27
Changed in openoffice.org:
status: Confirmed → Triaged
Mike Kusold (kusold) on 2008-12-05
description: updated
77 comments hidden view all 157 comments

Hi all,
 Noel isn't calc the one who's doing the PPA. I just know the
nickname. It may turn out that calc = Chris Chenney in which case I
would say thank you as well :)
--
          Regards,
          Shirish Agarwal
  This email is licensed under http://creativecommons.org/licenses/by-nc/3.0/
http://flossexperiences.wordpress.com
065C 6D79 A68C E7EA 52B3 8D70 950D 53FB 729A 8B17

Made an update today. OOo still crashes, when openoffice.org-kde is installed.

I saw the new files on the PPA, but I can only install it (on jaunty) using the intrepid backport.... choosing jaunty branch doesnt install...

Chris Cheney (ccheney) wrote :

Shirish,

Yes I am calc, as noted on my launchpad account under irc nick. :-)

BUGabundo,

The jaunty packages are in jaunty it just hasn't built yet due to waiting on the MIR bug to be processed.

Chris

lanzen (lanzen) wrote :

I can confirm what bendemann said about openoffice.org-kde. Removing it cures the crashes, but removes menus and icons.

orGSD (gerard-d+launchpad) wrote :

I wanted to add that my father updated to openoffice.org - 1:3.0.0-6ubuntu0intrepid1 today on his kubuntu machine through Adept and is now stuck with the same crash document recovery loop as discussed here. Whether choosing to go with the "Untitled" document recovery or not results in a crash. It is there on the next start and the process continues.
I have tried to diagnose over the phone with him, removing the openoffice.org-kde package results in openoffice working but the interface becomes difficult to use.
I had him try closing OOo with the OOo-kde integration removed so that it would close cleanly, then reinstall it and re-open it. It immediately starts with the document recovery even though it was closed cleanly.
Is there anyway to downgrade to 3.0.0-4/2 or whatever version was previous to -6 which is stuck in this crash loop ? Or are there any recommendations other than removing the kde integration? (His machine is amd64/kubuntu 8.10)

Cheers,

 orGSD

Chris Cheney (ccheney) wrote :

So apparently enabling GIO or enabling KDE4 support both cause OOo 3.0 to crash on start. :( Which was why it crashed on Gnome until the last upload, which I disabled GIO support in. I will look into if it is possible to fix the KDE support for 4 without having to fall back to 3.

orGSD (gerard-d+launchpad) wrote :

For what it is worth, my wife and mother, who also are using kubuntu 8.10, have 3.0.0-2 from your ppa and it is working brilliantly. I have instructed both to not upgrade at the moment. I suspect that is also the version that was on my father's machine before his upgrade and consequent crashes. I don't know if that helps narrow down what was introduced between 3.0.0-2 and 3.0.0-6 which has introduced crashing under KDE4. I apologize for all of these third party accounts, but I am the odd one out in the family. While my wife and folks run kubuntu, I run gentoo. Thus my experience is somewhat limited. I looked on my wife's laptop and didn't see anyway in synaptic to downgrade to a previous version to walk my father through downgrading from 3.0.0-6 to something which worked. I appreciate your looking into this!

Cheers,

 orGSD

openoffice.org-kde 3.0.0-6 crashes OpenOffice as described in previous post. As mentioned in this thread http://ubuntuforums.org/showthread.php?s=3bb68a2a873eebe15c4e4327fe0bb25c&t=993516&highlight=untitled+crash+openoffice.org-kde&page=5 the problem has been introduced with openoffice.org-kde 3.0.0-6. Copying over files from -5 fixes the crashes.

dorpm (dorpmueller) wrote :

Yesterday the update to RC1 came into my system and since that I cannot save any data from OO writer. Whenever I try the GUI freezes and I have to terminate the x session. To continue working I have downgraded to the former version (something like a3.0.0-6ubuntu...). Now I can save my work again.

My OS is Kubuntu Hardy.

It seems that this bug should have a high priority. (Also here: https://bugs.launchpad.net/ubuntu/+bug/316546 because I found this thread later).

Regards,
Florian

Chris Cheney (ccheney) wrote :

I just uploaded a new set of debs resolving the KDE mess again, I won't be turning KDE 4 support back on again without someone telling me it works for certain as there was miscommunication about working recently.

Also 3.0.1 release date is now scheduled for Jan 22 so perhaps we can get some official backports shortly after that time.

dorpm (dorpmueller) wrote :

@Chris,

thanks for reacting so fast but unfortunately this "KDE mess" is still there. So I downgrade to 3.0.0-6 again.

Cheers,
Florian

Chris Cheney (ccheney) wrote :

Florian,

The version that will be on the alpha 3 cd should work without crashing on KDE but as I understand the file picker doesn't currently work under KDE you can go in and turn off the integrated menu by selecting 'Tools->Options->OpenOffice.org->General->Use OpenOffice.org dialogs' which will use the non-native dialogs.

I have heard rc2 which should be out by next week will have properly working KDE dialogs.

Chris

2009/1/14, Chris Cheney <email address hidden>:
> Florian,
>
> The version that will be on the alpha 3 cd should work without crashing
> on KDE but as I understand the file picker doesn't currently work under
> KDE you can go in and turn off the integrated menu by selecting
> 'Tools->Options->OpenOffice.org->General->Use OpenOffice.org dialogs'
> which will use the non-native dialogs.
>
> I have heard rc2 which should be out by next week will have properly
> working KDE dialogs.
>
> Chris
>
> --
> [intrepid] Package OpenOffice.org 3.0 for Backports
> https://bugs.launchpad.net/bugs/267376
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Vladimiro Boffi

I had the problems with KDE too and solved it weeks ago this way. Most of us are using a gtk wrapper like gtk-qt-engine. So just install openoffice.org-gtk and everything is fine. Makes no difference.

Noel J. Bergman (noeljb) wrote :

Something is seriously wrong with the RC. I have it and the 3.1 milestone installed. The previous 3.0 was OK, but this one blows up the entire X session as soon as I try to access Help (possibly more things). The 3.1 milestone works fine, as did the previous 3.0 builds.

Please advise as to what I can provide that will be helpful. Host is T61p 6457-7WU, which means nvidia (177.82).

Noel J. Bergman (noeljb) wrote :

Clarification: that problem happens on Intrepid -- it does not blow up on Jaunty.

Jaime R. Garza (garzaj) wrote :

Hello,

I have problems with my graphics as soon as I run OpenOffice on Intrepid, the clock and menu fail completely. If I close the application then the graphics are fine again. Please, downgrade the packages on the launchpad repository to the version 3.0 which was working without problems.

Cheers!

Jaime R. Garza (garzaj) wrote :

Just to specify, I'm using Nvidia driver on a amd64. I installed the same on a 32 bit computer without Nvidia drivers and have no problems.

Max Randor (max-randor) wrote :

I was using the OO.org rc1 3.01 from the launchpad repository on 32bit with Nvidia drivers but it was completely broken. All parts of OO.org crashed on startup.
I say this because this points to an interaction with the Nvidia drivers causing the breakage.
I have had to downgrade to the 2.4 version in the offical repositories to get OO.org working again - to do this I removed the launchpad repository, removed OO.org and then installed OO.org again. Hopefully I haven't lost too many settings in the process.
I would recommend downgrading back to the 3.00 version as this actually appears to work where the 3.01 bug-fixing release is broken :-)

Geoffrey Thomas (geofft) wrote :

Hey,

What's the status of getting this package into backports? It looks like both OOo and go-oo 3.0.1 are out now, but I don't see this package in intrepid-backports.

Daniel Hollocher (chogydan) wrote :

I think it would be wise to set a cutoff date for getting OOo3 into intrepid. Jaunty seems right around the corner, and feature freeze is next week (which marks the beginging of jaunty's testing phase, I think) . Obviously, at a certain point, it wouldn't make sense to continue to try to backport packages to intrepid.

That feature freeze seems like a good cutoff point.
*ducks*

Bryan Quigley (bryanquigley) wrote :

I've been using the current version in the PPA for about a month now and it works for me with nvidia 96xx series. Are KDE/other nvidias still a trouble spot or can we get this into backports?

Adding Hardy/Intrepid backports to the bug, so backporters can begin to test packages...but as Chris said to me I think we should wait for backport OOo 3 because there are still some issue (e.g. gvfs)...

Changed in intrepid-backports:
status: New → Incomplete
Changed in hardy-backports:
status: New → Incomplete
emarkay (mrk) wrote :

Therefore - what it the procedure to get OO3.X into Intrepid, for those that want it. We know it's not officially supported, but want it, and would like to have the "best" suggestions from the "source".

This site seems to be the "top of the pile" in regarding the process , FWIW
http://news.softpedia.com/news/How-To-Install-OpenOffice-org-3-0-in-Ubuntu-8-10-96449.shtml

Thanks!

Chris Cheney (ccheney) wrote :

emarkay,

Yep, softpedia appears to tell the correct way to get the openoffice-pkgs ppa debs which are the ones that I create.

I'm still beating on gvfs at the moment, currently any gio/gvfs (Gnome smb/sftp/etc file shares) do not work for me with OOo. I know of a workaround but I am currently trying the fix issue in a better way. By Jaunty beta I will have to have decided on which way to go, if I can't fix the issue I will fall back to the workaround.

Chris

I for one never got 2.4.1 on Intrepid to open remote shares (SSH Share, I
think using gvfs). (never tried with 3.0.1 on Intrepid cause I assumed it
wouldn't work)
Just gave Jaunty a go and gvfs with 3.0.1 works like a charm.

Is the problem that it won't work like that if 3.0.1 is backported to
Intrepid? I think that's fine (especially for backports), it never worked
before (for me).

Bryan,

The last time I tested it I think it didn't work on SMB (Samba and Windows filesharing) either. Using gvfs fuse it seems to work but that would require completely disabling gvfs/gio support in OOo, and I don't think that Hardy has gvfs fuse, so those users would be left out if I can't find a way to make it work with gvfs.

Chris

Chris Cheney (ccheney) wrote :

I have uploaded OOo 1:3.0.1-7ubuntu1 for hardy and intrepid to the openoffice-pkgs ppa. They should be done building sometime Saturday.

Mantas Kriaučiūnas (mantas) wrote :

Hi all,

Chris Cheney wrote on 2009-03-21: (permalink)
> I have uploaded OOo 1:3.0.1-7ubuntu1 for hardy and intrepid to the openoffice-pkgs ppa.

Thank you very much. I have question/bugreport about OOo 1:3.0.1-7ubuntu1 from openoffice-pkgs ppa - why openoffice.org-core 1:3.0.1-7ubuntu1 package from Ubuntu Jaunty doesn't depend on librdf0, while packages from PPA depends on this library and forces Intrepid and Hardy users to install lots of unneeded packages, like libmysqlclient and mysql-common...

I've found a bugreport from <email address hidden> in Debian about this problem (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=511841), Steve wrote there:
"For the time being, OOo is switching back to use the bundled copy of redland in Ubuntu"
If you are using bundled copy of redland in official Ubuntu OOo build, why don't to use the same build config in openoffice-pkgs PPA builds ? I think it's better to have as identical builds as possible to give Ubuntu 8.x users a possibility to test new OOo and find Ubuntu Jaunty's OOo bugs.

Mitchell (mitchellvc) wrote :

I realized hat I cant update to openoffice 3.1 RC2 recently uploaded because it does not accept the language-support-es package from intrepid. If I install it (after removing openoffice 3.0) then language support is uninstalled, if I try to install language support again then openoffice 3.1 is unistalled. finally i have uninstalled OOo 3.1.
On the other hand, the splashimage showed when its launched says openoffice 3.0. shoudn't it say openoffice 3.1?

Chris Cheney (ccheney) wrote :

Mitchell,

This issue should be resolved in the next couple days, I am currently waiting on karmic to be fixed it currently has a problem with linux-libc-dev headers missing. There was a bug in the ppa openoffice.org-l10n that I have resolved in the bzr repo and will be fixed when I upload the new version. Also the splash screen is out of date and I will need to get a new one from our artist. To verify which version you have installed you can either look in the package manager or under Help->About in OOo.

Chris

Mitchell (mitchellvc) wrote :

Chris:
The problem between openoffice 3.1 and language-support package is still there, despite new OOo packages have been uploaded. So I wasn't able to test them since i dont wanna lose translations in my other apps. Let us know when it finally is fixed, thanks.

I see that the new packages just finished building in the PPA, but
openoffice.org-l10n - 1:3.1.0-1ubuntu2~jaunty1 failed to build again
:-/

summary: - [intrepid] Package OpenOffice.org 3.0 for Backports
+ Package OpenOffice.org 3.x for Backports
Changed in hardy-backports:
status: Incomplete → New
Changed in intrepid-backports:
status: Incomplete → New
Chris Cheney (ccheney) on 2009-10-06
Changed in openoffice.org (Ubuntu):
assignee: Chris Cheney (ccheney) → nobody
milestone: intrepid-updates → none
cement_head (andor-udel) wrote :

Hello,

Any chance of getting the intrepid packages for 3.01 restored to the PPA repository?

I really appreciated all the work that was done for this...

- Andor

Chris Cheney (ccheney) wrote :

cement_head,

I doubt that I will put new Intrepid debs up as there have been two new releases of Ubuntu since then 9.04 and 9.10 and support in general for 8.10 will be dropped in about 6 months. However, I might upload new debs for Hardy if I get some spare time.

Chris

Hi Chris,

    Any chance you could put the previously built ones back up?

Thanks

On Thu, 2009-10-29 at 12:23 -0400, Chris Cheney wrote:

> cement_head,
>
> I doubt that I will put new Intrepid debs up as there have been two new
> releases of Ubuntu since then 9.04 and 9.10 and support in general for
> 8.10 will be dropped in about 6 months. However, I might upload new debs
> for Hardy if I get some spare time.
>
> Chris
>

____________________________________________________________________
Andor J Kiss
Adjunct Assistant Professor
Department of Zoology - 194 Pearson Hall
Miami University
700 East High Street
Oxford, Ohio 45056
USA

eMAIL: <email address hidden>
Telephone: +1 (513) 529-3195
Fax: +1 (513) 529-6900
URL: http://openwetware.org/wiki/User:Andor_J_Kiss

Chris Cheney (ccheney) wrote :

Andor,

As far as I know there isn't a way to restore previously deleted debs.

Chris

cement_head (andor-udel) wrote :

Well...packages for Hardy would greatly appreciated.

Take care,
Andor

On Thu, 2009-10-29 at 15:19 -0400, Chris Cheney wrote:

> Andor,
>
> As far as I know there isn't a way to restore previously deleted debs.
>
> Chris
>

________________________________________________________________
Andor J Kiss
Visiting Assistant Professor
Laboratory for Ecophysiological Cryobiology
Department of Zoology - 194 Pearson Hall
Miami University
Oxford, Ohio 45056
USA

eMAIL: <email address hidden>
Telephone: +1 (513) 529-3195
URL: http://www.units.muohio.edu/cryolab/about/facbios.htm#AK_CV

Chris Cheney (ccheney) on 2010-03-26
Changed in intrepid-backports:
status: New → Invalid
Changed in hardy-backports:
status: New → Fix Released
status: Fix Released → New
Changed in openoffice.org (Ubuntu):
status: Triaged → Invalid
Changed in openoffice.org (Baltix):
status: New → In Progress
Mantas Kriaučiūnas (mantas) wrote :

OpenOffice.org 3.1 and newer packages on Ubuntu 8.04 (hardy) doesn't associate with Text documents, Spreatsheets and other files until desktop-file-utils 0.15-2 or newer package is installed. OOo doesn't open word documents and other supported files by double clicking in file-manager, because update-desktop-database command was removed from openoffice.org packages and dpkg triggers are used instead, see desktop-file-utils changelog:

desktop-file-utils (0.15-2) unstable; urgency=low
  * Do not hardcode the path to update-desktop-database in postinst.
  * postrm: remove created caches upon removal.
  * triggers: register interest in /usr/share/applications.
  * postinst: run update-desktop-database when triggered.
[..]

Changed in hardy-backports:
status: New → Invalid
Displaying first 40 and last 40 comments. View all 157 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.