Baltix GNU/Linux

[jaunty] Openoffice doesn't really use GVFS

Reported by Cédric Jeanneret on 2008-07-11
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
openoffice.org (Baltix)
Undecided
Unassigned
openoffice.org (Ubuntu)
High
Chris Cheney
Nominated for Jaunty by Itai Molenaar

Bug Description

Fix gio in OOo 3.0.1 to try to resolve this problem.

===

Binary package hint: openoffice.org-gnome

Hello,

Seems that OpenOffice doesn't use GVFS, or is buggy.

Steps :
- I mount my smb share through a bookmark (in .gtk-bookmarks : smb://server/share ), it asks for my username/password, so far so good
- I open a OOo document right after the mount, it works fine, so I closed the file, closed Nautilus so that I don't have any window linked to the share
- I waited about 1h without touching the share, working on other stuff
- I opened another file with OOo from the share. And OOo asked me my idents, though GVFS didn't ask for anything when I opened my filemanager...

Shouldn't GVFS communicate sessions with OOo so that we don't need to recall our idents every X minutes?

Versions :
- Description: Ubuntu 8.04.1
- Release: 8.04
- Kernel: 2.6.24-19-generic
- openoffice.org-gnome 1:2.4.1-1ubuntu2
- gvfs 0.2.4-0ubuntu1
- gvfs-backends 0.2.4-0ubuntu1
- gvfs-fuse 0.2.4-0ubuntu1
- libgvfscommon0 0.2.4-0ubuntu1

It's really annoying, and because of this behavior, we can't upgrade our office to Hardy (users will go crazy after 2 hours of this thing)

If someone has a working work-around, or a patch, or...

Thanks in advance

Regards

C.

Chris Cheney (ccheney) wrote :

Yes, it doesn't use GVFS, hopefully we will be able to get it to use GVFS for 3.0 in Intrepid. Or otherwise switch it to use %F instead of %U so that gvfs fuse can provide files to OOo.

Thanks,

Chris

Changed in openoffice.org:
importance: Undecided → High
status: New → Triaged
assignee: nobody → ccheney
milestone: none → intrepid-alpha-4
Martin Pitt (pitti) on 2008-08-12
Changed in openoffice.org:
milestone: intrepid-alpha-4 → intrepid-alpha-5

Hi,

Thanks for your answer. What do you mean by "use %F instead of %U" ? is it an option in OOo, Nautilus.. ?

Chris Cheney (ccheney) wrote :

Its a setting in the .desktop file for the application. After testing it doesn't seem to work properly at least on Ubuntu 8.04 (Hardy).

Chris

hm, well.... as it's THE point which block us for our upgrade gutsy->>hardy... maybe have you another workarround ?
I thought about saying to nautilus to link file:///home/<user>/.gvfs/path/to/file instead of smb://path/to/file. but I guess it's what you suggested with %F (maybe "file") instead of %U

thanks for your time

Regards

C.

Hello again. I searched google and IRC (#<email address hidden>) for some things.
Here's what I found :

I changed in my /usr/share/applications/ooo-*.desktop %U by %F so that it will use filesystem path instead of "virtual" (and thus use ~/.gvfs/).

Now I can open files through Nautilus in OOo without problem; I can save them without problem, so long I don't try to override them.
And just now, as I'm trying to export a odt file to PDF through OOo export, it returns me a really strange error :
"Error saving the document test:
/home/<user>/.gvfs/path/to/file.pdf on fileserver/test.pdf does not exist."
hu ?! How comes it takes now my path from smb share??

Another funny thing I discover yesterday : "ooffice -writer" does NOT work as "oowriter"! See https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/261148 for more informations.

All this stuff is really strange. I found on google multiple threads regarding problem with OOo and network filesystem, especially samba sharing.

I don't know what I can do for this stuff.... maybe simply use the old and ugly hack we used on gutsy, but as said, it's really ugly. mounting smb share in userspace is really nice -.-

I join here dialogs I have when I export to PDF;
As you can see, all seems to be all right in the first dialog; paths are correct. But the error let me think there's a "small" problem, as it seems to use smb instead of .gvfs path...

I join here dialogs I have when I export to PDF;
As you can see, all seems to be all right in the first dialog; paths are correct. But the error let me think there's a "small" problem, as it seems to use smb instead of .gvfs path...

I found this thread : http://user.services.openoffice.org/en/forum/viewtopic.php?f=16&t=7352&start=0&st=0&sk=t&sd=a
ok, it's about fedora core 9, but...
I checked which java was installed, on my computer it's:
sun-java6-bin
sun-java6-jdk
sun-java6-jre

.. doesn't seem to be the same problem. Fact is, it seems to work on fedora 9 :S

Chris Cheney (ccheney) on 2008-09-03
Changed in openoffice.org:
milestone: intrepid-alpha-5 → ubuntu-8.10-beta
Konstigt (konstigt) wrote :

There is a newer bug #229839 which is pretty much the same bug. This bug is however set to status wishlist(!).

Konstigt (konstigt) wrote :

Sorry, not newer, I meant older! Created 2008-05-13.

Chris Cheney (ccheney) on 2008-10-15
Changed in openoffice.org:
assignee: ccheney → nobody
milestone: ubuntu-8.10-beta → none
Chris Cheney (ccheney) on 2008-11-01
Changed in openoffice.org:
assignee: nobody → ccheney
milestone: none → jaunty-alpha-1
description: updated
Chris Cheney (ccheney) on 2008-12-01
Changed in openoffice.org:
milestone: jaunty-alpha-1 → ubuntu-9.04-beta
Kim d'Audretsch (kimda) wrote :

This bug is very annoying I hope it gets fixed really soon!! And also the fix get released for Intrepid and other versions. Let me tell you how I have to work right now: When I have to save a openoffice document I have to save it in my home folder after working on it then I have to move it to the network location because it won't save directly to it. I am considering using nfs instead of samba and then to circumvent gvfs all together.

in fact, after some discussion with OOo developpers, it seems they're changing their lock system. it will be far better. still buggy for now, it should come in 3.x release.

Kim d'Audretsch (kimda) wrote :

A temporary fix until the openoffice devs fixed this bug.

Use cifs mounts to mount the share directly.

Add an line to /etc/fstab to mount the samba share directly and you will not experience the problems caused by using gvfs.

Here's how:
Add a line for each share you want to open to the /etc/fstab file

Either like this:
//192.168.44.100/share_name /path_to/mount_point cifs username=server_user,password=server_password,_netdev,uid=client_username,gid=users 0 0

or use a .cred file to store your password/username like I did because you do not want readable in /etc/fstab

//192.168.44.100/share_name /path_to/mount_point cifs credentials=/path_to/.creds,_netdev,uid=client_username,gid=users 0 0

example of .cred file
username=myusername
password=mypassword

chmod 600 .cred to make it only readable to the fileowner.

more info here:
http://www.swerdna.net.au/linhowtosambacifs.html

Kim d'Audretsch (kimda) wrote :

A temporary fix until the openoffice devs fixed this bug.

Use cifs mounts to mount the share directly.

Add an line to /etc/fstab to mount the samba share directly and you will not experience the problems caused by using gvfs.

Here's how:
Add a line for each share you want to open to the /etc/fstab file

Either like this:
//192.168.44.100/share_name /path_to/mount_point cifs username=server_user,password=server_password,_netdev,uid=client_username,gid=users 0 0

or use a .cred file to store your password/username like I did because you do not want readable in /etc/fstab

//192.168.44.100/share_name /path_to/mount_point cifs credentials=/path_to/.creds,_netdev,uid=client_username,gid=users 0 0

example of .cred file
username=myusername
password=mypassword

chmod 600 .cred to make it only readable to the fileowner.

yep, indeed. Unfortunately, this mount won't appear in nautilus... so we have to use a shell to mount it (not that I care, but the other users will....)

Kim d'Audretsch (kimda) wrote :

It will if you mount it in a folder in your home dir. And it will also show up on your desktop.

Chris Cheney (ccheney) on 2009-01-20
description: updated
Chris Cheney (ccheney) wrote :

I believe that this bug is essentially fixed in openoffice.org 1:3.0.1-5ubuntu1 in Jaunty as I have now turned off both gnome-vfs and gio in OOo. OOo is now patched to use gvfs fuse which should work. There are a few remaining bugs in gvfs fuse that cause saving not to work for ftp/webdav but those bugs are already filed in the gnome upstream bug tracker at:

http://bugzilla.gnome.org/show_bug.cgi?id=574968
http://bugzilla.gnome.org/show_bug.cgi?id=575150

Please let me know if this resolves your problem.

Thanks,

Chris Cheney

Changed in openoffice.org:
status: Triaged → Incomplete
Chris Cheney (ccheney) on 2009-03-22
Changed in openoffice.org (Ubuntu):
status: Incomplete → Fix Released

Ok, thanks.
For now we're using Intrepid, and this problem is still here... we'll try with jaunty when it's released [in some weeks if I'm not wrong].

I'll post update here when it's tested.

Regards,

C.

Chris Cheney (ccheney) wrote :

Yes, saving to network shares in Intrepid even with OOo 3.0.1 still does not work since the gvfs fixes have not been backported. It should work fine in Jaunty though.

Hello,

indeed, it just works, now. Sometimes OOo ask for idents, when we don't touch fileserver through it for some time, but it's really not a problem.

My Boss have a big smile now ;)

Thanks for this update. I think we can close this bug... but I'll open two other for Firefox and Thunderbird : they have quiet the same problem.

Regards,

C.

Mörgæs (moergaes) on 2013-11-19
Changed in openoffice.org (Baltix):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.