OOo extensions (.oxt) only show up as type application/zip

Bug #188401 reported by Olivier Mengué on 2008-02-02
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
openoffice.org (Baltix)
Undecided
Unassigned
shared-mime-info (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: openoffice.org

.oxt files should be opened with OpenOffice.org

OpenOffice.org extensions are downloadable from http://extensions.services.openoffice.org/
The manual says:
  You can install an user extension in a different ways:
  * (...)
  * By a double-click on the *.oxt file in your system's file browser.
  * On a web page by a click on the hyperlink to a *.oxt file.
See http://extensions.services.openoffice.org/resources/user/howto_install

Chris Cheney (ccheney) on 2008-03-07
Changed in openoffice.org:
importance: Undecided → High
status: New → In Progress

OpenOffice.org .oxt extensions are not identified in a way that can be associated with OpenOffice as far as I can tell. This should be fixed in shared-mime-info so that it is possible to do so OpenOffice extensions can be installed.

ccheney@laptop-c2d:~/Desktop$ gvfs-info Linguist-1.1.oxt | grep -i content
  standard::content-type: application/zip
  standard::fast-content-type: application/octet-stream

Changed in shared-mime-info:
milestone: none → ubuntu-8.04
status: In Progress → New
Changed in shared-mime-info:
status: New → Confirmed
Chris Cheney (ccheney) on 2008-04-01
Changed in shared-mime-info:
milestone: ubuntu-8.04 → none
Chris Cheney (ccheney) on 2008-05-08
Changed in shared-mime-info:
milestone: none → ubuntu-8.10-beta

I agree. It's also annoying that:
1. You can't add extensions, because the extension manager won't open.
2. Adobe air can't work, because it associates itself with zip files

Chris Cheney (ccheney) on 2008-08-14
Changed in shared-mime-info:
milestone: ubuntu-8.10-beta → intrepid-alpha-5
Fabián Rodríguez (magicfab) wrote :

In Intrepid, .oxt files are identified has "Type: OpenOffice.org extension (application/vnd.openofficeorg.extension)" however they are still assigned to open with the Archive Manager.

Fabián Rodríguez (magicfab) wrote :

gvfs-info Desktop/LanguageTool-0.9.2.oxt | grep -i content

  standard::content-type: application/vnd.openofficeorg.extension
  standard::fast-content-type: application/vnd.openofficeorg.extension

Chris Cheney (ccheney) wrote :

Fabian,

Yes that is because I added the mimetype to a file installed by OpenOffice.org, but long term this should probably be in shared-mime-info instead. I still have to determine how to cause the .oxt to properly be installed by double clicking on it, that part is a bug of the OpenOffice.org packaging.

Chris

Gabriel de Perthuis (g2p) wrote :

There is no switch for graphical or noninteractive installation of OOo extensions:
http://qa.openoffice.org/issues/show_bug.cgi?id=83448

Some extensions are OK, others will ask for a licence in the terminal.
You could associate the mimetype with this command:
sh -c "yes yes | LANG=C unopkg add $PATH_TO_OXT"
or maybe a command that runs unopkg add in a terminal.

Sebastien Bacher (seb128) wrote :

the current shared-mime-info knows about oxt

Changed in shared-mime-info:
milestone: intrepid-alpha-5 → none
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.