The openerp database should not be created via createdb (error: ir_module_module does not exists)

Bug #327998 reported by Peter Jantz on 2009-02-11
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Invalid
Undecided
Unassigned
openerp-server (Baltix)
Undecided
Unassigned
openerp-server (Debian)
Fix Released
Unknown
openerp-server (Ubuntu)
Undecided
Unassigned

Bug Description

/usr/share/doc/openerp-server/README.Debian says:

OpenERP uses a PostgreSQL database to store its data. With the first generation of packages, you have to setup this database manually. Here is a short explanation how to achieve this:
 1. Creating the database
     # su - postgres -c "createdb -q --encoding=UNICODE openerp"

These instructions are incorrect - according to openerp developers the openerp database should not be created via createdb, openerp-client should be used instead, see comments bellow.

Problem exists in 5.0.0-3-1 deb package. Please change instructions in /usr/share/doc/openerp-server/README.Debian and fix /etc/openerp-server.conf - remove line "db_name = openerp"

Please note for example
http://www.openerp.com/forum/post28290.html?sid=300711113191eabf7d63a55161d0f92a
http://www.openobject.com/forum/topic9192.html
http://www.openobject.com/forum/topic9048.html

Peter Jantz (peterjantz) on 2009-02-11
description: updated

How did you create your database ? with the clients or with createdb from postgresql ?

Thanks

Changed in openobject-addons:
status: New → Incomplete
Changed in openobject-addons:
status: Incomplete → Invalid

Hi

It's not a bug, you must create database with GTK Client, not with createdb

Regards,

em (carlem88) wrote :

hi

I have the same problem and i try to create data base with GTK client but i recieved yhis message "Error during database creation !"

Thanks

Can you paste your server log ?

em (carlem88) wrote :

[2009-03-03 15:24:45,265] INFO:server:version - 5.0.0
[2009-03-03 15:24:45,280] INFO:server:addons_path - C:\Program Files\OpenERP Server\addons
[2009-03-03 15:24:45,280] INFO:server:database hostname - localhost
[2009-03-03 15:24:45,280] INFO:server:database port - 5432
[2009-03-03 15:24:45,280] INFO:server:database user - Emile
[2009-03-03 15:24:45,280] INFO:objects:initialising distributed objects services

Can you comment log_level line in config server file
add ; at the begining of the line
and restart the server

Changed in openerp-server (Debian):
status: Unknown → New
summary: - ir_module_module does not excist
+ The openerp database should not be created via createdb (error:
+ ir_module_module does not exits)
summary: The openerp database should not be created via createdb (error:
- ir_module_module does not exits)
+ ir_module_module does not exists)
description: updated
tags: added: jaunty
Changed in openerp-server (Debian):
status: New → Fix Committed
Schmirrwurst (schmirrwurst) wrote :

I've submitted an update from the package that should correct this, you can try it, I hope some motu will commit it...
https://bugs.launchpad.net/ubuntu/+source/openerp-server/+bug/337759

Changed in openerp-server (Ubuntu):
status: New → Confirmed
Changed in openerp-server (Debian):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.