backported libgphoto can't import from canon S1 IS version from egdy does

Bug #91265 reported by Mateusz Holysz on 2007-03-10
16
Affects Status Importance Assigned to Milestone
Edgy Backports
High
Unassigned
libgphoto2 (Baltix)
Undecided
Unassigned
libgphoto2 (Ubuntu)
Undecided
Unassigned

Bug Description

after upgrade to backported version 2.3.0 it is not possibble to import photo from Canon S1 IS (ptp mode). Program says that usb port can't be reached (used)

Please refer to:

http://www.ubuntuforums.org/showthread.php?t=381431

and

http://www.ubuntuforums.org/showthread.php?t=381066

description: updated
John Dong (jdong) wrote :

Should be fixed in the ~edgy2 release of the backport. Reopen if not.

Changed in edgy-backports:
status: Unconfirmed → Fix Committed
tartanpion (rombaut-gerald) wrote :

The problem is not fixed for many users (canon powershot a620 in my case, ptp mode).
see the french forum :
http://forum.ubuntu-fr.org/viewtopic.php?id=99131&p=1

Changed in edgy-backports:
status: Fix Committed → Confirmed
hbbk (hbbk) wrote :

I can confirm, this bug still exist and BTW is not specific to canon S1, I have the same pb with finepix F30 (maybe not exactly the same pb as my camera is recognized but I can't read it from within digikam for ex - it was ok before the last upgrade).

John Dong (jdong) wrote :

Yikes.... umm, do these cameras work with the Feisty beta?

tartanpion (rombaut-gerald) wrote :

it seems to be a permission problem, tips like
- sudo chmod 666 /dev/bus/usb/00*/* ... or
- gksudo gnome-volume-manager-gthumb %h
help to import photo.

John Dong (jdong) wrote :

Can you ls -al /dev/bus/usb/00*/*

Changed in edgy-backports:
importance: Undecided → High
Kristof Bajnok (bajnokk) wrote :

Changing permissions of /dev/bus/usb/00*/* has solved the problem.
Maybe group owner of the devices should be something a normal local user belongs to. By default it is root:root mode 660.

Serge Hartmann (shartmann) wrote :

For a Canon Powershot S45 woking on edgy, and now failing on feisty with libgphoto2-2_2.3.0-0ubuntu4 - I unsuccessfully tried :
- forcing vendor/device id's to group lugdev in /etc/udev/rules.d/45-libgphoto2.rules
- in the same file, changing line BUS!="usb*", GOTO="libgphoto2_rules_end"
   by BUS!="usb_device*", GOTO="libgphoto2_rules_end"
   or SUBSYSTEM!="usb_device", GOTO="libgphoto2_rules_end" (and other suggetstions)
- changing rights on /dev/bus/usb/00*/*
A lot of topics in forums reveals the same problem with Canon cameras, libgphoto 2.3.0 for feity or edgy-backports.
The camera is well detected, but the system cannot read any files on it.

edgy is dead, if this is still an issue on modern releases, please file bugs there.

Changed in edgy-backports:
status: Confirmed → Invalid
Changed in libgphoto2:
status: New → Incomplete
status: New → Incomplete
Martin Pitt (pitti) wrote :

Since 8.04 we are using a more flexible approach of granting device access (not with udev rules any more), so I think this is fixed in current releases.

Changed in libgphoto2:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers