Baltix GNU/Linux

Can't recive files from cell phone

Reported by Alex Fiestas on 2007-09-28
64
Affects Status Importance Assigned to Milestone
kdebluetooth (Baltix)
Undecided
Unassigned
kdebluetooth (Ubuntu)
Undecided
Anthony Mercatante
Nominated for Gutsy by Ryan Novosielski

Bug Description

Hi, I'm using the last kubuntu gutsy beta and i detect a issue with kdebluetooth.

We can reproduce the issue easily, only need try to send any file from cell phone (or other bt device) to gutsy box, and the sender (cell phone for example) will say "Can't connect".

I fix it compiling and installing the kdebluetooth from kde subversion, and now all work nice.

You can build yourself with this guide:
http://bluetooth.kmobiletools.org/svn-howto

Aps remember, you need these packages:
build-essential automake autoconf libdbus-qt-1-dev libobexftp-dev and kde-devel (I'm not sure if it is needed).

Great job, the new kubuntu gutsy is in my opinion the best distro :)

Related branches

I can confirm this. It has been an issue for a while on Gutsy (see Bug #134585 ). Just tried booting the Gutsy Beta live-cd; and can confirm that the problem persists.

From /usr/bin/kblueplugd:

import commands

x = commands.getstatusoutput('ps ax|grep rotatelogs')[1]

#!/usr/bin/python
# -*- coding: UTF-8 -*-
"""
Copyright (C) 2007 Achim Bohnet <email address hidden>

This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation; either version 2 of the License, or
(at your option) any later version.
"""

import sys
from PyQt4 import QtCore, QtGui
import dbus
import dbus.mainloop.qt
import distutils.spawn

I think some patching went totally wrong, it has to look like this:

#!/usr/bin/python
# -*- coding: UTF-8 -*-
"""
Copyright (C) 2007 Achim Bohnet <email address hidden>

This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation; either version 2 of the License, or
(at your option) any later version.
"""

import sys
from PyQt4 import QtCore, QtGui
import dbus
import dbus.mainloop.qt
import distutils.spawn
import commands

x = commands.getstatusoutput('ps ax|grep rotatelogs')[1]

...

This does not fix receive files bug from the phone, as building svn does ...

Emanuel Goscinski (emu-) wrote :

Confirm this too.
It is impossible to send files from a bluetooth device i.E. cellphone to the computer.

My Cellphone just can't discover the laptop.

Changed in kdebluetooth:
assignee: nobody → txwikinger

will fix, thanks.

Changed in kdebluetooth:
assignee: txwikinger → hobbsee
status: New → In Progress

As written in irc and seen above:

1) /usr/bin/kblueplugd has errors (variables and statements before #!/usr/bin/python)
2) file receiving does not work

Currently workaround:
build svn version

What is not working:
build svn version as debian package, with just leaving kubuntu_08 patch out, perhaps debian patches are faulty, too.

kblueplugdev error is fixed in latest version 1.0~beta8-0ubuntu5

file receiving ist not working. debian packages seem working, rebuild on ubuntu.

Ryan Novosielski (novosirj) wrote :

I also have this problem. I really hope this is fixed prior to release.

Emanuel Goscinski (emu-) wrote :

Will this issue be fixed for till the Gutsy Release?

Fabio Povoledo (povvy) wrote :

I can confirm the bug is still present.. very annoying.. hope will be solved :)

Hannes Koller (hannes-koller) wrote :

Bug still present as of this writing. Sending a file from my Nokia 6600 to the computer immediately gives the error message "Sending Failed". Transferring files from computer to cellphone works fine.

erlguta (gonzalomarcote) wrote :

The same here.
It happen in both kubuntu i have installed. One in my laptop upgraded from feisty to gutsy and in my PC with a fresh install of Gutsy.
Sending a file from my Nokia 6670, or my Sony Ericsson k610i , or my Motorola, etc, etc in a second it gives the error message "Sending Failed".
It is an important bug for the people who needs to transfer photos all the time (it is important for my day to day job).
It is the first time i remeber kdebluetooth does not work from...i am using KDE (3 years or more).
It is very good to have new features, and now you can move the cursosr in the screen with the mobile or put one presentation in OO, but does not work the BASIC and more important, "sending files".
Please fix it.
Thank you for your job and your time.

looks like tonio has already removed the test code, in ubuntu5.

Changed in kdebluetooth:
assignee: hobbsee → tonio
sk0rp10 (matteo-andreozzi) wrote :

Confirmed in Gutsy Stable,
Kdebluetooth still doesn't work with file receiving

Anthony Mercatante (tonio) wrote :

I found the issue, just testing the package and will upload once the fix if confirmed to work

Anthony Mercatante (tonio) wrote :

kdebluetooth (1.0~beta9~r734866-0ubuntu3) hardy; urgency=low

  * Fixed packaging, libkbluetooth0.install installs kbtobexsrv.
    Closes LP: #146145

 -- Anthony Mercatante <email address hidden> Fri, 16 Nov 2007 10:30:57 +0100

Changed in kdebluetooth:
status: In Progress → Fix Released
Fabio Papa (papaf) wrote :

Ok, that's good to know. However, switching to Hardy just to fix kdebluetooth seems a little too much for me. Any chances of a backport?

Thanks!

millenium-hand (yairgordon) wrote :

Yep, I can also confirm it in Gutsy release.... very annoying... the bluetooth system is much cooler than before, except of course for the 'minor' problem of not being able to receive any files!!! :) Please could someone who's built it from svn package it to a .deb? Or could the maintainers please do the same? This is a major functionality problem. Thanks

Nick B. (futurepilot) wrote :

I noticed this says Fix Released however I still have this problem on Kubuntu Gutsy. Every time I try to send a file to my computer from my phone it fails.

Roberto Maurizzi (r-maurizzi) wrote :

Any news on this problem? I just booted into windows to transfer files from my cellphone to be able to do end-of-month accounting.

Can we have a backport from hardy (since hardy package don't work in Gutsy due to kdelibs dependencies)? Or, can we have the old package back, since the new beta removed the possibility to run a script on device presence, and I was using that script to control IM presence with Pidgin?

Ciao, RobM

Uqbar (uqbar) wrote :

Well, the fix has been released for Hardy alone.
As it fixes a packaging problem, not a coding one, would it be possible to "backport" it at least to Gutsy?
It'd be a no brainer, right?

Uqbar (uqbar) wrote :
Roberto Maurizzi (r-maurizzi) wrote :

I'd like to have some 'official' statement on what the problems are, and on what is the timeframe for a "supported" solution.

I can compile kdebluetooth myself, but I'm using Kubuntu because it has a good packaging system, not because I like to compile important features from scratch because someone decided it was funny to do an upgrade to a new half-broken version of something.

The situation right now is that I don't know if there are good reason to NOT release a backport from the fixed hardy packages. Maybe the dependencies are unsolvable. Or maybe the problem isn't fixed? I tend to think that it's not so easily done, or else someone would have done it... but maybe I'm wrong...

Please, say something! :-)

Ciao, RobM

Ciao, sono Uqbar su Launchpad.
Enzo per gli amici.

Il problema è, come in quasi tutte le distribuzioni, che le risorse
soprattutto umane sono limitate. E non tutte sono all'altezza.
Il problema del BT è nulla se pensi che non si riesce più ad attivare
il DMA e la modalità 32 bit sui dischi ATA e su molti S-ATA.
E sui kernel autocompilati, invece, la cosa funziona.

A me girano e non poco. Ma almeno per me le altre distribuzioni non
sono state migliori. Con Gentoo ho atteso mesi invano che mi dessero
il PostgreSQL, il GCC o il KDE più aggiornato. Nulla. Però si potevano
avere le ultime release dei "giochini" OpenGL!

Forse facendosi sentire ...

Il Monday 03 December 2007 17:18:58 Roberto Maurizzi ha scritto:
> I'd like to have some 'official' statement on what the problems are, and
> on what is the timeframe for a "supported" solution.
>
> I can compile kdebluetooth myself, but I'm using Kubuntu because it has
> a good packaging system, not because I like to compile important
> features from scratch because someone decided it was funny to do an
> upgrade to a new half-broken version of something.
>
> The situation right now is that I don't know if there are good reason to
> NOT release a backport from the fixed hardy packages. Maybe the
> dependencies are unsolvable. Or maybe the problem isn't fixed? I tend to
> think that it's not so easily done, or else someone would have done
> it... but maybe I'm wrong...
>
> Please, say something! :-)
>
> Ciao, RobM

--
Reg me, please!

Uqbar (uqbar) wrote :

Sorry, the above message was meant to be private to Roberto.
But I failed to choose the right "Mailto" from the list.
Any chance to delete it from here?

Roberto Maurizzi (r-maurizzi) wrote :

I agree with you that the problem is often manpower, but here we have a bigger problem: a maybe, especially out of UE, minor feature has been broken by adopting a beta version of a package. Was it necessary? No. Does it improve user experience? No. This beta has also other problems, mainly the new kbluelock is awkward (I have to reselect the device that locks the screen every time I login) and the old script that did this was able to do that AND other things, like using DCOP or DBUS to command other applications on the event of BT device appearance or disappearance.

It's obvious that something in the decision process failed, but since I don't like useless ranting, I ask: what can we do do avoid it in the future?
Do we have to become MOTU to help in these matters, or there's some kind of poll/forum/maillist where this kind of decisions are made where "normal users" can offer their opinion?
I'm not very competent in Ubuntu community workings (especially Kubuntu ones) and I have limited time to offer, but maybe I can do something useful for the next releases. But this can't be reporting bugs, since open bugs weren't enough to stop the adoption of a clearly broken package in this case.

On a more useful front, I tried to compile kdebluetooth from beta8, and I wasn't able to continue. It seems the autoconf (arrrrgh) script searches for an older version of dbus than the 7.10-shipped one (searches for dbus/connection.h but I have /usr/include/dbus-1.0/dbus/dbus-connection.h).

The kdebluetooth website seems to be "in a flux" (just migrated and registration doesn't work...). I'll maybe try svn to get a maybe newer and hopefully working version.

Ciao,
   Roberto

Tomasz Czapiewski (xeros) wrote :

It's very annoying that the bug with file receiving over obex protocol on bluetooth doesn't work in Gutsy. Why haven't you backport kdebluetooth from hardy to gutsy? It's over two months from this bug report. If you don't want to backport the hardy version you can just apply a fix from hardy to gutsy version and release it as update/fix. For me one one of the main reasons for migration to gutsy from dapper was better bluetooth services handling and I'm disappointed with that. I know that there may appear some bugs in the stable release as some of them can't be catched before release but they should be fixed as soon as it's possible. Too bad my network connection is so slow (28kbps dial-up). If it were better I'd probably build a fixed package for that.

Tomasz Czapiewski (xeros) wrote :

I have forced install of kdebluetooth_1.0~beta9~r734866-0ubuntu6_i386.deb and libkbluetooth0_1.0~beta9~r734866-0ubuntu6_i386.deb packages from hardy on gutsy and it works without problems now but I have unsatisfied dependencies forced - both packages wanted kdelibs4c2a (>= 4:3.5.8-1) but gutsy has 4:3.5.8-0ubuntu3.1. It can be other temporary workaround for those who can't or don't want to compile kdebluetooth from sources.

(I'm posting this in this bug report as well, since more people can be interested)

I have quickpackaged the file uqbar linked to and it works fine for me, I can send files to my computer which was something I couldn't do before.

You can find the package at
http://peppesbodega.nu/files/Packages/kdebluetooth_1.0-beta8-0quickpackage_i386.deb
it's made for kubuntu 7.10, 32-bit. You have to uninstall libkbluetooth0 before you can install my package (don't know what it should be called really).
After the installation you'll find the kde bluetooth server at K-menu->Settings

Uqbar (uqbar) wrote :

Il Saturday 08 December 2007 22:01:12 Tomasz Czapiewski ha scritto:
> It's very annoying that the bug with file receiving over obex protocol
> on bluetooth doesn't work in Gutsy. Why haven't you backport
> kdebluetooth from hardy to gutsy? It's over two months from this bug
> report. If you don't want to backport the hardy version you can just
> apply a fix from hardy to gutsy version and release it as update/fix.
> For me one one of the main reasons for migration to gutsy from dapper
> was better bluetooth services handling and I'm disappointed with that. I
> know that there may appear some bugs in the stable release as some of
> them can't be catched before release but they should be fixed as soon as
> it's possible. Too bad my network connection is so slow (28kbps dial-
> up). If it were better I'd probably build a fixed package for that.

I have no idea on how to "backport" things. I can jusr compile and fix.
I am not a KUbuntu developer but just a user.
If I am provided with the right infos, I could also send a "backported"
package.

--
Reg me, please!

Ivo Mans (ivomans) wrote :

Thanks Peppelorum! Your package solved the problem for me.

Hans van Dok (dok) wrote :

Agree with Ivo. Nice one, peppelorum.

As I use AMD64 architeture and as I don't like compiling either, I went to the debian page and downloaded the file kdebluetooth_1.0~beta8-2_amd64.deb directly.

I did

[quote]
$ sudo dpkg -i kdebluetooth_1.0~beta8-2_amd64.deb[quote]

and it worked nicely after it.

I don't understand why can't this package be incorporated in Gutsy repositories.

on Mandriva 2008.0, after compiling, same problem

My Nokia phone don't "see" my laptop even if I send the "hciconfig hci0 piscan" command

Suggestion ?

confirming that peppelorum's deb fixed my issue.

STaRMaN (jarizaro) wrote :

PERFECT peppelorum !, works for me too. Thanks a lot! :)
When this package in repositories?

mrvanes (mrvanes) wrote :

For the brave:
- extract peppelorum's quickpackage (dpkg -x [deb] [target dir])
- create /usr/lib/kdebluetooth/servers directory (mkdir -p /usr/lib/kdebluetooth/servers as root)
- copy [target dir]/usr/lib/kdebluetooth/servers/kbtobexsrv to /usr/lib/kdebluetooth/servers (as root)

Uqbar (uqbar) wrote :

What I can argue from all the things reported above, especially the ones regarding the peppelorum "fix", is that the guys in charge for this "bug" are sleeping tight.
Packaging problem need minutes to fix, especially if someone else already identifiled the problem, found the fix, did the tests.

giorgosts (tsipoti) wrote :

Latest version is 1.0_beta8 at http://sourceforge.net/project/showfiles.php?group_id=89888 Except the packages listed above you'll need the bluez-utils package.

Taomyn (taomyn+launchpad) wrote :

Thanks peppelorum, this fixes the same issue for me.

And *nix people have the nerve to complain when Microsoft won't fix simple things in Windows - no wonder Linux keeps being shunned for the desktop by the general public.

We have a fix why the feck not put it into production!?!?!?!?!

I can confirm the problem is today still present on Gutsy AMD64.

Also I can confirm that the problem can be "fixed" by installing current Debian Testing package kdebluetooth_1.0~beta8-3_amd64.deb (from http://ftp.fi.debian.org/debian/pool/main/k/kdebluetooth/kdebluetooth_1.0~beta8-3_amd64.deb).

However to install package I must force dependencies from requirements to warnings:
dpkg --force-depends -i kdebluetooth_1.0~beta8-3_amd64.deb

dpkg: kdebluetooth: dependency problems, but configuring anyway as you request:
 kdebluetooth depends on kdelibs4c2a (>= 4:3.5.8-1); however:
  Version of kdelibs4c2a on system is 4:3.5.8-0ubuntu3.3.
 kdebluetooth depends on libc6 (>= 2.7-1); however:
  Version of libc6 on system is 2.6.1-1ubuntu10.

btw this is on Kubuntu rather than Ubuntu, in case that makes a difference.

erlguta (gonzalomarcote) wrote :

I think this situation is pathetic. Throughout the life of Gutsy there is not has been solved this "easy" bug. This gives an indication of the importance that give developers from Ubuntu to the Kubuntu distribution. People like peppelorum have solved this bug and in February 14, 2008 nobody from the Kubuntu team has shown signs of life to solve this.
We are still waiting for one official solution!

PD: Thank you peppelorum ;)

Martin Rusko (rusko) wrote :

Hi all,

relatively clean solution is to backport package from Hardy to Gutsy. Here is the procedure ...

1.) Preparation
mkdir $HOME/temp-build
cd $HOME/temp-build
sudo apt-get install build-essential
sudo apt-get build-dep kdebluetooth
sudo apt-get install wget fakeroot

2.) Visit http://packages.ubuntu.com/source/hardy/kdebluetooth

3.) Download three files from bottom of page (.dsc, .tar.gz, .diff.gz) into $HOME/temp-build directory
wget http://archive.ubuntu.com/ubuntu/pool/main/k/kdebluetooth/kdebluetooth_1.0~beta9~r769275-0ubuntu1.dsc
wget http://archive.ubuntu.com/ubuntu/pool/main/k/kdebluetooth/kdebluetooth_1.0~beta9~r769275.orig.tar.gz
wget http://archive.ubuntu.com/ubuntu/pool/main/k/kdebluetooth/kdebluetooth_1.0~beta9~r769275-0ubuntu1.diff.gz
Note: File versions can change, so please download current version.

4.) Building binary package
cd $HOME/temp-build
dpkg-source -x *.dsc
cd kdebluetooth-1.0~beta9~r769275 <-- Note: If versions changed, directory name is different
fakeroot dpkg-buildpackage -b -uc -us

You can watch how compilation goes now :-)

5.) Installation - there are *.deb files created after compilation in $HOME/temp-build directory
cd $HOME/temp-build
sudo dpkg -i *.deb

It might be needed to logout and login and it worked for me. Enjoy!

Martin

This bug occurs again on Hardy beta with latest updates. Can this bug be reopened, or should I file a new one?

Emanuel Goscinski (emu-) wrote :

@Sami Mäkinen,
are you sure it doesn`t works for you?
On my Laptop it works absolute flawlessly without any problems...

Well, after a lot of testing, reseting and rebooting, I can say the following:

- Sending a file via bt obex push from (Kubuntu) desktop worked
- ...but not always 100% reliably
- Sending via Nokia N95 did not work
- ...however seeing that push via desktop worked this might be the phone's problem
- There is definitely something odd. At one time, after disabling and enabling obex server, desktop found three obex servers on the laptop, and none of them could receive a file

I will test some more and try to get it both working reliably and to reliably repeat this odd behaviour.

Thanks for making me re-test though - at least I'm getting somewhere now :)

Okay, I have used test devices as such:
* Desktop running Kubuntu Gutsy AMD64 without hack-fix (see earlier comment)
* Laptop running WinXP
* UMPC dual-booting Kubuntu Hardy Current and WinVista, as well as booting off USB stick to an older version of Hardy Live CD
* Mobile running Symbian (Nokia N95)

And I see behavior like this:
* Desktop can send to UMPC/KubuntuHC
* Laptop can send to UMPC/KubuntuHC
* Mobile can send to Desktop
* Mobile can send to Laptop
* UMPC/Kubuntu can send to mobile
* Mobile can send to UMPC/WinVista
* Mobile cannot send to Desktop (original bug in Gutsy)
* Mobile can send to UMPC/KubuntuLiveCD (bug was fixed?)
* Mobile cannot send to UMPC/KubuntuHC (bug has reappeared?)

So: from the above I theoretize that the Obex server itself is running and working properly, but there is something wrong that is specific to how this Nokia phone is sending the BT Push message. It appears that the original problem has been fully fixed at some point, but after that has been partially re-broken. I tested also running UMPC/KubuntuHC as root, so that personal settings are not a factor. This did not help - still could not send the file.

I am also using the N95 as a dial-up modem, but for these tests I commented out the entry in /etc/bluetooth/rfcomm.conf and removed the trusted device pairing. This did not affect test results either.

One more note: upon sending the file, UMPC reports that the phone has connected, and then immediately the phone says that sending failed, but then the KDE Bluetooth icon remains lit for a few more seconds.

Soo... a weird incident specific to myself somehow, or a partial regression?

Naveen (naveenkhanna) wrote :

This problem still exists in Hardy RC with kdebluetooth version 1.0~beta9~r769275-0ubuntu1 when sending files from a Nokia 6600

Tested on a few cellphones:
Samsung D600: ok
Nokia N70: failed
SonyEricsson K750i: ok
Nokia 6230i: ok
Nokia 3230: failed
SonyEricsson P900: failed
Nokia 6680: failed
SonyEricsson T610: ok
Samsung Z500: ok on second attempt. First try caused a kernel panic...
Nokia 6111: ok
Samsung E250: ok

The pattern here seems to be that Kubuntu bluetooth cannot receive files over OBEX from Symbian devices, while all other systems work fine.

This is on:
bluez-utils 3.26-0ubuntu6
kdebluetooth 1.0~beta9~r769275-0ubuntu1
libbluetooth2 3.29-0ubuntu1
libkbluetooth 1.0~beta9~r769275-0ubuntu1

There is definitely a bug here, and it's not an isolated incident.

Can anyone successfully receive obex push from a Symbian device on Hardy RC?

Roberto Maurizzi (r-maurizzi) wrote :

I confirm the problem with a just-upgraded kubuntu 8.04 RC: I can't send bt files via obex FROM the phone (Nokia E65 and Nokia E61) to the computer.

That said, the problem isn't the one this bug is about: /usr/lib/kdebluetooth/servers/kbtobexsrv is present, and the computer can connect to the phone and download files.

The problem, as Sami said, is in object push from (at least) Symbian phones.

There's nothing in the syslog or on the phone about the error.

Ciao,
   Roberto

hmm, should this bug be closed and left alone, and a new bug report opened regarding symbian support with perhaps a reference to this one? Especially since this bug report already has a fix released.

ps; how can I send an image via obex bt push from a Motorola phone? I can't figure it out.. it can receive files over bt just fine.

Onkar Shinde (onkarshinde) wrote :

Sami,

Thanks a lot of detailed testing. I would like to redirect all to bug #211252 where people also have reported problem on hardy. This bug is unlike to get fixed on gutsy since a lot has changed since then and it is highly unlikely that the fix, when found, will be backported to gutsy.

Roberto Maurizzi (r-maurizzi) wrote :

@Onjar Shinde:

I agree in full that the new problem of not being able to receive files from Symbian devices is a new problem and should be tracked in a different bug.

But how can you say "This bug is unlike to get fixed on gutsy"??? Let me try to explain again the problem in gutsy: you people left out the obex server from the package!!! Someone also noticed it, released a "fix" for hardy ALPHA, then never backported it to Gutsy, then proceeded with upgrading the package to a new version on Hardy introducing another problem.

See here: https://bugs.launchpad.net/ubuntu/+source/kdebluetooth/+bug/146145/comments/15
* Fixed packaging, libkbluetooth0.install installs kbtobexsrv. Closes LP: #146145

So, I know now hardy is out, gutsy is old, etc, but *PLEASE* go fix this packaging bug in gutsy.

Pavel Mendl (pavel-mendl) wrote :

Just for those, who desperately read up to here: there is another easy workaround (at least in my KDE 3.5.9).

You do not need to push files one by one, if your phone supports obexftp protocol. But it is hidden in KDE. If you click on Bluetooth icon in the system tray, you probably get Konqueror opened with bluetooth:/ and icon of your mobile phone (where you normally see folders and files). Clicking on phone icon brings you to URL sdp:/[hexa id of your phone]/ showing no folders/files.

JUST REPLACE sdp: with obex: in the URL box, so that it reads obex:/[hexa id of your phone]/ and voila, you now see all folders/files allowed for bluetooth in your mobile and you can manipulate them as used to. (I had to manually set files in the phone as allowed for bluetooth before, luckily my phone allows "all in the folder" function.)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers