Please add supported filetypes into MimeType line of inkscape.desktop

Bug #278307 reported by Mantas Kriaučiūnas on 2008-10-04
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned
inkscape (Baltix)
Undecided
Unassigned
inkscape (Debian)
Fix Released
Unknown
inkscape (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: inkscape

Currently Inkscape isn't associated with lots of supported filetypes including compressed svg (svgz), PDF, Postscript (ps), Encapsulated Postscript (eps), Adobe illustrator (ai).
I've patched inkscape.desktop.in file from inkscape sources and added main supported filetypes into MimeType line.
Please add attached patch to allow opening supported filetypes directly from file manager.

Also don't forget to include update-desktop-database command in debian/postinst script.

Related branches

Hi,

i make an debdiff with your Patch included. Can you test if it works?

Changed in inkscape:
status: New → Confirmed
Bryce Harrington (bryce) on 2008-12-06
Changed in inkscape:
assignee: nobody → bryceharrington
David D Short (chameleondave) wrote :

This is affecting me in Kubuntu Intrepid (SVGs open in Inkscape by default, but only with .svg extensions, not with .svg.gz or .svgz). Will this patch help us KDE 4 users?

Hi,

This patch will help KDE3, KDE4, XFCE, GNOME, LXDE and all other desktop
environments, which follow freedesktop.org standarts :)

On Tue, Dec 09, 2008 at 02:05:09PM -0000, David D Short wrote:
> This is affecting me in Kubuntu Intrepid (SVGs open in Inkscape by
> default, but only with .svg extensions, not with .svg.gz or .svgz).
> Will this patch help us KDE 4 users?
>
> --
> [PATCH] Inkscape isn't associated with lots of supported filetypes - please add supported filetypes into MimeType line of inkscape.desktop

--
Labanaktis/Good luck,
Mantas Kriaučiūnas Jabber ID: <email address hidden> GPG ID: 43535BD5
Public organization "Open Source for Lithuania" - www.akl.lt

Version in Jaunty has all these now.

Changed in inkscape:
importance: Undecided → Unknown
status: New → Unknown
status: Confirmed → Fix Released
Changed in inkscape (Ubuntu):
status: Fix Released → New
Mantas Kriaučiūnas (mantas) wrote :

Inkscape in Ubuntu 9.04, 10.04 and even in Ubuntu 10.10 is associated only with svg and svgz files and still isn't associated with lots of supported filetypes including PDF, Postscript (ps), Encapsulated Postscript (eps), Adobe illustrator (ai) and Corel Draw (cdr), so I'm reopening this bug.

Bryce Harrington wrote on 2009-02-04:
> Version in Jaunty has all these now.

Bryce, you are not right - look at inkscape.desktop file in Ubuntu inkscape deb packages.

Alex Valavanis (valavanisalex) wrote :

Debian bug report refers to bash completion. This still needs to be forwarded.

Changed in inkscape (Debian):
importance: Unknown → Undecided
status: Unknown → New
Bryce Harrington (bryce) on 2010-09-14
Changed in inkscape (Ubuntu):
assignee: Bryce Harrington (bryceharrington) → nobody
summary: - [PATCH] Inkscape isn't associated with lots of supported filetypes -
- please add supported filetypes into MimeType line of inkscape.desktop
+ Please add supported filetypes into MimeType line of inkscape.desktop
tags: added: patch-forwarded-upstream
removed: pet-bug
Changed in inkscape:
importance: Undecided → Wishlist
Changed in inkscape (Debian):
importance: Undecided → Unknown
status: New → Unknown
Changed in inkscape:
status: New → Confirmed
Changed in inkscape (Ubuntu):
status: New → Confirmed
tags: added: packaging
Changed in inkscape:
status: Confirmed → Triaged
Changed in inkscape (Debian):
status: Unknown → Confirmed
Changed in inkscape (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in inkscape:
importance: Wishlist → Low
Alex Valavanis (valavanisalex) wrote :

This patch has now been applied in Debian, and will shortly be merged into Ubuntu. Any thoughts from upstream developers about including this?

Changed in inkscape (Debian):
status: Confirmed → Fix Released
jazzynico (jazzynico) wrote :

Patch committed in the trunk (revision 10056) and the 0.48.x branch (revision 9764)

Changed in inkscape:
milestone: none → 0.48.2
status: Triaged → Fix Committed
Alex Valavanis (valavanisalex) wrote :

@JazzyNico - Thanks very much :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.48.1-2ubuntu1

---------------
inkscape (0.48.1-2ubuntu1) natty; urgency=low

  * Merge with Debian unstable (LP: #719648, LP: #278307). Remaining changes:
  * debian/control:
    - Ubuntu maintainers
    - Promote python-lxml, python-numpy, python-uniconvertor to Recommends.
    - Demote pstoedit to Suggests (universe package).
  * debian/rules:
    - Run intltool-update on build (Ubuntu-specific).
    - Add translation domain to .desktop files (Ubuntu-specific)
  * debian/patches/01_add_unity_quicklist_support.patch:
    - add unity quicklist support for a new entry to inkscape (LP: #676886)

inkscape (0.48.1-2) unstable; urgency=low

  * upload to unstable (closes: #611626)
  * [d364fdc] link against libwpg0.2/libwpd0.9 (closes: 604825)
    Thanks to Rene Engelhard <email address hidden> for his work and the patch!
  * upload sponsored by Guido Guenther <email address hidden>
    Thank you very much!

inkscape (0.48.1-1) experimental; urgency=low

  * [f6250fa] Imported Upstream version 0.48.1
  * [e5b9206] remove debian/patches/01-end-drag-fix.dpatch since applied
    upstream
  * [2b6fb5b] add patch to fix shebang lines in extensions scripts
  * [f38e3e1] drop dependency upon ttf-bitstream-vera (closes: #597503)
  * [0a91fb1] binary depends on ${misc:Depends} as indicated by lintian
  * [02b4953] depend on libmagick++-dev instead of libmagick++9-dev
  * [ea095c3] Add supported mime types (closes: #596982)
 -- Alex Valavanis <email address hidden> Sun, 20 Feb 2011 12:07:30 +0000

Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
Ted Gould (ted) on 2011-09-07
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.