app-install-data-partner package is missing desktop and icon files

Bug #1005209 reported by Jonathan Thomas on 2012-05-27
42
This bug affects 5 people
Affects Status Importance Assigned to Milestone
app-install-data-partner (Baltix)
Critical
Mantas Kriaučiūnas
app-install-data-partner (Ubuntu)
Medium
Unassigned
Nominated for Precise by Mathew Hodson
Nominated for Trusty by Mathew Hodson
ubuntu-meta (Ubuntu)
Low
Unassigned
Nominated for Precise by Mathew Hodson
Nominated for Trusty by Mathew Hodson

Bug Description

[Impact]

* app-install-data-partner doesn't install any .desktop files, so the
  Canonical Partners sections in the Ubuntu Software Center and the Muon
  Software Center are empty.

[Test Case]

* Install app-install-data-partner

* Open Ubuntu Software Center

* In the software drop-down list, select Canonical Partners

[Regression Potential]

* The package hasn't been updated for Precise or Trusty, so any change would
  be positive.

Related branches

Changed in app-install-data-partner (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in app-install-data-partner (Baltix):
status: New → Fix Committed
assignee: nobody → Mantas Kriaučiūnas (mantas)
importance: Undecided → High
Mantas Kriaučiūnas (mantas) wrote :

I've fixed this important app-install-data-partner package bug, see lp:~baltix/ubuntu/precise/app-install-data-partner/fix-for-missing-applications-flashplugin-skype

New, fixed app-install-data-partner package for Ubuntu 12.04 LTS is available from official Baltix GNU/Linux distribution PPA:

http://launchpad.net/~baltix-members/+archive/ppa

Ubuntu developers, please merge my fixes and improvements to app-install-data-partner package for Ubuntu 12.04 LTS, which is completely broken (empty) in 12.04 LTS release. I've fixed several important bugs, including:
Bug #1005209 - Package empty (no desktop files) High Triaged
Bug #875683 - software center tries to install adobe-flashplugin:i386 even if amd64 environment

Also I've fixed desktop/skype.desktop - changed Exec line to "Exec=skype" instead "Exec=skype-wrapper", this problem exists even in Ubuntu 12.10 branch ( lp:ubuntu/quantal-proposed/app-install-data-partner )

tags: added: precise regression regression-release
summary: - Package empty (no desktop files)
+ [SRU] app-install-data-partner package in Ubuntu 12.04 LTS is empty (no
+ desktop and icon files)

The latest release of app-install-data-partner package (13.04) is totally broken in Ubuntu 14.04 and 13.10, please fix this package before 14.04 LTS is released.

summary: - [SRU] app-install-data-partner package in Ubuntu 12.04 LTS is empty (no
- desktop and icon files)
+ [Trusty] [SRU] app-install-data-partner package in Ubuntu 12.04 LTS and
+ 13.10 is empty (no desktop and icon files)
Changed in app-install-data-partner (Baltix):
status: Fix Committed → In Progress
importance: High → Critical
tags: added: trusty

There is another bugreport for broken app-install-data-partner in Ubuntu 14.04 LTS, see bug #1306894

summary: - [Trusty] [SRU] app-install-data-partner package in Ubuntu 12.04 LTS and
- 13.10 is empty (no desktop and icon files)
+ [Trusty] [SRU] app-install-data-partner package in Ubuntu 12.04 LTS,
+ 13.10 and 14.04 is empty (no desktop and icon files)
tags: removed: regression

I don't think it's useful for ubuntu-desktop to recommend app-install-data-partner.

affects: app-install-data-partner (Ubuntu) → robolinux
Changed in robolinux:
status: Triaged → Fix Released
assignee: nobody → MARK MORELOS (mightymouse777-777s)
Bryan Quigley (bryanquigley) wrote :

Does Ubuntu-meta need a fix too or can it be closed?

Changed in ubuntu-meta (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
affects: ubuntu-meta (Ubuntu) → app-install-data-partner (Ubuntu)
affects: app-install-data-partner (Ubuntu) → ubuntu-meta (Ubuntu)
Changed in ubuntu-meta (Ubuntu):
importance: Medium → Low
status: Triaged → Confirmed
Changed in robolinux:
assignee: MARK MORELOS (mightymouse777-777s) → nobody
affects: robolinux → app-install-data-partner (Ubuntu)
Changed in app-install-data-partner (Ubuntu):
status: Fix Released → Triaged
importance: High → Medium
Mathew Hodson (mathew-hodson) wrote :

Bryan Quigley, I added the ubuntu-meta task, because ubuntu-desktop currently recommends app-install-data-partner, but that package doesn't look like it's ever going to be updated.

summary: - [Trusty] [SRU] app-install-data-partner package in Ubuntu 12.04 LTS,
- 13.10 and 14.04 is empty (no desktop and icon files)
+ app-install-data-partner package is missing desktop and icon files
description: updated
tags: added: wily xenial
Mathew Hodson (mathew-hodson) wrote :

This is also affecting the new gnome-software package in Bug #1578473

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers