No right button on touchpad on HP ProBook 4720s

Bug #710335 reported by George Shuklin
This bug affects 9 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Won't Fix

Bug Description

Binary package hint: xserver-xorg-input-synaptics

Touchpad on HP ProBook 4720s (and as far as I know many other HP ProBooks) use a single button, it detects 'left' or 'right' button pressed by position where touchpad was touched.

Windows and proprientary driver distinct right click from left, but current does not.

Right now HP ProBook 4720s have only proprientary drivers for 2.6.32, with module for X-server, wich crash server if used by force.

I believe implement left/right click-detection is not very hard...

Here dmesg data for synaptic touchpad:

Synaptics Touchpad, model: 1, fw: 7.4, id: 0x1e0b1, caps: 0xd04771/0xe40000/0x5a0400

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xorg 1:7.5+6ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-25.44-generic
Uname: Linux 2.6.35-25-generic i686
NonfreeKernelModules: fglrx wl
Architecture: i386
Date: Sun Jan 30 23:28:30 2011
 bcmwl,, 2.6.35-25-generic, i686: installed
 fglrx, 8.801, 2.6.35-25-generic, i686: installed
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
MachineType: Hewlett-Packard HP ProBook 4720s
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-25-generic root=UUID=f7e5864d-5779-4ff2-b0be-7e05ee2a588d ro quiet splash single
SourcePackage: xorg
Symptom: display 01/12/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68AZZ Ver. F.01 1411
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 57.17
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68AZZVer.F.01:bd01/12/2010:svnHewlett-Packard:pnHPProBook4720s:pvr:rvnHewlett-Packard:rn1411:rvrKBCVersion57.17:cvnHewlett-Packard:ct10:cvr: HP ProBook 4720s
dmi.sys.vendor: Hewlett-Packard
glxinfo: Error: [Errno 2] Нет такого файла или каталога
 distro: Ubuntu
 codename: maverick
 architecture: i686
 kernel: 2.6.35-25-generic

Revision history for this message
George Shuklin (george-shuklin) wrote :
Revision history for this message
Gursimran singh (simar) wrote :

I think this functionality can be better integrated in kernel rather that synaptics driver as per the concepts of software layering.

Changed in xserver-xorg-input-synaptics (Ubuntu):
importance: Undecided → Low
affects: xserver-xorg-input-synaptics (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Low → Wishlist
Revision history for this message
Stant (stant) wrote :

By the way, it worked in 10.04 before I've upgraded to 10.10.

Revision history for this message
splashis (splashote) wrote :

Did anyone solve this issue with workarounds?
I'm thinking about buying one and I am trying to figure out what problems I have to solve when using Ubuntu on it.

Do you got any other problems?

Revision history for this message
Stant (stant) wrote :

> splashis

In 10.04 there was a problem with a screen brigthness control via keyboard keys. Touchpad and other things worked well. In 10.10 the brigthness problem was solved, but touchpad has lost ability to handle righclick. Also wi-fi key on keyboard now works just as indicator (can't switch on/off wi-fi). I have not noticed any other problems.

Revision history for this message
Anton Statutov (astatutov) wrote :

Ubuntu 11.04 still have this bug.

Revision history for this message
George Shuklin (george-shuklin) wrote :

I think, it happens in drivers/input/mouse/synaptics.c file.

We have this code in linux-2.6.32:

 if (SYN_CAP_CLICKPAD(priv->ext_cap))
  clickpad_process_packet(priv, &hw);

(and big clickpad_process_packet function)

and now we have no this lines (in linux-2.6.38). I don't understand why they was removed, I'll try to bisect changes in vanilla tree...

Revision history for this message
Ru_Grey (linux-cool) wrote :

bug exists in 11.04. need to fix

Revision history for this message
Anton Statutov (astatutov) wrote :

This problem caused by dropped support of ClickZone in
It was dropped as a result of bug #669399 so clickpads (touchpads w/o separated buttons) now work as usual touchpads .

I believe this bug is not duplicate of bug #527890 and it's was incorrectly marked as such. In contrast to the description of that bug the touchpad are successfully recognized on my HP ProBook 4720s, also there is appropriate configuration tab for it. But still any click on touchpad are recognized as a left click, so there is no possibility to produce a right click.

Revision history for this message
Anton Statutov (astatutov) wrote :
Brad Figg (brad-figg)
Changed in linux (Ubuntu):
status: New → Confirmed
Revision history for this message
শরীফ আহম্মেদ (sa-mollick) wrote :

I have got my solution by installing driver provided by hp. plz have this link for the deb file I have installed.--

Revision history for this message
Joseph Salisbury (jsalisbury) wrote : Unsupported series, setting status to "Won't Fix".

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
Revision history for this message
Martin Daser (m4rt1n-d453r) wrote :

I found out accidentally ... it works for me, probably since the update to 12.10.
I can either tap in or press the lower right corner of the clickpad and get the required action, i.e. a pop up menue on the desktop or in the browser.

Just wanted to mention it.

Revision history for this message
Anton Statutov (astatutov) wrote :

I'm confirming it now works on 12.10 as Martin have said.

It's amusingly when something is starting to work just after bug was marked as "won't fix" )

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.