[needs-packaging] LibreOffice Productivity Suite

Reported by Fabián Rodríguez on 2010-09-29
204
This bug affects 36 people
Affects Status Importance Assigned to Milestone
LibreOffice Productivity Suite
Invalid
Undecided
Unassigned
OpenOffice
Invalid
Undecided
Unassigned
Baltix
Undecided
Unassigned
libreoffice (Ubuntu)
Wishlist
Matthias Klose
Natty
Wishlist
Matthias Klose

Bug Description

Package name : libreoffice
Version : 3.3
URL : http://www.libreoffice.org/
License : LGPLv3
Description : (from openoffice.org package, perhaps should be adapted)

LibreOffice is a full-featured office productivity suite that provides a near drop-in replacement for Microsoft(R) Office.
 .
 This metapackage installs all components of LibreOffice:
  * libreoffice-writer: Word processor
  * libreoffice-calc: Spreadsheet
  * libreoffice-impress: Presentation
  * libreoffice-draw: Drawing
  * libreoffice-base: Database
  * libreoffice-math: Equation editor
  * libreoffice-filter-mobiledev: Mobile Devices filters
  * libreoffice-filter-binfilter: legacy filters (e.g. StarOffice 5.2)
 .
 You can extend the functionality of LibreOffice by installing these packages:
  * hunspell-dictionary-*/myspell-dictionary-*: Hunspell/Myspell dictionaries for use with LibreOffice
  * libreoffice-l10n-*: UI interface translation
  * libreoffice-help-*: User help
  * libreoffice-thesaurus-*: Thesauri for the use with LibreOffice
  * libreoffice-hyphenation-*: Hyphenation patterns for LibreOffice
  * libreoffice-gtk: Gtk UI Plugin, GNOME File Picker support, QuickStarter for GNOMEs notification area
  * libreoffice-gnome: GNOME VFS, GConf backend
  * libreoffice-kde: KDE UI Plugin and KDE File Picker support
  * menu: Will add LibreOffice menu entries for every Debian window manager.
  * unixodbc: ODBC database support
  * cups-bsd: Allows LibreOffice to detect your CUPS printer queues automatically
  * libsane: Use your sane-supported scanner with LibreOffice
  * libxrender1: Speed up display by using Xrender library
  * libgl1: OpenGL support
  * openclipart-libreoffice.org: Open Clip Art Gallery with LibreOffice index files
  * iceweasel | firefox | icedove | thunderbird | iceape-browser | mozilla-browser:
    Mozilla profile with Certificates needed for XML Security...
  * openjdk-6-jre | gcj-jre | java5-runtime:
    Java Runtime Environment for use with LibreOffice
  * pstoedit / imagemagick: helper tools for EPS thumbnails
  * gstreamer0.10-plugins-*: GStreamer plugins for use with LibreOffice's media backend
  * libpaper-utils: papersize detection support via paperconf
  * libldap-2.4-2: LDAP client library; needed for LibreOffice getting its profiles from LDAP

Source code, RPM and .Deb packages for 32-bit and 64-bit systems are available here:
http://www.libreoffice.org/download/

tags: added: needs-packaging
description: updated
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

Changed in ubuntu:
importance: Undecided → Wishlist
Christian A. Reiter (droetker) wrote :

I think LibreOffice should be the default in Ubuntu 11.04 instead of OpenOffice.

Artem Vorotnikov (skybon) wrote :

@2
It _will_ actually be default in Natty Narwhal.

AsstZD (eskaer-spamsink) wrote :

Why should we package beta software, which fully duplicates functionality of go-oo?

Fabián Rodríguez (magicfab) wrote :

@AsstZD because we want an easy and safe way to install it to try it. Otherwise most users wanting to try it may break their existing install. We also want a maximum of testers before our next release is out.

Artem Vorotnikov (skybon) wrote :

@4 because LO will be in Natty anyway.

Linux Lover (obake) wrote :

I do not believe that Libre Office should be the default for (K)Ubuntu since it is still a Beta software from what I read.
It should be packaged so that we could test it.

Eric Appleman (erappleman) wrote :

What's the timeframe for LibreOffice? Alpha 2?

Fabián Rodríguez (magicfab) wrote :

A new job opening has been up for some weeks on Ubuntu's web site:
http://webapps.ubuntu.com/employment/canonical_UP-SE-RS2/

It indicates "[...] The successful candidate will ensure a first class user experience by envisioning new desktop integration features for office productivity, packaging, desktop integration, bug fixing and development of office productivity related software such as Open Office. [...] Required skills & Experience: [...] - Strong interests and experience with Open Office and/or other Open Source office productivity software packages. [...]"

Presumably this same person will take care of LibreOffice packaging. I can't speak for Canonical as I am not involved in packaging or hiring such resources (and wasn't, when I worked for them).

The current release is not alpha but a release candidate 3.3.0-rc1 which I have been using for some weeks now and installs cleanly besides OpenOffice.org without conflicts that I could see in my limited use of Writer and Impress. I also tested language packs: logging into different language sessions brought the corresponding language LO apps when invoked, as expected.

I downloaded directly from http://download.documentfoundation.org/libreoffice/testing/.

Fabián Rodríguez (magicfab) wrote :

@AsstZD FWIW, if you need a stable version, you should keep 10.10 as long as possible or stick to 10.04 LTS. IMHO LibreOffice should be default ASAP so it gets maximum exposure and testing before our next LTS.

Matthias Klose (doko) wrote :

LO will be in natty, however I cannot assure that it will be for alpha2. alpha3 is more realistic. The current OOo packaging needs to be merged (unfortunately non-trivial) before an upload to natty.

Changed in ubuntu:
assignee: nobody → Matthias Klose (doko)
milestone: none → natty-alpha-3
status: New → In Progress
Matthias Klose (doko) wrote :
tags: added: lo33
removed: needs-packaging
druido77 (druido77) wrote :

where can I file new bugs about LibreOffice packages available on ppa repository? There are some issue with toolbars in LibreOffice Base...

On 05.01.2011 21:37, druido77 wrote:
> where can I file new bugs about LibreOffice packages available on ppa
> repository? There are some issue with toolbars in LibreOffice Base...

use https://launchpad.net/ubuntu/+filebug
don't add any package name and tag the report with `lo33'.

harrykar (harrykar) wrote :

I'm not sure if that's the right place to report a LibreOffice installation problem. anyway i use Ubuntu 10.04 and when i try install LibreOffice from your PPA i obtain
"E: /var/cache/apt/archives/libreoffice-common_1%3a3.3.0~rc2-3lucid1_all.deb: trying to overwrite '/etc/bash_completion.d/ooffice.sh', which is also in package openoffice.org-common 1" as you can see in Screenshot.png

harrykar (harrykar) wrote :

Ok in a second try i purge manually some packages of openoffice like thesaurus, hypenation etc.(seems that Libreoffice not wipe all OO packages). Now LibreOffice install go like a sharm

I installed Libreoffice from PPA in Ubuntu 10.10 and now I can't get Slovenian dictionary to work. I reinstalled the myspell-sl package just in case but that didn't work either. When I press F7 I only get the "Spellchecking complete" message and the language drop-down list seems to be empty.

Fabián Rodríguez (magicfab) wrote :

@Grega, @harrykar as Matthias indicated above, please file a separate bug using the "lo33" tag for such issues. The current list of related issues is here:
https://bugs.launchpad.net/ubuntu/+bugs?field.tag=lo33

- Use this form to file such bugs: https://launchpad.net/ubuntu/+filebug
- Don't add any package name and tag the report with `lo33'

I tried Alt+f2 -> ubuntu-bug -> Other problem but then I got an error saying that PID is required.

Fabián Rodríguez (magicfab) wrote :

LIbreOffice 3.3 Release Candidate 3 is now available:
http://blog.documentfoundation.org/2011/01/13/libreoffice-3-3-release-candidate-3-available/

I have updated this bug's original description and links to reflect the new information.

description: updated
Matthias Klose (doko) on 2011-01-19
affects: Ubuntu Natty → libreoffice (Ubuntu Natty)
Linux Lover (obake) wrote :

LibreOffice RC4 has been released 3 days ago (2011-01-20). Release notes can be found at

1) http://www.libreoffice.org/download/release-notes/

2)Detailed notes:
 http://cgit.freedesktop.org/libreoffice/build/plain/NEWS?id=libreoffice-3.3.0.4

******

I am very happy to know that LibreOffice will be the default office suit for Ubuntu Natty.
Thank you everyone!

Fabián Rodríguez (magicfab) wrote :

Bug # 712725 has been filed about the libreoffice-extension-nlpsolver being missing from the LibreOffice packages. It is available from libreoffice.org in the .debs install archive, as libobasis3.3-extension-nlpsolver - NLPSolver extension for LibreOffice 3.3

description: updated

closing on LibreOffice and OpenOffice products as packaging is only related to distributions.

Changed in df-libreoffice:
status: New → Invalid
Changed in openoffice:
status: New → Invalid
Juan Carlos Donoso (jdonoso) wrote :

When can we expect an update to version 3.4.3?

Best regards

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments